Bug 59569 - GUI install hangs with trident Cyberblade
GUI install hangs with trident Cyberblade
Status: CLOSED DUPLICATE of bug 64397
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 14:29 EST by Chris Ricker
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-25 12:44:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from beta3 X startup (7.25 KB, text/plain)
2002-03-21 00:24 EST, Chris Ricker
no flags Details
working XF86 4.2 config file -- automatically generated during install (3.71 KB, text/plain)
2002-03-26 21:58 EST, Chris Ricker
no flags Details
log from working XFree86 4.2 startup (38.01 KB, text/plain)
2002-03-27 23:16 EST, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2002-02-10 14:29:14 EST
I have a Compaq laptop with a Trident CyberBlade chipset.  When booting off of
CD-ROM, anaconda starts, detects the correct video chipset and fails detecting
the display (as expected -- it's a laptop) so falls back to generic.

After that, the screen goes black while starting X and the console is completely
locked.  VCs cannot be switched.

Now I'm going to try forcing a text install
Comment 1 Chris Ricker 2002-02-10 14:31:02 EST
Same results with lowres.  Anaconda starts, box locks starting X
Comment 2 Chris Ricker 2002-02-10 14:35:18 EST
same results with nofb, and when forcing 1024x768x8bit
Comment 3 Chris Ricker 2002-02-10 17:28:41 EST
FWIW, after a text-mode upgrade completed, XFree86 4.2 worked with the video
card, so it's not a matter of the Trident simply being unsupported by RH.
Comment 4 Michael Fulbright 2002-02-11 11:01:35 EST
What are the PCI ids for the video card?
Comment 5 Chris Ricker 2002-02-11 21:57:42 EST
pci bus 0x0001 cardnum 0x00 function 0x00: vendor 0x1023 device 0x8420
 Trident CyberBlade/DSTN/i7
 CardVendor 0x0e11 card 0xb15a (Compaq, Card unknown)
  STATUS    0x02b0  COMMAND 0x0207
  CLASS     0x03 0x00 0x00  REVISION 0x5d
  BIST      0x00  HEADER 0x00  LATENCY 0x40  CACHE 0x00
  BASE0     0xf5000000  addr 0xf5000000  MEM
  BASE1     0xf4100000  addr 0xf4100000  MEM
  BASE2     0xf4800000  addr 0xf4800000  MEM
  MAX_LAT   0x00  MIN_GNT 0x00  INT_PIN 0x01  INT_LINE 0x09
Comment 6 Chris Ricker 2002-03-07 21:29:27 EST
This is still broken in beta2, though it looks slightly different (progress? ;-).

linux switches to graphical mode, turns the screen mottled white (like when you
overdrive an LCD), and is hung.

This happens regardless of which options I use to boot
Comment 7 Chris Ricker 2002-03-07 21:31:06 EST
Forgot to change the version....
Comment 8 Chris Ricker 2002-03-21 00:24:32 EST
Created attachment 49327 [details]
log from beta3 X startup
Comment 9 Chris Ricker 2002-03-21 00:26:08 EST
Still broken in beta3....
Comment 10 Michael Fulbright 2002-03-26 20:21:44 EST
Do you have an X configuration that works on this card, and if so please tell me
the X server driver and attach the X config file?
Comment 11 Chris Ricker 2002-03-26 21:57:06 EST
With 3.3.6 on older RH releases, it used the XFree86_SVGA driver.  I don't still
have an XF86Config file around from that.

In the beta cycles, 4.2.0 has been working just fine with it (first version of
XFree86 4 to do so; 4.1 was supposed to support it, but I never could get RH 7.2
to drive it using anything except 3.3.6).

XF86Config-4 will be attached.
Comment 12 Chris Ricker 2002-03-26 21:58:17 EST
Created attachment 50764 [details]
working XF86 4.2 config file -- automatically generated during install
Comment 13 Michael Fulbright 2002-03-27 17:28:08 EST
I noticed the working config is using 1152x864 - is this the resolution of the LCD?
Comment 14 Chris Ricker 2002-03-27 23:07:00 EST
Actually, the config file lists 1152x864, but it's running at 1024x768. 
Bizarre, but what anaconda put on the disk worked so I've not monkeyed with it....

With 3.3.6 on RH <= 7.2, I ran this machine at 1024x768 as well.
Comment 15 Chris Ricker 2002-03-27 23:14:43 EST
I just changed the config to 1024x768 -- thanks for pointing that out.

Attached will be the log from it working with 4.2.0 on beta3, running at
1024x768, in case the video mode info from that will be useful.
Comment 16 Chris Ricker 2002-03-27 23:16:04 EST
Created attachment 51064 [details]
log from working XFree86 4.2 startup
Comment 17 Chris Ricker 2002-04-04 03:20:42 EST
Still true with beta4.  Text install works, graphic locks the screen, X works
after install
Comment 18 Michael Fulbright 2002-04-15 17:24:16 EDT
I have not been able to locate this hardware unfortunately.
Comment 19 Chris Ricker 2002-06-07 21:45:09 EDT
Closed, since #64397 became the same as this, with a potential solution

*** This bug has been marked as a duplicate of 64397 ***

Note You need to log in before you can comment on or make changes to this bug.