Bug 64397 - graphical install fails with Cyberblade chipset
graphical install fails with Cyberblade chipset
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 59569 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-03 11:55 EDT by Chris Ricker
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-07 21:45:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-05-03 11:55:32 EDT
Attempting to do a text-mode install from NFS images sometimes crashes (great! a
heisenbug! ;-) with the following error:

Probing for mouse type: Generic - 3 Button Mouse (PS/2)
Traceback (innermost last):
  File "/usr/bin/anaconda", line 551, in ?
   method = NfsIsoInstallMethod(method[8:], intf.messageWindow)
  File "/usr/lib/anaconda/image.py", line 264, in __init__
   self.discImages = findIsoImages(tree, messageWindow)
  File "/usr/lib/anaconda/image.py", line 206, in findIsoImages
   "installer (RECOMMENDED). " % file, type = "okcancel")
  File "/usr/lib/anaconda/image.py", line 264, in messageWindow
   return OkCancelWindow(self.screen, title, text)
  File "/usr/lib/anaconda/image.py", line 117, in __init__
   buttons=[TEXT_OK_BUTTON, _("Cancel")])
  File "/usr/lib/python1.5/site-packages/snack.py", line 547, in
ButtonChoiceWindow
   t = TextboxReflowed(width, text, maxHeight = screen.height - 12)
AttributeError: 'None' object has no attribute 'height'
install exited abnormally

I don't see this if I try graphical installs from the same NFS server
(though this machine cannot successfully do graphical installs; those hang
when the X server is started, since anaconda starts it in an unsupported
resolution and that bug's still not fixed with 7.3)

This doesn't appear to be due to incorrect ISO images -- install sometimes
succeeds, and all images have the correct MD5 checksums:

[root@spazzim iso]# md5sum *.iso
cb91810ce8173039fed24420407e4c59  Valhalla-i386-disc1.iso
ec1b813d32ffdc8edc2be261735d17de  Valhalla-i386-disc2.iso
5dc81ce523cfddf99b4d4d63e91bcaa7  Valhalla-i386-disc3.iso
c9a4d963a49e384e10dec9c2bd49ad73  Valhalla-i386-disc4.iso
41b03d068e84d2a17147aa27e704f79b  Valhalla-i386-disc5.iso
58caad7d93b06c1c0e2af1ce2111a4ae  docs-7.3-i386.iso
b5e24c1043cc190a0fe8a6fa559e7842  lacd-7.3-Productivity.iso
67779193951f92b887f98d9305c39d12  lacd-7.3-Server.iso
c13f08b5b52d6a8f7a27edeb3287ebe8  rescue-cd-7.3.iso
[root@spazzim iso]#
Comment 1 Michael Fulbright 2002-05-03 12:33:58 EDT
Have you tried the 'resolution=<width>x<height>' flag at boot time to force the
video mode for graphical install?

I'm guessing there aren't any interesting errors on VC4?
Comment 2 Chris Ricker 2002-06-06 23:52:58 EDT
(summary changed to reflect the bug this has become about)

Good job!  Adding

resolution=1024x768

works with 7.3

Is this something can be forced automatically in future releases (I've not
gotten to try Milan on this machine yet, so I can't say what it does), or should
I just remember to do that always for this machine?
Comment 3 Chris Ricker 2002-06-07 21:42:15 EDT
*** Bug 59569 has been marked as a duplicate of this bug. ***
Comment 4 Michael Fulbright 2002-06-11 23:21:01 EDT
I don't know of any way to detect this situation. It would be nice if X could do
the right thing for us.

Note You need to log in before you can comment on or make changes to this bug.