Bug 595728 - Complete submission interface
Complete submission interface
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: cumin (Show other bugs)
Development
All Linux
high Severity medium
: 1.3
: ---
Assigned To: messaging-bugs
Jan Sarenik
:
Depends On:
Blocks: 595746
  Show dependency treegraph
 
Reported: 2010-05-25 09:28 EDT by Justin Ross
Modified: 2010-10-20 07:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Ross 2010-05-25 09:28:45 EDT
* Work out user identity
* Use new qmf interfaces
* Validate extended attributes and transmit type information
* Add universe field
Comment 1 Jan Sarenik 2010-09-03 06:16:54 EDT
Please comment:

* User identity is not worked out AFAIU, Condor has to be configured with
  QUEUE_ALL_USERS_TRUSTED = TRUE

* That probably works (no user-visible change, if you can point me to
  the commit, I can review - e.g. SVN rev. 4038 seems to be one such).

* The validation is not so perfect yet (e.g. " " (i.e. space) can be
  supplied as an argument to Requirements field).

* Universe field is there.
Comment 2 Justin Ross 2010-09-07 11:54:38 EDT
Responses by point.

* By work out user identity, I was referring to something smaller in scope than solving qmf auth issues in general.  I consider this one completed.  Of course, you're correct about the needed configuration.

* No need to verify this one.

* Empty string validation is fixed in revision 4231.

* Agreed!
Comment 3 Jan Sarenik 2010-09-08 02:38:33 EDT
Verified using cumin-0.1.4219-1.el5

Note You need to log in before you can comment on or make changes to this bug.