Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 595785 - [abrt] crash in genesis-0.4.3-1.fc13: genesis.py:343:save_preference:AttributeError: 'NoneType' object has no attribute 'split'
[abrt] crash in genesis-0.4.3-1.fc13: genesis.py:343:save_preference:Attribut...
Status: CLOSED DUPLICATE of bug 588630
Product: Fedora
Classification: Fedora
Component: genesis (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Andrea Musuruane
Fedora Extras Quality Assurance
abrt_hash:9d9b7e37
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-25 11:35 EDT by John Margaritopoulos
Modified: 2010-05-30 15:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-30 15:04:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (499 bytes, text/plain)
2010-05-25 11:35 EDT, John Margaritopoulos
no flags Details

  None (edit)
Description John Margaritopoulos 2010-05-25 11:35:21 EDT
abrt 1.1.0 detected a crash.

architecture: i686
cmdline: /usr/bin/python /usr/bin/genesis
component: genesis
executable: /usr/bin/genesis
kernel: 2.6.33.4-95.fc13.i686
package: genesis-0.4.3-1.fc13
reason: genesis.py:343:save_preference:AttributeError: 'NoneType' object has no attribute 'split'
release: Fedora release 13 (Goddard)

backtrace
-----
genesis.py:343:save_preference:AttributeError: 'NoneType' object has no attribute 'split'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/Genesis/genesis.py", line 343, in save_preference
    widget_type, name = widget.name.split('_', 1)
AttributeError: 'NoneType' object has no attribute 'split'

Local variables in innermost frame:
widget: <gtk.SpinButton object at 0x9afc5f4 (GtkSpinButton at 0x9c3c018)>
self: <Genesis.genesis.PreferencesDialog object at 0x9af5cec>
Comment 1 John Margaritopoulos 2010-05-25 11:35:23 EDT
Created attachment 416440 [details]
File: backtrace
Comment 2 Andrea Musuruane 2010-05-25 11:48:23 EDT
It seems to me that this is a duplicate of #588630 even though it happened in a different part of code. 

Can you please tell me how you reproduced this bug?
Comment 3 Andrea Musuruane 2010-05-30 15:04:12 EDT

*** This bug has been marked as a duplicate of bug 588630 ***

Note You need to log in before you can comment on or make changes to this bug.