Bug 588630 - [abrt] crash in genesis-0.4.2.1-3.fc13: genesis.py:338:save_preference:AttributeError: 'NoneType' object has no attribute 'split'
[abrt] crash in genesis-0.4.2.1-3.fc13: genesis.py:338:save_preference:Attrib...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: genesis (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Andrea Musuruane
Fedora Extras Quality Assurance
abrt_hash:c755db49
:
: 595785 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-04 02:58 EDT by Blonďák
Modified: 2010-06-25 14:08 EDT (History)
3 users (show)

See Also:
Fixed In Version: genesis-0.4.3-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-25 14:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (499 bytes, text/plain)
2010-05-04 02:58 EDT, Blonďák
no flags Details

  None (edit)
Description Blonďák 2010-05-04 02:58:15 EDT
abrt 1.0.9 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/genesis
component: genesis
executable: /usr/bin/genesis
kernel: 2.6.33.2-57.fc13.x86_64
package: genesis-0.4.2.1-3.fc13
reason: genesis.py:338:save_preference:AttributeError: 'NoneType' object has no attribute 'split'
release: Fedora release 13 (Goddard)
How to reproduce: Open preferences and try check "Lanch on startup"

backtrace
-----
genesis.py:338:save_preference:AttributeError: 'NoneType' object has no attribute 'split'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/Genesis/genesis.py", line 338, in save_preference
    widget_type, name = widget.name.split('_', 1)
AttributeError: 'NoneType' object has no attribute 'split'

Local variables in innermost frame:
widget: <gtk.SpinButton object at 0x20b4a50 (GtkSpinButton at 0x1ef1050)>
self: <Genesis.genesis.PreferencesDialog object at 0x20bc0d0>
Comment 1 Blonďák 2010-05-04 02:58:17 EDT
Created attachment 411198 [details]
File: backtrace
Comment 2 Andrea Musuruane 2010-05-19 14:53:40 EDT
I cannot reproduce this bug on a F12/x86_64 and I have yet to get my hands on a machine with F13/x64_64. But AFAIK there should be no real difference between this two systems. Anyway it would be great if the reporter or some other user in CC can tell me if genesis crashes after the first start-up (with or without configuring a syncml provider?) and then checking the "launch at startup".

BTW, I updated genesis to the latest available upstream version. By now it should be available in stable. Can you please test it and tell me if you still have this bug?

Thanks!
Comment 3 Blonďák 2010-05-20 02:51:07 EDT
Package:    	genesis-0.4.3-1.fc13
Latest Crash:	Čt 20. květen 2010, 08:38:48 
Command:    	/usr/bin/python /usr/bin/genesis
Reason:     	genesis.py:343:save_preference:AttributeError: 'NoneType' object has no attribute 'split'

Back Trace:	

genesis.py:343:save_preference:AttributeError: 'NoneType' object has no attribute 'split'

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/Genesis/genesis.py", line 343, in save_preference
    widget_type, name = widget.name.split('_', 1)
AttributeError: 'NoneType' object has no attribute 'split'

Local variables in innermost frame:
widget: <gtk.SpinButton object at 0x150ba50 (GtkSpinButton at 0x1689030)>
self: <Genesis.genesis.PreferencesDialog object at 0x1514110>


Strange, I have tried newer version of genesis package, but still error when I try check Launch on startup in preferenes
Comment 4 Blonďák 2010-05-20 03:15:08 EDT
Another hint, I have also problems with syncevo-dbus-server and syncevolution (probably because dbus server segfaulting). I don't know if that errors can cause problem with genesis, but some time before syncevolutin works and genesis was unable set launch on startup. (For me its no problem add it manualy, but for novice users can...)
Comment 5 Andrea Musuruane 2010-05-30 15:04:12 EDT
*** Bug 595785 has been marked as a duplicate of this bug. ***
Comment 6 Andrea Musuruane 2010-05-30 15:12:01 EDT
I used a Live USB disk of Fedora 13 to understand the problems you reported. 

First of all there is a bug in syncevolution. It does no longer work in F13. I
opened bug #597739 for this issue.

Then it seems you found upstream bug #576559:
https://bugs.launchpad.net/genesis-sync/+bug/576559

If I apply the patch from upstream bazaar repository I no longer have the
issue. I'll try to build a new RPM for F13 and devel in the next days.
Comment 7 Fedora Update System 2010-06-10 13:48:32 EDT
genesis-0.4.3-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/genesis-0.4.3-2.fc13
Comment 8 Fedora Update System 2010-06-14 13:25:43 EDT
genesis-0.4.3-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update genesis'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/genesis-0.4.3-2.fc13
Comment 9 Fedora Update System 2010-06-25 14:08:44 EDT
genesis-0.4.3-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.