Bug 59598 - lock screen appears to log out
lock screen appears to log out
Status: CLOSED DUPLICATE of bug 62120
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-10 21:11 EST by Chris Ricker
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-22 00:16:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tar of .kde directory (60.00 KB, application/octet-stream)
2002-03-21 14:38 EST, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2002-02-10 21:11:00 EST
hampton beta1.  Selecting lock screen from the K menu as a normal user dumps the
user back to the KDM dialog screen, making it appear as if it logged the user out.

What it actually does is some bizarre combination of locking the screen and then
dump the user back to KDM.  At KDM, when the user logs back in, they actually
fire up a new X Server on a subsequent vt.  After trying to lock the screen a
couple of times, I wound up with:

/usr/X11R6/bin/X vt7 -auth /var/run/xauth/A:0-Lkepz7
/usr/X11R6/bin/X :1 vt8 -auth /var/run/xauth/A:1-q04CR0
/usr/X11R6/bin/X :2 vt9 -auth /var/run/xauth/A:2-Zw2llf

it took me a little bit to figure out what was going on.  I'm not sure if this
is a bug or if it's a new "feature" of KDE 3 (I can see it being useful for
common machines used by several people, for example), but it's definitely going
to cause confusion for a lot of people if it's the default.
Comment 1 Jay Turner 2002-03-19 14:46:16 EST
Not able to replicate this with the latest KDE 3 packages here in the office. 
Closing out.  Please reopen if the problem reemerges.
Comment 2 Ben Levenson 2002-03-20 11:02:26 EST
REOPENING -- though I don't really have much useful info to add to this report.
So far, this has happened to me about 50% of the time; once while manually locking
the screen, and once while letting the screen lock automatically.

currently running: kdebase-3.0.0-0.cvs20020314.4
Comment 3 Bernhard Rosenkraenzer 2002-03-21 05:09:27 EST
Never happens here. Please attach your .kde directory when this happens, might be some 
odd setting. 
Comment 4 Chris Ricker 2002-03-21 09:47:16 EST
I saw this on multiple systems with beta1, and on those systems it occurred
system-wide, not per user....

I'll see what I can find w/ beta3.
Comment 5 Chris Ricker 2002-03-21 14:37:29 EST
Just did a fresh install of beta3, starting up in runlevel 5 using kdm.

I added a user account (kaboom, o' course) during install.

After the system booted, I logged in as kaboom.  In the initial "Configuring
your environment" queries KDE does, I selected North America -> USA, and then on
the performance dialog I just dragged it all the way to the right (enabling
everything).

I then clicked lock screen.  It did the whole "spawn a new kdm on the next
console, lock the current console" thing.

Attached will be a tarball of my .kde directory.
Comment 6 Chris Ricker 2002-03-21 14:38:11 EST
Created attachment 49485 [details]
tar of .kde directory
Comment 7 Chris Ricker 2002-03-22 00:16:35 EST
It's doing the same thing on this install I just did as well.  Here, I didn't
change anything from the default configuration, other than language....
Comment 8 Bernhard Rosenkraenzer 2002-03-27 12:49:10 EST

*** This bug has been marked as a duplicate of 62120 ***

Note You need to log in before you can comment on or make changes to this bug.