Bug 596133 - Assertion when decoding DMI type 0x08 on pogolinux-1.rhts.eng.rdu.redhat.com
Assertion when decoding DMI type 0x08 on pogolinux-1.rhts.eng.rdu.redhat.com
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-dmidecode (Show other bugs)
5.5
All Linux
urgent Severity high
: rc
: ---
Assigned To: Roman Rakus
qe-baseos-daemons
: ZStream
Depends On: 1058872 583867 596264 621146
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 07:46 EDT by RHEL Product and Program Management
Modified: 2014-01-28 11:49 EST (History)
12 users (show)

See Also:
Fixed In Version: python-dmidecode-3.10.13-1.el5_5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-13 03:20:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2010-05-26 07:46:29 EDT
This bug has been copied from bug #583867 and has been proposed
to be backported to 5.5 z-stream (EUS).
Comment 5 Roman Rakus 2010-08-03 09:57:18 EDT
Fixed in python-dmidecode-3.10.13-1.el5_5.1
Comment 8 Petr Sklenar 2010-09-07 03:46:55 EDT
Hi,

Looking at output from rhn-client-tools - which takes data from python-dmidecode, there are these info on pogolinux-2***:

DMI Info
Vendor: 	To Be Filled By O.E.M.
System: 	To Be Filled By O.E.M.
Product: 	To Be Filled By O.E.M.
Asset Tag: 	To Be Filled By O.E.M.
Chassis: 	To Be Filled By O.E.M.
Board: 	To be filled by O.E.M.

Other machines return more informative data.
What should return pogolinux from python-dmidecode?
Comment 9 David Sommerseth 2010-09-07 04:07:46 EDT
(In reply to comment #8)
> Hi,
> 
> Looking at output from rhn-client-tools - which takes data from
> python-dmidecode, there are these info on pogolinux-2***:
> 
> DMI Info
> Vendor:  To Be Filled By O.E.M.
> System:  To Be Filled By O.E.M.
> Product:  To Be Filled By O.E.M.
> Asset Tag:  To Be Filled By O.E.M.
> Chassis:  To Be Filled By O.E.M.
> Board:  To be filled by O.E.M.
> 
> Other machines return more informative data.
> What should return pogolinux from python-dmidecode?

It should probably return exactly what you are seeing.  Those strings are taken out of the DMI tables directly.  I'm even guessing you'll find these strings in clear text in the DMI dump from this box, if you use strings or hexdump -C on it.

I presume the reason is that this box is a so called 'white label box', kind of like a prototype and not a typical mass-produced sales model.  The BIOS on such boxes are therefore not "complete", but "complete enough" to boot a system to be able to test it out.
Comment 11 errata-xmlrpc 2010-09-13 03:20:51 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0695.html

Note You need to log in before you can comment on or make changes to this bug.