Bug 596359 - When dispatch_avail is set to -1 (openais server is killed), library functions segfault
Summary: When dispatch_avail is set to -1 (openais server is killed), library function...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openais   
(Show other bugs)
Version: 5.5
Hardware: All Linux
urgent
urgent
Target Milestone: rc
: 5.6
Assignee: Jan Friesse
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords: ZStream
Depends On: 579081
Blocks: 603623
TreeView+ depends on / blocked
 
Reported: 2010-05-26 16:23 UTC by Steven Dake
Modified: 2016-04-26 14:24 UTC (History)
8 users (show)

Fixed In Version: openais-0.80.6-20.el5
Doc Type: Bug Fix
Doc Text:
When the openais server was stopped, server clients may have encountered a segmentation fault because of an invalid return code in an internal function. This crash no longer occurs.
Story Points: ---
Clone Of: 579081
Environment:
Last Closed: 2011-01-13 23:56:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (2.79 KB, patch)
2010-06-11 09:22 UTC, Jan Friesse
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0100 normal SHIPPED_LIVE openais bug fix update 2011-01-12 17:21:13 UTC

Comment 1 Steven Dake 2010-05-26 16:24:06 UTC
This bug is used to track the problem with handling the condition of dispatch_avail = -1.

Comment 4 Jan Friesse 2010-06-11 09:22:02 UTC
Created attachment 423182 [details]
Proposed patch

This patch solves problem with untested dispatch_avail variable (when == -1, something bad happened).

See last comment in https://bugzilla.redhat.com/show_bug.cgi?id=579081:
> Hello,
>
> I have large scale tests using the openais with the provided fixes, integrated
> with a telecom application. The test were successful.
>
> Regards,
>
> Lech

Patch was sent to ML, but it's not applied yet.

Steve, can you please apply this patch so we can close both of bugs (579081 and 596359)?

Comment 10 Douglas Silas 2011-01-11 23:15:33 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When the openais server was stopped, server clients may have encountered a segmentation fault because of an invalid return code in an internal function. This crash no longer occurs.

Comment 12 errata-xmlrpc 2011-01-13 23:56:56 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0100.html


Note You need to log in before you can comment on or make changes to this bug.