Bug 596522 - Printing option to staple output doesn't work with multiple copies
Summary: Printing option to staple output doesn't work with multiple copies
Status: CLOSED DUPLICATE of bug 476039
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-26 21:15 UTC by Aram Agajanian
Modified: 2010-06-01 15:40 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 06:55:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 112007 None None None Never

Description Aram Agajanian 2010-05-26 21:15:20 UTC
Description of problem:
We have a multifuntion printer (Xerox WorkCentre Pro C2128) which can automatically staple print jobs.  When a print job in OpenOffice consists of multiple copies, these copies get stapled together.

Version-Release number of selected component (if applicable):
openoffice.org-core-3.2.0-12.17.fc13.x86_64

How reproducible:
Happens every time

Steps to Reproduce:
1.  Start any OpenOffice application.
2.  Open a multipage document which is to be stapled.
3.  Select Print... option in File menu.
4.  Click on the Properties... button in the Print dialog.
5.  Click on the Device tab in the "Properties of" dialog.
6.  In the list of Options, click on the Stapling option.
    A list of stapling options should appear under Current Value.
7.  Select the "1 Staple" option.
8.  Click the OK button in the "Properties of" dialog.
    The "Properties of" dialog should disappear.
9.  Change the Number of Copies in the Print dialog to 2.
10.  Click the OK button in the Print dialog.
  
Actual results:
All sheets output from the print job are stapled together.

Expected results:
The 2 copies printed out should be stapled individually.

Additional info:
This happens in OOo Writer, Calc, and Impress.

This does not happen in Gedit or Evince on the same computer.

Comment 1 Caolan McNamara 2010-05-27 06:55:56 UTC
Best way to fix all these is to use the gtk print dialog and get uniform results across apps for the edge-cases

*** This bug has been marked as a duplicate of bug 476039 ***

Comment 2 Aram Agajanian 2010-06-01 15:40:15 UTC
This problem also occurs in Windows XP so I filed a bug report upstream.


Note You need to log in before you can comment on or make changes to this bug.