Bug 476039 - RFE: Extend gtk print dialog to support custom printing per-app features
RFE: Extend gtk print dialog to support custom printing per-app features
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
: Reopened
: 484856 506182 506907 585239 596522 600556 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-11 11:47 EST by Horst H. von Brand
Modified: 2011-12-06 09:12 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 07:31:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 344519 None None None Never
GNOME Desktop 551409 None None None Never
GNOME Desktop 551726 None None None Never
GNOME Desktop 563619 None None None Never
GNOME Desktop 564854 None None None Never
OpenOffice.org 91478 None None None Never

  None (edit)
Description Horst H. von Brand 2008-12-11 11:47:02 EST
Description of problem:
The help tells me to go to File --> Print, and select Handout in the "Content listbox". There just isn't any "Content listbox"in the print menu.

Version-Release number of selected component (if applicable):
openoffice.org-impress-3.0.1-13.1.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Caolan McNamara 2008-12-11 18:15:57 EST

*** This bug has been marked as a duplicate of bug 476037 ***
Comment 2 Horst H. von Brand 2008-12-12 12:41:13 EST
This is certainly a completely different matter (ooimpress has no way to select handout printing) than 476037 (ooimpress crash closing window while printing)
Comment 3 Caolan McNamara 2008-12-15 12:12:28 EST
Toggle on the alternative dialog, i.e. 
tools->options->general and tick on "use openoffice.org dialogs"

Need a way to get the system dialog to be able to show the extended non-system features.
Comment 4 Caolan McNamara 2008-12-15 12:15:09 EST
This sort of thing *used* to be in the options... dialog, but some of them have gotten moved around, which complicates matters
Comment 5 Horst H. von Brand 2008-12-15 13:10:32 EST
Re #3: There is no mention of this in the documentation... one of the things that did make me go to MSFT Office was precisely that I could not find a way to print presentations.

Thanks!
Comment 6 Nicola Soranzo 2008-12-19 09:58:36 EST
I had the same problem: I wanted to print just the notes of an Impress presentation, found in the Guide the part about "Content", but that dialog was missing. The workaround suggested by Caolan in comment #3 solved the issue, but certainly this regression should be fixed.
Comment 7 William A. Rowe, Jr. 2009-01-25 21:46:48 EST
"use openoffice.org dialogs" actually spells out (Load/Save) and makes
no mention of Print (which it modifies).  Right now File - Print dialog
'Option' button no longer includes Content (Drawing|Notes|Handouts|Outline)
leaving the user entirely confused until they trip across THIS bug report.

Thank you for the hint, please restore the regression of the Content Dialog
choices under the Options pane.
Comment 8 Caolan McNamara 2009-02-10 06:39:13 EST
*** Bug 484856 has been marked as a duplicate of this bug. ***
Comment 9 Caolan McNamara 2009-03-18 10:14:23 EDT
I'm going to revert to the built-in dialog for now, see https://www.redhat.com/archives/fedora-desktop-list/2009-March/msg00044.html for some details.

Would be a good bit easier with a "selection" option, and "printer changed" signal as part of the standard base gtk print dialog
Comment 10 David Tardon 2009-06-16 01:59:57 EDT
*** Bug 506182 has been marked as a duplicate of this bug. ***
Comment 11 David Tardon 2009-06-19 05:04:42 EDT
*** Bug 506907 has been marked as a duplicate of this bug. ***
Comment 12 Philip Frampton 2009-06-22 05:30:43 EDT
The revert to the OOo dialog seems to have brought problems. Randomly the printer list is empty. I have two documents open, Ctrl+P one one gives me my laser, Ctrl+P on the other just gives me "generic printer". Close dialog, Ctrl+P again and it works.
Comment 13 Illtud Daniel 2009-10-13 11:01:10 EDT
Other bugs complaining that OOo has stopped using gtk print dialog have been marked as duplicates of this one. I don't quite see that they're the same issue. I can't now print 2up (my default format, and one strongly encouraged in my enterprise) because of this issue. Is there a way of manually switching OOo back to using the gtk print dialog? I was perfectly happy with it.
Comment 14 Caolan McNamara 2009-10-13 11:30:26 EDT
It need to be reimplemented. Plan is to build it on top of the printerpullpages work of http://wiki.services.openoffice.org/wiki/Printerpullpages/Specification_OOo32 which will enable getting it merged into the "vanilla" upstream tree which allows the translations and help to get synced up wrt. the custom options in the built-in dialog

There's no way to manually switch it back, the code just isn't in there.
Comment 16 David Tardon 2010-04-13 09:43:35 EDT
taking over as agreed
Comment 17 Caolan McNamara 2010-04-23 10:20:13 EDT
*** Bug 585239 has been marked as a duplicate of this bug. ***
Comment 18 Caolan McNamara 2010-05-27 02:55:56 EDT
*** Bug 596522 has been marked as a duplicate of this bug. ***
Comment 19 Caolan McNamara 2010-06-05 09:04:55 EDT
*** Bug 600556 has been marked as a duplicate of this bug. ***
Comment 20 Alex Lancaster 2010-06-17 03:09:27 EDT
Is the reversion to the OOo print dialogs still supposed to be present in F-13?  I seem to only get OOo not GNOME dialogs when printing with openoffice.org-core-3.2.0-12.24.fc13.x86_64.  Is this being worked on upstream?
Comment 21 David Tardon 2010-06-17 03:22:16 EDT
dtardon->alexl: yes, it is (for both questions)
Comment 22 Caolan McNamara 2010-06-17 03:35:32 EDT
Where "being worked on upstream" doesn't mean "being worked on by some giant team of anonymous *other* people, but being worked on by the same unfortunate assignee as here"
Comment 24 David Tardon 2011-12-06 07:31:44 EST
it will be experimental feature in libreoffice 3.5

Note You need to log in before you can comment on or make changes to this bug.