Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596571 - Exaile won't start in F14 rawhide
Exaile won't start in F14 rawhide
Status: CLOSED DUPLICATE of bug 596392
Product: Fedora
Classification: Fedora
Component: exaile (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 21:19 EDT by Gene Snider
Modified: 2010-05-27 20:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 20:28:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Snider 2010-05-26 21:19:37 EDT
Description of problem: The current version of Exaile from the rawhide repo won't run in rawhide.


Version-Release number of selected component (if applicable):
Installed Packages
exaile.noarch        0.3.1.1-1.fc14        @rawhide


How reproducible:


Steps to Reproduce:
1.sudo yum install exaile
2.start exaile
3.
  
Actual results:
[gene@Mobile-PC ~]$ exaile
/usr/lib64/python2.6/site-packages/gtk-2.0/gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
  from gtk import _gtk
ImportError: No module named gi
INFO    : Loading Exaile 0.3.1.1...
INFO    : Loading settings...
INFO    : Setting up deferred idle manager function...
INFO    : Loading plugins...
INFO    : Loading collection...
INFO    : Loading devices...
INFO    : Loading interface...
INFO    : HAL Providers: [<cd.CDHandler object at 0x1878190>]
INFO    : Loading main window...
INFO    : Connecting main window events...
/usr/lib/python2.6/site-packages/exaile/xlgui/main.py:1177: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
  if settings.get_option(option, False) == False:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/main.py", line 937, in on_playlist_notebook_switch
    self._on_setting_change(None, None, 'playback/shuffle')
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/main.py", line 1177, in _on_setting_change
    if settings.get_option(option, False) == False:
ImportError: No module named gi
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/main.py", line 937, in on_playlist_notebook_switch
    self._on_setting_change(None, None, 'playback/shuffle')
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/main.py", line 1177, in _on_setting_change
    if settings.get_option(option, False) == False:
ImportError: No module named gi
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/main.py", line 937, in on_playlist_notebook_switch
    self._on_setting_change(None, None, 'playback/shuffle')
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/main.py", line 1177, in _on_setting_change
    if settings.get_option(option, False) == False:
ImportError: No module named gi
INFO    : Loading panels...
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 52, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/exaile/exaile.py", line 49, in main
    exaile = main.Exaile()
  File "/usr/lib/python2.6/site-packages/exaile/xl/main.py", line 84, in __init__
    self.__init()
  File "/usr/lib/python2.6/site-packages/exaile/xl/main.py", line 206, in __init
    self.gui = xlgui.Main(self)
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/__init__.py", line 118, in __init__
    self.add_panel(*self.panels[panel].get_panel())
  File "/usr/lib/python2.6/site-packages/exaile/xlgui/__init__.py", line 385, in add_panel
    label = gtk.Label(name)
TypeError: could not convert parameter 'str' of type 'gchararray'


Expected results: Exaile should start normally.


Additional info:
Comment 1 Gene Snider 2010-05-27 19:50:26 EDT
This is probably a duplicate of:
https://bugzilla.redhat.com/show_bug.cgi?id=596392

Gene
Comment 2 Gene Snider 2010-05-27 19:57:29 EDT
Yup, it was a dup.  From repo  : /pygobject2-2.21.1-9.fc14.x86_64 fixed the exaile startup issue.

Gene
Comment 3 Colin Walters 2010-05-27 20:28:44 EDT

*** This bug has been marked as a duplicate of bug 596392 ***

Note You need to log in before you can comment on or make changes to this bug.