Bug 596392 - ImportError message for module gi when importing gtk
ImportError message for module gi when importing gtk
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pygtk2 (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
: 596571 596572 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-26 13:27 EDT by Mamoru TASAKA
Modified: 2010-05-28 01:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 01:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2010-05-26 13:27:40 EDT
Description of problem:
On rawhide just trying to import gtk shows some error messages
like:

[tasaka1@localhost ~]$ python
Python 2.6.5 (r265:79063, May 25 2010, 16:22:37) 
[GCC 4.4.4 20100518 (Red Hat 4.4.4-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtk
/usr/lib/python2.6/site-packages/gtk-2.0/gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
  from gtk import _gtk
ImportError: No module named gi


Version-Release number of selected component (if applicable):
[tasaka1@localhost ~]$ rpm -q python gtk2 pygtk2
python-2.6.5-10.fc14.i686
gtk2-2.21.0-1.fc14.i686
pygtk2-2.17.0-3.fc13.i686


How reproducible:
100%
Comment 1 Colin Walters 2010-05-27 10:39:08 EDT
*** Bug 596572 has been marked as a duplicate of this bug. ***
Comment 2 Colin Walters 2010-05-27 10:39:52 EDT
Shoudl be resolved by http://koji.fedoraproject.org/koji/taskinfo?taskID=2213015
Comment 3 Gene Snider 2010-05-27 19:50:37 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=596571 is probably a duplicate of this bug, too.

Gene
Comment 4 GoinEasy9 2010-05-27 20:04:38 EDT
The update to pygobject2-2.21.1-9.fc14.i686 from koji, solved the problem.  Specifically Bug 596572 which was marked as a duplicate of this bug.
Comment 5 Gene Snider 2010-05-27 20:23:16 EDT
This update also resolved https://bugzilla.redhat.com/show_bug.cgi?id=596571.  How do I get that nice lined out "Bug nnnnn" instead of the link?  :)

Gene
Comment 6 Colin Walters 2010-05-27 20:28:44 EDT
*** Bug 596571 has been marked as a duplicate of this bug. ***
Comment 7 Mamoru TASAKA 2010-05-28 01:22:38 EDT
Works for me, thanks. Closing for now.

Note You need to log in before you can comment on or make changes to this bug.