Bug 59667 - cannot allocate partitions on 4 Gb of free disk space on RAID
cannot allocate partitions on 4 Gb of free disk space on RAID
Status: CLOSED DUPLICATE of bug 58616
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-11 13:12 EST by Martin Haubrich
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 23:29:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logfile that came with the crash (33.06 KB, text/plain)
2002-02-11 13:13 EST, Martin Haubrich
no flags Details

  None (edit)
Description Martin Haubrich 2002-02-11 13:12:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
I have an HTP370 hardware RAID controller. I downloaded the appropriate driver 
and boot disk (created them) I have 40 Gbs total, of which 4 Gb un-allocated. 
When I use "automatic partitioning", option "use free disk space" it 
says "cannot allocate partitions" and exits with a bug summary. Disk druid does 
the same after manually allocating 32 megs to '/boot', 512 megs to 'swap' and 
the rest to '/'

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from the HPT370 RAID boot disk
2. Use the 'linux dd' option and load the additional drivers
3. Try to make Linux use the free disk space for install
	

Actual Results:  I got the error message "Cannot allocate partitions" and a bug 
trace.

Expected Results:  It should have built the swap, boot and root partitions and 
continued installing.

Additional info:

Hardware for RAID: 
HTP370 controller on motherboard (A-bit K7 RAID)
2 x Seagate Barracuda 20 Gb HDD
RAID 0 (striping)
Divided into: 
-4,9 Gb NTFS (For Windows 2k)
-14,6 Gb NTFS 
-14,6 Gb FAT32
-the rest is unpartitioned

I read somewhere that for the '/boot' partition, you should use the first 1024 
cylinders, especially with some older BIOS versions, which can only use these 
first 1024 cylinders. However, my BIOS isn't more than 2 years old (which was 
the approximate age in 'older').

Also, I really wish to retain the current partitions, including its data :-)
Comment 1 Martin Haubrich 2002-02-11 13:13:47 EST
Created attachment 45281 [details]
logfile that came with the crash
Comment 2 Michael Fulbright 2002-02-12 16:47:58 EST
Where did you get the HPT boot image?
Comment 3 Martin Haubrich 2002-02-13 02:20:31 EST
From the official HPT website,
http://www.highpoint-tech.com

then to
http://www.highpoint-tech.com/370drivers_down.htm

Where I found the download for Red Hat driver version 1.3 (Which is the latest)
http://www.highpoint-tech.com/RedHat_v13_370_372.zip
Comment 4 Jeremy Katz 2002-04-15 19:02:44 EDT
This is due to not having enough unpartioned space for the installer to use for
installing in and then not reviewing the partitioning. 

*** This bug has been marked as a duplicate of 58616 ***

Note You need to log in before you can comment on or make changes to this bug.