Bug 596716 - [abrt] gvfs-archive-1.5.4-2.fc14: raise: Process /usr/libexec/gvfsd-archive was killed by signal 6 (SIGABRT)
[abrt] gvfs-archive-1.5.4-2.fc14: raise: Process /usr/libexec/gvfsd-archive w...
Status: CLOSED DUPLICATE of bug 645630
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs (Show other bugs)
6.0
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Tomáš Bžatek
desktop-bugs@redhat.com
abrt_hash:3b22c6f6cd5824db1a3cbdaee27...
: Reopened
: 601928 605957 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 07:24 EDT by Chris Ward
Modified: 2015-03-03 17:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-04 09:03:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (10.53 KB, text/plain)
2010-05-27 07:24 EDT, Chris Ward
no flags Details

  None (edit)
Description Chris Ward 2010-05-27 07:24:54 EDT
abrt version: 1.1.3
architecture: x86_64
Attached file: backtrace
cmdline: /usr/libexec/gvfsd-archive file=file:///tmp/fwconsularreportofbirthabroadpackage.zip
component: gvfs
crash_function: raise
executable: /usr/libexec/gvfsd-archive
global_uuid: 3b22c6f6cd5824db1a3cbdaee273b1f163a62005
kernel: 2.6.32-28.el6.x86_64
package: gvfs-archive-1.5.4-2.fc14
rating: 1
reason: Process /usr/libexec/gvfsd-archive was killed by signal 6 (SIGABRT)
release: Red Hat Enterprise Linux release 6.0 Beta (Santiago)
Comment 1 Chris Ward 2010-05-27 07:24:56 EDT
Created attachment 417202 [details]
File: backtrace
Comment 2 Chris Ward 2010-05-27 07:26:01 EDT
Closing NOTABUG as this was a test report
Comment 3 Chris Ward 2010-06-03 11:10:48 EDT
Funny thing is... this actually happened to me for real...
Obviously, you'll notice that i have gvfs-archive... from fc14 installed rather than el6; this might be the problem. I'm downgrading back to el6 version to see if it corrects the situation.




Package:    	gvfs-archive-1.5.4-2.fc14
Latest Crash:	Thu Jun  3 17:00:25 2010
Command:    	/usr/libexec/gvfsd-archive file=/home/cward/Downloads/5.4_Errata_Report.zip
Reason:     	Process /usr/libexec/gvfsd-archive was killed by signal 6 (SIGABRT)
Comment:    	None
Bug Reports:	Status: CLOSED NOTABUG
		https://bugzilla.redhat.com/show_bug.cgi?id=596716


backtrace: 

[New Thread 18014]
[New Thread 18013]
Core was generated by `/usr/libexec/gvfsd-archive file=/home/cward/Downloads/5.4_Errata_Report.zip'.
Program terminated with signal 6, Aborted.
#0  0x00007fe6809fe9c5 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
	in ../nptl/sysdeps/unix/sysv/linux/raise.c

Thread 2 (Thread 18013):
#0  0x00007fe680aa3e03 in __poll (fds=<value optimized out>, 
    nfds=<value optimized out>, timeout=<value optimized out>)
    at ../sysdeps/unix/sysv/linux/poll.c:87
        __arg2 = 3
        _a3 = 911
        _a1 = 32274144
        resultvar = <value optimized out>
        __arg3 = 911
        __arg1 = 32274144
        _a2 = 3
        resultvar = <value optimized out>
        oldtype = 0
        result = <value optimized out>
#1  0x00007fe6811ce635 in g_main_context_poll (context=0x1ec2d80, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2904
        poll_func = 0x7fe6811db600 <IA__g_poll>
#2  g_main_context_iterate (context=0x1ec2d80, block=1, dispatch=1, 
    self=<value optimized out>) at gmain.c:2586
        max_priority = 2147483647
        timeout = 911
        some_ready = <value optimized out>
        nfds = 3
        allocated_nfds = <value optimized out>
        fds = 0x1ec76e0
        __PRETTY_FUNCTION__ = "g_main_context_iterate"
#3  0x00007fe6811ced35 in IA__g_main_loop_run (loop=0x1ec7150) at gmain.c:2799
        self = 0x1eb6520
        __PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#4  0x000000000040915e in ?? ()
No symbol table info available.
#5  0x00000000004093ec in ?? ()
No symbol table info available.
#6  0x00007fe6809eac5d in __libc_start_main (main=0x4093a0, argc=2, 
    ubp_av=0x7ffff673fcb8, init=<value optimized out>, 
    fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7ffff673fca8) at libc-start.c:226
        result = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {0, 4107975733793936805, 
                4225072, 140737328184496, 0, 0, -4107957076587293275, 
                -4120944191498463835}, mask_was_saved = 0}}, priv = {pad = {
              0x0, 0x0, 0x41a1e0, 0x7ffff673fcb8}, data = {prev = 0x0, 
              cleanup = 0x0, canceltype = 4301280}}}
        not_first_call = <value optimized out>
#7  0x0000000000407859 in ?? ()
No symbol table info available.
#8  0x00007ffff673fca8 in ?? ()
No symbol table info available.
#9  0x000000000000001c in ?? ()
No symbol table info available.
#10 0x0000000000000002 in ?? ()
No symbol table info available.
#11 0x00007ffff6741a8f in ?? ()
No symbol table info available.
#12 0x00007ffff6741aaa in ?? ()
No symbol table info available.
#13 0x0000000000000000 in ?? ()
No symbol table info available.

Thread 1 (Thread 18014):
#0  0x00007fe6809fe9c5 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = 18013
        selftid = 18014
#1  0x00007fe680a001a5 in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x1, sa_sigaction = 0x1}, 
          sa_mask = {__val = {140627949714544, 1, 140627977460493, 
              140627832510112, 140627985470881, 140627976989520, 
              140628013037976, 140627832489216, 4294967295, 1, 5, 3032040, 0, 
              140627949714544, 3, 140627985113088}}, sa_flags = -2103218432, 
          sa_restorer = 0x5}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00007fe6811f0a4f in IA__g_assertion_message (
    domain=<value optimized out>, file=0x41a326 "gvfsbackendarchive.c", 
    line=<value optimized out>, 
    func=0x41a5b0 "g_vfs_backend_archive_finalize", 
    message=0x7fe678003610 "assertion failed: (archive->file == NULL)")
    at gtestutils.c:1302
        lstr = "235\000\346\177\000\000\260\245\031\201\346\177\000\000\002\000\000\000\000\000\000\000\020\243A\000\000\000\000"
        s = 0x7fe6780067f0 ""
#3  0x00007fe6811f0ff0 in IA__g_assertion_message_expr (domain=0x0, 
    file=0x41a326 "gvfsbackendarchive.c", line=235, 
    func=0x41a5b0 "g_vfs_backend_archive_finalize", 
    expr=<value optimized out>) at gtestutils.c:1313
        s = 0x0
#4  0x0000000000407b07 in ?? ()
No symbol table info available.
#5  0x00007fe682106acf in IA__g_object_unref (_object=0x1ec6860)
    at gobject.c:2472
        object = 0x1ec6860
        old_ref = <value optimized out>
        is_zero = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_object_unref"
#6  0x000000000040ee97 in ?? ()
No symbol table info available.
#7  0x00007fe682106acf in IA__g_object_unref (_object=0x1ec7800)
    at gobject.c:2472
        object = 0x1ec7800
        old_ref = <value optimized out>
        is_zero = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_object_unref"
#8  0x00007fe6811f55db in g_thread_pool_thread_proxy (
    data=<value optimized out>) at gthreadpool.c:265
        task = 0x1ec7800
        pool = 0x1ec3490
#9  0x00007fe6811f4044 in g_thread_create_proxy (data=0x1ec80d0)
    at gthread.c:635
        thread = 0x1ec80d0
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#10 0x00007fe68189c761 in start_thread (arg=0x7fe67efd0710)
    at pthread_create.c:301
        __res = <value optimized out>
        pd = 0x7fe67efd0710
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140627949717264, 
                4107975733793936805, 140737328183632, 140627949717968, 0, 3, 
                -4121202867237923419, -4120946243245025883}, 
              mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, 
            data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#11 0x00007fe680aad4fd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
No locals.
From                To                  Syms Read   Shared Object Library
0x00007fe68281a0f0  0x00007fe682824398  Yes (*)     /usr/lib64/libgvfscommon.so.0
0x00007fe6825ecb70  0x00007fe682605a08  Yes         /lib64/libexpat.so.1
0x00007fe682356950  0x00007fe6823b8af8  Yes         /lib64/libgio-2.0.so.0
0x00007fe682101970  0x00007fe68212af78  Yes         /lib64/libgobject-2.0.so.0
0x00007fe681ef7080  0x00007fe681ef7fc8  Yes         /lib64/libgmodule-2.0.so.0
0x00007fe681cf3590  0x00007fe681cf49e8  Yes         /lib64/libgthread-2.0.so.0
0x00007fe681ab8090  0x00007fe681adf448  Yes         /lib64/libdbus-1.so.3
0x00007fe68189a640  0x00007fe6818a5e48  Yes         /lib64/libpthread.so.0
0x00007fe68168f140  0x00007fe6816925a8  Yes         /lib64/librt.so.1
0x00007fe68147c730  0x00007fe681487708  Yes         /usr/lib64/libgnome-keyring.so.0
0x00007fe6811a5470  0x00007fe68121c038  Yes         /lib64/libglib-2.0.so.0
0x00007fe680f57ac0  0x00007fe680f824e8  Yes         /usr/lib64/libarchive.so.2
0x00007fe680d4be10  0x00007fe680d4c688  Yes         /lib64/libutil.so.1
0x00007fe6809ea9a0  0x00007fe680af7980  Yes         /lib64/libc.so.6
0x00007fe6807c8de0  0x00007fe6807c9998  Yes         /lib64/libdl.so.2
0x00007fe6805b18c0  0x00007fe6805c0528  Yes         /lib64/libresolv.so.2
0x00007fe680394610  0x00007fe6803a4718  Yes         /lib64/libselinux.so.1
0x00007fe682a29af0  0x00007fe682a41934  Yes         /lib64/ld-linux-x86-64.so.2
0x00007fe680188d30  0x00007fe68018cc08  Yes         /lib64/libacl.so.1
0x00007fe67ff84350  0x00007fe67ff86418  Yes         /lib64/libattr.so.1
0x00007fe67fc49900  0x00007fe67fd0dcf8  Yes         /usr/lib64/libcrypto.so.10
0x00007fe67f9ce5d0  0x00007fe67f9e2978  Yes         /usr/lib64/liblzma.so.0
0x00007fe67f7bc630  0x00007fe67f7c8cc8  Yes         /lib64/libbz2.so.1
0x00007fe67f496600  0x00007fe67f571f88  Yes         /usr/lib64/libxml2.so.2
0x00007fe67f256ef0  0x00007fe67f262218  Yes (*)     /lib64/libz.so.1
0x00007fe67efd4ea0  0x00007fe67f014fa8  Yes         /lib64/libm.so.6
0x00007fe67d904c00  0x00007fe67d911128  Yes (*)     /usr/lib64/gio/modules/libgioremote-volume-monitor.so
0x00007fe67d6dea00  0x00007fe67d6f7938  Yes (*)     /usr/lib64/gio/modules/libgvfsdbus.so
0x00007fe67d4c9880  0x00007fe67d4d1788  Yes         /lib64/libudev.so.0
0x00007fe67e3c5110  0x00007fe67e3cd278  Yes         /lib64/libnss_files.so.2
(*): Shared library is missing debugging information.
$1 = 0x0
No symbol "__glib_assert_msg" in current context.
rax            0x0	0
rbx            0x7fe6780067f0	140627832498160
rcx            0xffffffffffffffff	-1
rdx            0x6	6
rsi            0x465e	18014
rdi            0x465d	18013
rbp            0x41a326	0x41a326
rsp            0x7fe67efcfb08	0x7fe67efcfb08
r8             0x0	0
r9             0xa	10
r10            0x8	8
r11            0x202	514
r12            0x41a5b0	4302256
r13            0x7fe678003610	140627832485392
r14            0x7fe67efcfc70	140627949714544
r15            0x3	3
rip            0x7fe6809fe9c5	0x7fe6809fe9c5 <raise+53>
eflags         0x202	[ IF ]
cs             0x33	51
ss             0x2b	43
ds             0x0	0
es             0x0	0
fs             0x0	0
gs             0x0	0
Dump of assembler code for function raise:
   0x00007fe6809fe990 <+0>:	mov    %fs:0x2d4,%eax
   0x00007fe6809fe998 <+8>:	mov    %fs:0x2d0,%esi
   0x00007fe6809fe9a0 <+16>:	test   %esi,%esi
   0x00007fe6809fe9a2 <+18>:	jne    0x7fe6809fe9d0 <raise+64>
   0x00007fe6809fe9a4 <+20>:	mov    $0xba,%eax
   0x00007fe6809fe9a9 <+25>:	syscall 
   0x00007fe6809fe9ab <+27>:	mov    %eax,%esi
   0x00007fe6809fe9ad <+29>:	mov    %eax,%fs:0x2d0
   0x00007fe6809fe9b5 <+37>:	movslq %edi,%rdx
   0x00007fe6809fe9b8 <+40>:	movslq %esi,%rsi
   0x00007fe6809fe9bb <+43>:	movslq %eax,%rdi
   0x00007fe6809fe9be <+46>:	mov    $0xea,%eax
   0x00007fe6809fe9c3 <+51>:	syscall 
=> 0x00007fe6809fe9c5 <+53>:	cmp    $0xfffffffffffff000,%rax
   0x00007fe6809fe9cb <+59>:	ja     0x7fe6809fe9df <raise+79>
   0x00007fe6809fe9cd <+61>:	repz retq 
   0x00007fe6809fe9cf <+63>:	nop
   0x00007fe6809fe9d0 <+64>:	test   %eax,%eax
   0x00007fe6809fe9d2 <+66>:	jg     0x7fe6809fe9b5 <raise+37>
   0x00007fe6809fe9d4 <+68>:	test   $0x7fffffff,%eax
   0x00007fe6809fe9d9 <+73>:	jne    0x7fe6809fe9ef <raise+95>
   0x00007fe6809fe9db <+75>:	mov    %esi,%eax
   0x00007fe6809fe9dd <+77>:	jmp    0x7fe6809fe9b5 <raise+37>
   0x00007fe6809fe9df <+79>:	mov    0x3465ba(%rip),%rdx        # 0x7fe680d44fa0
   0x00007fe6809fe9e6 <+86>:	neg    %eax
   0x00007fe6809fe9e8 <+88>:	mov    %eax,%fs:(%rdx)
   0x00007fe6809fe9eb <+91>:	or     $0xffffffffffffffff,%eax
   0x00007fe6809fe9ee <+94>:	retq   
   0x00007fe6809fe9ef <+95>:	neg    %eax
   0x00007fe6809fe9f1 <+97>:	jmp    0x7fe6809fe9b5 <raise+37>
End of assembler dump.
Debuginfo absent: 24a80d26586e370e4909e3632f2bfd763b60f308
Debuginfo absent: 2c6dcdc910e6a1c706cdf5ad179ff8395da02423
Debuginfo absent: 2f92226b8b462c2f0aa05078e7ff19b89ac3fc13
Debuginfo absent: df71dd3946fa4d51de720d4ee2b3bfa91dd5ce40
Debuginfo absent: f39d418b549c9bf5f7601fd51089ece1bf2ea919
Comment 5 Chris Ward 2010-06-03 11:37:06 EDT
Strange, after downgrading to all el6 packages... still crashing.

Maybe i'm missing some packages or something?

%> rpm -qa|grep gvfs 
gvfs-obexftp-1.4.3-8.el6.x86_64
gvfs-archive-1.4.3-8.el6.x86_64
gvfs-smb-1.4.3-8.el6.x86_64
gvfs-fuse-1.4.3-8.el6.x86_64
gvfs-1.4.3-8.el6.x86_64

%> /usr/libexec/gvfsd-archive file=/home/cward/Downloads/5.4_Errata_Report.zip
**
ERROR:gvfsbackendarchive.c:235:g_vfs_backend_archive_finalize: assertion failed: (archive->file == NULL)
Aborted (core dumped)
Comment 6 RHEL Product and Program Management 2010-06-03 11:43:20 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Matthias Clasen 2010-06-21 13:59:48 EDT
*** Bug 601928 has been marked as a duplicate of this bug. ***
Comment 8 Matthias Clasen 2010-06-21 14:07:20 EDT
*** Bug 605957 has been marked as a duplicate of this bug. ***
Comment 9 Tomáš Bžatek 2010-06-24 10:06:04 EDT
The finalize fix for gvfsd-archive was included in 1.4.3-5.el6.

(In reply to comment #5)
> Maybe i'm missing some packages or something?
rpm -q libarchive ?

> %> /usr/libexec/gvfsd-archive file=/home/cward/Downloads/5.4_Errata_Report.zip
> **
> ERROR:gvfsbackendarchive.c:235:g_vfs_backend_archive_finalize: assertion
> failed: (archive->file == NULL)
> Aborted (core dumped)    

Does this message show up right after execution? (should be displayed only after the archive is unmounted). Do you have a mess in /usr/local or having gvfsd-archive binary somewhere else?

Weird that we have more duplicates. Any way to reproduce the crash? Mounting an archive (Fedora-13-i386-netinst.iso), browsing in Nautilus and unmounting doesn't end with an error here.
Comment 10 Chris Ward 2010-06-25 06:43:40 EDT
%> rpm -q libarchive
libarchive-2.8.3-1.el6.x86_64

%> rpm -q gvfs-archive
gvfs-archive-1.4.3-9.el6.x86_64

I'm not sure what you mean by 'having a mess in /usr/local/' but i don't know why i would. I'm working with stock rhel 6 bits, always the latest. 

%> locate gvfsd-archive
/usr/libexec/gvfsd-archive

I seem to be able to reproduce this quite easily.

# touch testfile.empty
# zip testfile.zip testfile.empty

Then just open up nautilus. Double click on the zip file. It will mount and it browsable. Then without unmounting the archive or anything, try to open the archive again and again and again until abrt catches the sig 6. It usually takes just a few 'open' attempts and it crashes.

Resulting report:

[New Thread 8738]
[New Thread 8737]
Core was generated by `/usr/libexec/gvfsd-archive file=/home/cward/Downloads/testfile.zip'.
Program terminated with signal 6, Aborted.
#0  0x00007fbca4fcf9c5 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64	../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
	in ../nptl/sysdeps/unix/sysv/linux/raise.c

Thread 2 (Thread 8737):
#0  0x00007fbca5074e03 in __poll (fds=<value optimized out>, 
    nfds=<value optimized out>, timeout=<value optimized out>)
    at ../sysdeps/unix/sysv/linux/poll.c:87
        __arg2 = 3
        _a3 = 997
        _a1 = 39491472
        resultvar = <value optimized out>
        __arg3 = 997
        __arg1 = 39491472
        _a2 = 3
        resultvar = <value optimized out>
        oldtype = 0
        result = <value optimized out>
#1  0x00007fbca579f635 in g_main_context_poll (context=0x25a4e40, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2904
        poll_func = 0x7fbca57ac600 <IA__g_poll>
#2  g_main_context_iterate (context=0x25a4e40, block=1, dispatch=1, 
    self=<value optimized out>) at gmain.c:2586
        max_priority = 2147483647
        timeout = 997
        some_ready = <value optimized out>
        nfds = 3
        allocated_nfds = <value optimized out>
        fds = 0x25a9790
        __PRETTY_FUNCTION__ = "g_main_context_iterate"
#3  0x00007fbca579fd35 in IA__g_main_loop_run (loop=0x25a9200) at gmain.c:2799
        self = 0x2598520
        __PRETTY_FUNCTION__ = "IA__g_main_loop_run"
#4  0x00000000004090fe in daemon_main (argc=2, argv=<value optimized out>, 
    max_job_threads=1, default_type=0x41a11d "archive", 
    mountable_name=<value optimized out>, first_type_name=0x41a11d "archive")
    at daemon-main.c:294
        var_args = {{gp_offset = 48, fp_offset = 0, 
            overflow_arg_area = 0x7fff38212220, 
            reg_save_area = 0x7fff382121a0}}
        connection = <value optimized out>
        loop = <value optimized out>
        daemon = 0x25a5800
        derror = {name = 0x0, message = 0x0, dummy1 = 1, dummy2 = 0, 
          dummy3 = 0, dummy4 = 0, dummy5 = 0, padding1 = 0x7fbca57ba5a1}
        mount_spec = 0x25a4c20
        mount_source = <value optimized out>
        error = 0x0
        res = <value optimized out>
        type = <value optimized out>
#5  0x000000000040938c in main (argc=2, argv=0x7fff38212318)
    at daemon-main-generic.c:39
No locals.

Thread 1 (Thread 8738):
#0  0x00007fbca4fcf9c5 in raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = <value optimized out>
        selftid = 8738
#1  0x00007fbca4fd11a5 in abort () at abort.c:92
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x1, sa_sigaction = 0x1}, 
          sa_mask = {__val = {140448171166832, 1, 140448198912781, 39425568, 
              140448206923169, 140448198441808, 140448232211656, 
              140448047842560, 4294967295, 1, 5, 3032040, 0, 140448171166832, 
              3, 140448206565376}}, sa_flags = -1495404800, sa_restorer = 0x5}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2  0x00007fbca57c1a4f in IA__g_assertion_message (
    domain=<value optimized out>, file=0x41a046 "gvfsbackendarchive.c", 
    line=<value optimized out>, 
    func=0x41a2d0 "g_vfs_backend_archive_finalize", 
    message=0x7fbc9c0035d0 "assertion failed: (archive->file == NULL)")
    at gtestutils.c:1302
        lstr = "235\000\274\177\000\000\260\265v\245\274\177\000\000\002\000\000\000\000\000\000\000\060\240A\000\000\000\000"
        s = 0x7fbc9c0068f0 "\360D"
#3  0x00007fbca57c1ff0 in IA__g_assertion_message_expr (domain=0x0, 
    file=0x41a046 "gvfsbackendarchive.c", line=235, 
    func=0x41a2d0 "g_vfs_backend_archive_finalize", 
    expr=<value optimized out>) at gtestutils.c:1313
        s = 0x0
#4  0x0000000000407aa7 in g_vfs_backend_archive_finalize (object=0x25a8840)
    at gvfsbackendarchive.c:235
        archive = <value optimized out>
        __PRETTY_FUNCTION__ = "g_vfs_backend_archive_finalize"
#5  0x00007fbca64d3acf in IA__g_object_unref (_object=0x25a8840)
    at gobject.c:2472
        object = 0x25a8840
        old_ref = <value optimized out>
        is_zero = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_object_unref"
#6  0x000000000040eda7 in g_vfs_job_mount_finalize (object=0x25a88c0)
    at gvfsjobmount.c:52
        job = 0x25a88c0
#7  0x00007fbca64d3acf in IA__g_object_unref (_object=0x25a88c0)
    at gobject.c:2472
        object = 0x25a88c0
        old_ref = <value optimized out>
        is_zero = <value optimized out>
        __PRETTY_FUNCTION__ = "IA__g_object_unref"
#8  0x00007fbca57c65db in g_thread_pool_thread_proxy (
    data=<value optimized out>) at gthreadpool.c:265
        task = 0x25a88c0
        pool = 0x25a5560
#9  0x00007fbca57c5044 in g_thread_create_proxy (data=0x25a7fc0)
    at gthread.c:635
        thread = 0x25a7fc0
        __PRETTY_FUNCTION__ = "g_thread_create_proxy"
#10 0x00007fbca5e6d761 in start_thread (arg=0x7fbca35a1710)
    at pthread_create.c:301
        __res = <value optimized out>
        pd = 0x7fbca35a1710
        now = <value optimized out>
        unwind_buf = {cancel_jmp_buf = {{jmp_buf = {140448171169552, 
                7078368687594691302, 140734135082928, 140448171170256, 0, 3, 
                -7115075646554613018, -7115088056561673498}, 
              mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x0, 0x0}, 
            data = {prev = 0x0, cleanup = 0x0, canceltype = 0}}}
        not_first_call = <value optimized out>
        sp = <value optimized out>
        freesize = <value optimized out>
#11 0x00007fbca507e4fd in clone ()
    at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115
No locals.
From                To                  Syms Read   Shared Object Library
0x00007fbca6bc2e30  0x00007fbca6bcca98  Yes         /usr/lib64/libgvfscommon.so.0
0x00007fbca69b7590  0x00007fbca69b89e8  Yes         /lib64/libgthread-2.0.so.0
0x00007fbca6723950  0x00007fbca6785af8  Yes         /lib64/libgio-2.0.so.0
0x00007fbca64ce970  0x00007fbca64f7f78  Yes         /lib64/libgobject-2.0.so.0
0x00007fbca62c4080  0x00007fbca62c4fc8  Yes         /lib64/libgmodule-2.0.so.0
0x00007fbca6089090  0x00007fbca60b0448  Yes         /lib64/libdbus-1.so.3
0x00007fbca5e6b640  0x00007fbca5e76e48  Yes         /lib64/libpthread.so.0
0x00007fbca5c60140  0x00007fbca5c635a8  Yes         /lib64/librt.so.1
0x00007fbca5a4d730  0x00007fbca5a58708  Yes         /usr/lib64/libgnome-keyring.so.0
0x00007fbca5776470  0x00007fbca57ed038  Yes         /lib64/libglib-2.0.so.0
0x00007fbca5528ac0  0x00007fbca55534e8  Yes         /usr/lib64/libarchive.so.2
0x00007fbca531ce10  0x00007fbca531d688  Yes         /lib64/libutil.so.1
0x00007fbca4fbb9a0  0x00007fbca50c89c0  Yes         /lib64/libc.so.6
0x00007fbca4d99de0  0x00007fbca4d9a998  Yes         /lib64/libdl.so.2
0x00007fbca4b828c0  0x00007fbca4b91558  Yes         /lib64/libresolv.so.2
0x00007fbca4965610  0x00007fbca4975718  Yes         /lib64/libselinux.so.1
0x00007fbca6dd1af0  0x00007fbca6de9954  Yes         /lib64/ld-linux-x86-64.so.2
0x00007fbca4759d30  0x00007fbca475dc08  Yes         /lib64/libacl.so.1
0x00007fbca4555350  0x00007fbca4557428  Yes         /lib64/libattr.so.1
0x00007fbca421a900  0x00007fbca42ded08  Yes         /usr/lib64/libcrypto.so.10
0x00007fbca3f9f5d0  0x00007fbca3fb3978  Yes         /usr/lib64/liblzma.so.0
0x00007fbca3d8d630  0x00007fbca3d99cc8  Yes         /lib64/libbz2.so.1
0x00007fbca3a67600  0x00007fbca3b42f88  Yes         /usr/lib64/libxml2.so.2
0x00007fbca3827ef0  0x00007fbca38331a8  Yes         /lib64/libz.so.1
0x00007fbca35a5ea0  0x00007fbca35e5fa8  Yes         /lib64/libm.so.6
0x00007fbca1ed5b70  0x00007fbca1ee15b8  Yes         /usr/lib64/gio/modules/libgioremote-volume-monitor.so
0x00007fbca1cb0940  0x00007fbca1cc9358  Yes         /usr/lib64/gio/modules/libgvfsdbus.so
0x00007fbca1a9b880  0x00007fbca1aa3788  Yes         /lib64/libudev.so.0
0x00007fbca2996110  0x00007fbca299e0d8  Yes         /lib64/libnss_files.so.2
$1 = 0x0
No symbol "__glib_assert_msg" in current context.
rax            0x0	0
rbx            0x7fbc9c0068f0	140448047851760
rcx            0xffffffffffffffff	-1
rdx            0x6	6
rsi            0x2222	8738
rdi            0x2221	8737
rbp            0x41a046	0x41a046
rsp            0x7fbca35a0b08	0x7fbca35a0b08
r8             0x0	0
r9             0x0	0
r10            0x8	8
r11            0x206	518
r12            0x41a2d0	4301520
r13            0x7fbc9c0035d0	140448047838672
r14            0x7fbca35a0c70	140448171166832
r15            0x3	3
rip            0x7fbca4fcf9c5	0x7fbca4fcf9c5 <raise+53>
eflags         0x206	[ PF IF ]
cs             0x33	51
ss             0x2b	43
ds             0x0	0
es             0x0	0
fs             0x0	0
gs             0x0	0
Dump of assembler code for function raise:
   0x00007fbca4fcf990 <+0>:	mov    %fs:0x2d4,%eax
   0x00007fbca4fcf998 <+8>:	mov    %fs:0x2d0,%esi
   0x00007fbca4fcf9a0 <+16>:	test   %esi,%esi
   0x00007fbca4fcf9a2 <+18>:	jne    0x7fbca4fcf9d0 <raise+64>
   0x00007fbca4fcf9a4 <+20>:	mov    $0xba,%eax
   0x00007fbca4fcf9a9 <+25>:	syscall 
   0x00007fbca4fcf9ab <+27>:	mov    %eax,%esi
   0x00007fbca4fcf9ad <+29>:	mov    %eax,%fs:0x2d0
   0x00007fbca4fcf9b5 <+37>:	movslq %edi,%rdx
   0x00007fbca4fcf9b8 <+40>:	movslq %esi,%rsi
   0x00007fbca4fcf9bb <+43>:	movslq %eax,%rdi
   0x00007fbca4fcf9be <+46>:	mov    $0xea,%eax
   0x00007fbca4fcf9c3 <+51>:	syscall 
=> 0x00007fbca4fcf9c5 <+53>:	cmp    $0xfffffffffffff000,%rax
   0x00007fbca4fcf9cb <+59>:	ja     0x7fbca4fcf9df <raise+79>
   0x00007fbca4fcf9cd <+61>:	repz retq 
   0x00007fbca4fcf9cf <+63>:	nop
   0x00007fbca4fcf9d0 <+64>:	test   %eax,%eax
   0x00007fbca4fcf9d2 <+66>:	jg     0x7fbca4fcf9b5 <raise+37>
   0x00007fbca4fcf9d4 <+68>:	test   $0x7fffffff,%eax
   0x00007fbca4fcf9d9 <+73>:	jne    0x7fbca4fcf9ef <raise+95>
   0x00007fbca4fcf9db <+75>:	mov    %esi,%eax
   0x00007fbca4fcf9dd <+77>:	jmp    0x7fbca4fcf9b5 <raise+37>
   0x00007fbca4fcf9df <+79>:	mov    0x3465ba(%rip),%rdx        # 0x7fbca5315fa0
   0x00007fbca4fcf9e6 <+86>:	neg    %eax
   0x00007fbca4fcf9e8 <+88>:	mov    %eax,%fs:(%rdx)
   0x00007fbca4fcf9eb <+91>:	or     $0xffffffffffffffff,%eax
   0x00007fbca4fcf9ee <+94>:	retq   
   0x00007fbca4fcf9ef <+95>:	neg    %eax
   0x00007fbca4fcf9f1 <+97>:	jmp    0x7fbca4fcf9b5 <raise+37>
End of assembler dump.
Comment 11 RHEL Product and Program Management 2010-07-15 09:58:53 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 12 Tomáš Bžatek 2011-01-04 09:03:26 EST
Seems to be duplicate of 645630

*** This bug has been marked as a duplicate of bug 645630 ***

Note You need to log in before you can comment on or make changes to this bug.