Bug 596825 - It is impossible to download multiple packages from RHN
It is impossible to download multiple packages from RHN
Status: CLOSED DUPLICATE of bug 590136
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
RHN Stable
All Linux
low Severity medium
: ---
: ---
Assigned To: Grant Gainey
Red Hat Network Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 11:10 EDT by Alex Wood
Modified: 2010-06-09 08:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 08:51:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Wood 2010-05-27 11:10:03 EDT
Hello Red Hat HelpDesk

My name is Kristijan and work like RH support engineer. I don't know whom 
to address regarding this issue. I have a Customer ticket with following 
problem:

When he log in to RHN > Channels > Channel Name ( Red Hat Enterprise Linux 
(v. 5 for 32-bit x86 Server)  ) > Packages 7196 
he is getting the package list, he has the right to download rpm packages. 
What's more: he can download them by clicking the package name acl (see 
the attachment), which takes him to the page 

https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=387100 

On that page, there is a Download Package link at the bottom of the page, 
which works deliciously. 

What is not working is download multiple packages in one download. And it 
should work. It used to work. This is probably an issue with the RHN 
software. And very probably, this has nothing to do with admin rights. 
Now, I would like to say that this option is working for me and  it used 
to work for Customer, too.

It stopped working a year ago, unfortunately. If Customer would create a 
new user for his Org, it works for that user, but not for him ' user 
(szivan) '.

Customer account number is 736503.

Thank you for helping me. 

Best wishes, 
Kristijan Besu 
RHCE/RHCX 
Regional Center for Support Research and Development 
Center Millennium - Business Tower, 
Omladinski trg 17, 26300 Vrsac 
Serbia 
Phone:+381 (11) 360 5361 
Mobile: +381 (64) 886 58 77 
kristijan.besu@vdel.com 
www.vdel.com
Comment 1 Grant Gainey 2010-06-09 08:51:00 EDT
"Download Packages" has a number of known issues. 

The primary one is that it should only allow for 25 packages at a time, but a) the logic allows for 25 package *names* at a time, which can result in more than 25 *packages*, and b) an unrelated bug involving error-messages can result in the "Only 25 at once" message never making it back to the user.

There are also edge cases when the resulting tarball is "too big" and fails to be transferred before the proxy timeout kicks in.

BZ 590136 is the oldest public BZ I can find for the Download Packages problem.  I am marking all the other ones I can find as duplicates of that one, and raising '136's priority.
Comment 2 Grant Gainey 2010-06-09 08:51:32 EDT

*** This bug has been marked as a duplicate of bug 590136 ***

Note You need to log in before you can comment on or make changes to this bug.