Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 590136 - (package-download) RHN Hosted: "download packages" button (e.g., pkg upgrade page, channel pkgs page...) does not work above a certain # of pkgs
RHN Hosted: "download packages" button (e.g., pkg upgrade page, channel pkgs ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn521
All Linux
high Severity medium
: ---
: ---
Assigned To: Grant Gainey
Red Hat Network Quality Assurance
US=3418
:
: 437779 464062 473064 486414 596825 (view as bug list)
Depends On:
Blocks: rhn-sprint48
  Show dependency treegraph
 
Reported: 2010-05-07 15:51 EDT by Xixi
Modified: 2018-11-14 13:38 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-26 12:54:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xixi 2010-05-07 15:51:02 EDT
Description of problem:
Customer reports that when trying to bulk download the upgrade packages from the Red Hat Network site, the "download" button just don't respond at all. Tried both IE8 and firefox but without any luck.

I've tested this and can reproduce the problem - on System -> Software -> Packages -> upgrade page and Channels -> Packages page.  If I select 50 packages, clicking download button throws me back on the same page.  If I select 12 packages, clicking the download button proceeds to the download confirmation page as expected.

Version-Release number of selected component (if applicable):
Red Hat Network 5.2.1

How reproducible:
Always

Steps to Reproduce:
1. Login to RHN -> Systems -> select system -> Software tab -> upgrade tab -> select all the packages (e.g. 1 to 20 of 300 (300 selected) 
2. Click on Download Packages button 
3. Try another page with the Download button, such as Channels -> Packages, select about 50 or a few hundreds and click on Download Packages button.
  
Actual results:
It does not respond or throws back on same page without proceeding.

Expected results:
Proceeds to download confirmation page to download pkgs.

Additional info:
For customer, if they go to Your Preferences -> RHN List Page Size and select highest entries per list page, then try to download packages e.g (1 to 50 of 300 (50 selected)) -> Click on Download Packages, it works.
For me, this does not make a difference. If the selection is larger than 40-50 packages, it does not work, otherwise, it works as expected.
Comment 3 Grant Gainey 2010-06-09 08:51:32 EDT
*** Bug 596825 has been marked as a duplicate of this bug. ***
Comment 4 Grant Gainey 2010-06-09 08:51:53 EDT
*** Bug 486414 has been marked as a duplicate of this bug. ***
Comment 5 Grant Gainey 2010-06-09 08:52:22 EDT
*** Bug 464062 has been marked as a duplicate of this bug. ***
Comment 6 Grant Gainey 2010-06-15 16:53:03 EDT
*** Bug 437779 has been marked as a duplicate of this bug. ***
Comment 8 Sebastian Skracic 2010-08-26 12:54:16 EDT
The download package tarball facility has been rewritten so that it no longer involves redirects with enormously long URLs, which sooner or later would get cut off in user's browsers.  Having said that, the 25 package per download tarball limit still applies, and the efforts have been made to present that information correctly to user.
Comment 10 Sebastian Skracic 2010-10-07 02:47:30 EDT
*** Bug 473064 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.