Bug 597117 - A warning should be given in the help of mke2journal-L for the length of label
Summary: A warning should be given in the help of mke2journal-L for the length of label
Status: CLOSED DUPLICATE of bug 579118
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs   
(Show other bugs)
Version: unspecified
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 07:23 UTC by Yufang Zhang
Modified: 2010-05-28 08:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 08:48:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yufang Zhang 2010-05-28 07:23:57 UTC
Description of problem:
For the mke2journal-L, label is limited to 16 bytes. So if you set label longer than that length, it will be truncated. Thus the label set may not be as what you expect. So it is better to add some warning in the help of mke2journal-L to let people know this limitation. 

Version-Release number of selected component (if applicable):
major: 1
minor: 2
release: 7
extra: 


How reproducible:
Always

Steps to Reproduce:
1.><fs> mke2journal-L 1024 "1234567890abcdefg" /dev/VG/jounal
  
2.><fs> get-e2label /dev/VG/jounal
1234567890abcdef

  
Actual results:


Expected results:
At least a warning should be given in the help to inform people this limitation.

Additional info:

Comment 1 Yufang Zhang 2010-05-28 08:48:19 UTC

*** This bug has been marked as a duplicate of bug 579118 ***


Note You need to log in before you can comment on or make changes to this bug.