Bug 597247 - The Evolution address book has quit unexpectedly.
The Evolution address book has quit unexpectedly.
Status: CLOSED DUPLICATE of bug 597128
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 09:52 EDT by William Lovaton
Modified: 2010-05-28 12:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 12:50:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Lovaton 2010-05-28 09:52:17 EDT
Description of problem:
I updated my office system from Fedora 11 to Fedora 13 with a fresh install and when I restored my evolution backup I'm unable to search contacts in the GAL.

When I go to the contacts module in Evolution and select the Global Address List I get the following alert window:

"The Evolution address book has quit unexpectedly.

Your contacts for file:///home/nalwalovaton/.evolution/addressbook/local/system will not be available until Evolution is restarted."

If I start evolution in the command line I get the following message printed twice in the console:

(evolution:2841): libebook-WARNING **: e-book.c:106: e-d-s proxy died

The same message gets printed again if I try to look up for contact that I know exists but I got no result.

Now if I try to type a name in the mail composer I get the following message printed in the console:

(evolution:2841): libebook-CRITICAL **: file e-book.c: line 1221 (e_book_get_book_view): assertion `book->priv->proxy' failed

The only way I have to workaround this problem is to additionally configure the MAPI module and leave the Exchange account as the default, then I go to the Contacts Preferences and uncheck the Exchange module as the source of contacts leaving only the Local and the MAPI module as a source.  Then I have to go to the Calendar module to uncheck the MAPI source in order for the appointments to not show up twice.

So I end up sending the mails using the Exchange module but looking up the contacts with the MAPI module.  Obviously this is not ideal.  I think I have to use evolution-exchange instead of evolution-mapi because my OutLook server is 2003 and someone told me that only 2007 is officially supported by evolution-mapi.

I have been migrating my evolution data through several Fedora releases from version 6 to 11 without any problem, now migrating from F11 to F13 I got this serious issue.

Version-Release number of selected component (if applicable):
This is a Fedora 13 system with the latest updates:
evolution-exchange-2.30.1-3.fc13.i686
evolution-2.30.1-5.fc13.i686
evolution-mapi-0.30.1-1.fc13.i686
evolution-data-server-2.30.1-2.fc13.i686


How reproducible:
I always get this error message anytime I try to search a contact.

Steps to Reproduce:
1. Start evolution
2. Go to the contact module
3. Select the Global Address List
4. Watch the error message in the alert window and in the console
  
Actual results:
I'm unable to find any contact to send him an email

Expected results:
I should be able to find contacts and send them emails

Additional info:
The full console output of a test session is the following:

(evolution:2765): e-data-server-DEBUG: Loading categories from "/home/nalwalovaton/.evolution/categories.xml"
(evolution:2765): e-data-server-DEBUG: Loaded 29 categories

** (evolution:2765): CRITICAL **: categories_icon_theme_hack: assertion `filename != NULL && *filename != '\0'' failed
** (evolution:2765): DEBUG: Loading Exchange MAPI Plugin 

** (evolution:2765): DEBUG: MAPI listener is constructed with 1 listed MAPI accounts 

(evolution:2765): libebook-WARNING **: e-book.c:106: e-d-s proxy died

(evolution:2765): eab-widgets-CRITICAL **: contact_display_url_requested: assertion `icon_info != NULL' failed

(evolution:2765): eab-widgets-CRITICAL **: contact_display_url_requested: assertion `icon_info != NULL' failed

(evolution:2765): libebook-WARNING **: e-book.c:106: e-d-s proxy died

(evolution:2765): libebook-WARNING **: e-book.c:106: e-d-s proxy died
Comment 1 William Lovaton 2010-05-28 10:28:51 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=597128

Oppsss... Gregor beat me for 5 hours.  I swear I was going to report this yesterday but I was too busy at work  :-)
Comment 2 Milan Crha 2010-05-28 12:50:33 EDT
Thanks for a bug report and finding the previous bug. I'm marking this one as a duplicate of it. :)

*** This bug has been marked as a duplicate of bug 597128 ***

Note You need to log in before you can comment on or make changes to this bug.