Bug 597316 - rpm fails to update higher numbered versions from older releases
rpm fails to update higher numbered versions from older releases
Status: CLOSED DUPLICATE of bug 596840
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-28 12:05 EDT by Wolfgang Denk
Modified: 2010-05-31 01:50 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-31 01:50:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Denk 2010-05-28 12:05:28 EDT
Description of problem:

During anupgrade from F12 to F13 I noticed that a number of old (F12) packages were not replaced by the new F13 versions. It turns out that rpm will consider a package "3.12.4-19.fc12" to be newer than "3.12.4-17.fc13"

Version-Release number of selected component (if applicable):

rpm-4.8.0-14.fc13.x86_64


How reproducible:

Always.

Steps to Reproduce:
1. Take a F12 based system, make sure that the latest version of nss-softokn is installed:
$ rpm -q nss-softokn
nss-softokn-3.12.4-19.fc12.x86_64

2. Update the system to F13 using yum upgrade
3. Check the version of the package:

$ rpm -q nss-softokn
nss-softokn-3.12.4-19.fc12.x86_64

==> not replaced.
4. Attempt a manual update:

# rpm -Uvh ftp://ftp-stud.fht-esslingen.de/pub/fedora/linux/releases/13/Fedora/x86_64/os/Packages/nss-softokn-3.12.4-17.fc13.x86_64.rpm
Retrieving ftp://ftp-stud.fht-esslingen.de/pub/fedora/linux/releases/13/Fedora/x86_64/os/Packages/nss-softokn-3.12.4-17.fc13.x86_64.rpm
Preparing...                ########################################### [100%]
        package nss-softokn-3.12.4-19.fc12.x86_64 (which is newer than nss-softokn-3.12.4-17.fc13.x86_64) is already installed
  
Actual results:

The older (F12) package does not get replaced.

Expected results:

Any F13 version package should be considered more recent than a F12 version package.

Additional info:
Comment 1 Daniel Laczi 2010-05-30 12:13:40 EDT
I have a problem with nss-softokn-3.12.4-17.fc13.x86_64 too.

I tried to install wine, but I get the following error message:

Error while processing:
  package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed

IMHO there is problem solving dependences for this package somewhere.
Comment 2 Daniel Laczi 2010-05-30 12:20:55 EDT
In addition I did not upgrade from Fedora 12, but I have done a clean installation!

Also I don't have problems on any of my i686 machines with this package.
Comment 3 Panu Matilainen 2010-05-31 01:50:47 EDT
(In reply to comment #0)
> Expected results:
> 
> Any F13 version package should be considered more recent than a F12 version
> package.

Rpm doesn't know anything about F12 or F13, it simply compares package EVR against another, and according to rpm's version comparson rules 3.12.4-19.fc12 *is* newer than 3.12.4-17.fc13. This is just a packaging bug (or perhaps several, looking at bug 596840).

*** This bug has been marked as a duplicate of bug 596840 ***

Note You need to log in before you can comment on or make changes to this bug.