Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 596840 - i686 version missing from the x86_64 updates repo
i686 version missing from the x86_64 updates repo
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nss-softokn (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
: 597316 597583 597924 598843 601804 604934 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-27 11:41 EDT by Jonathan Underwood
Modified: 2011-05-13 15:30 EDT (History)
30 users (show)

See Also:
Fixed In Version: nss-3.12.6-7.fc13,nss-softokn-3.12.6-3.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-13 15:30:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add %{?_isa} to requires in the devel packages (2.27 KB, patch)
2010-06-02 19:59 EDT, Elio Maldonado Batiz
no flags Details | Diff

  None (edit)
Description Jonathan Underwood 2010-05-27 11:41:45 EDT
Description of problem:
After running preupgrade on an up to date F12 system to upgrade it to F-13, running package-cleanup --orphans lists 

nss-softokn-3.12.4-19.fc12.x86_64
nss-softokn-freebl-3.12.4-19.fc12.x86_64

Doing a yum remove on these will of course remove 1500 or so packages and destroy the system. The reason seems to be that the nvr of the F13 packages are lower than the F12 packages:


# yum downgrade nss-softokn-freebl nss-softokn
Loaded plugins: presto, refresh-packagekit
Setting up Downgrade Process
Resolving Dependencies
--> Running transaction check
---> Package nss-softokn.x86_64 0:3.12.4-17.fc13 set to be updated
---> Package nss-softokn.x86_64 0:3.12.4-19.fc12 set to be erased
---> Package nss-softokn-freebl.x86_64 0:3.12.4-17.fc13 set to be updated
---> Package nss-softokn-freebl.x86_64 0:3.12.4-19.fc12 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                  Arch         Version               Repository    Size
================================================================================
Downgrading:
 nss-softokn              x86_64       3.12.4-17.fc13        fedora       168 k
 nss-softokn-freebl       x86_64       3.12.4-17.fc13        fedora       118 k

Transaction Summary
================================================================================
Remove        0 Package(s)
Reinstall     0 Package(s)
Downgrade     2 Package(s)

Total download size: 286 k
Is this ok [y/N]: 


Please rectify this with some new F13 packages ASAP.
Comment 1 Elio Maldonado Batiz 2010-05-27 15:20:18 EDT
nss-softokn-3.12.4-19.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nss-softokn-3.12.4-19.fc13
Comment 2 Jonathan Underwood 2010-05-29 05:42:59 EDT
This looks a little bit suspect:

# yum check all
Loaded plugins: presto, refresh-packagekit
nss-softokn-3.12.4-19.fc13.x86_64 is a duplicate with nss-softokn-3.12.4-17.fc13.i686
nss-softokn-freebl-3.12.4-19.fc13.x86_64 is a duplicate with nss-softokn-freebl-3.12.4-17.fc13.i686
Error: check all
Comment 3 Elio Maldonado Batiz 2010-05-29 14:45:58 EDT
(In reply to comment #2)
> This looks a little bit suspect:
> 
> # yum check all
> Loaded plugins: presto, refresh-packagekit
> nss-softokn-3.12.4-19.fc13.x86_64 is a duplicate with
> nss-softokn-3.12.4-17.fc13.i686
> nss-softokn-freebl-3.12.4-19.fc13.x86_64 is a duplicate with
> nss-softokn-freebl-3.12.4-17.fc13.i686
> Error: check all    

Yes, and I suspect nss rather than nss-softokn as the culprit. See Bug 527867.
Comment 4 Elio Maldonado Batiz 2010-05-29 14:48:12 EDT
See also latest comments to Bug 590199
Comment 5 leigh scott 2010-05-30 09:27:15 EDT
nss-softokn-freebl-3.12.4-19.fc13.i686 is missing from the x86_64 updates repo

[leigh@localhost ~]$ yum list nss-softokn-freebl
Loaded plugins: langpacks, presto, refresh-packagekit, remove-with-leaves, show-
              : leaves
Adding en_GB to language list
Installed Packages
nss-softokn-freebl.i686   3.12.4-19.fc13 @/nss-softokn-freebl-3.12.4-19.fc13.i686
nss-softokn-freebl.x86_64 3.12.4-19.fc13 @updates


I grabbed the i686 package from the i386 repo


http://forums.fedoraforum.org/showthread.php?t=245886
Comment 6 Rex Dieter 2010-05-30 09:35:26 EDT
notting (resident mash guru dude), I fail to see why the newer nss-softokn.i686 and nss-softokn-freebl.i686 pkgs aren't getting properly multilib'd in the updates repo.  any clues?  (or is this already known?)
Comment 7 Elio Maldonado Batiz 2010-05-30 14:11:39 EDT
The nss.spec file has this line
Requires:         nss-softokn%{_isa} = %{nss_softokn_fips_version}
The %{_isa} part was added as a fix to this bug
https://bugzilla.redhat.com/show_bug.cgi?id=52786
Could that have been an ill-conceived "fix" that's now causing the current problem?
Comment 8 Rex Dieter 2010-05-30 15:37:15 EDT
bug #527867 had the correct fix imo.  The badness appears to be multilib'ing going wrong here, as required dependency is going unsatisfied in the f13 x86_64 updates repo.  The f13 core/GA x86_64 repo seems ok, and does contain nss-softokn.i686.
Comment 9 Ralf Corsepius 2010-05-31 00:31:30 EDT
(In reply to comment #8)
> bug #527867 had the correct fix imo.
I think this BZ is irrelevant, wrt. this issue. Whether adding explicit %{_isa}'s is useful is a different is matter 

(IMO, it's is not. These are cludges to work around deficiencies/bugs in yum)

>  The badness appears to be multilib'ing
> going wrong here, as required dependency is going unsatisfied in the f13 x86_64
> updates repo.  The f13 core/GA x86_64 repo seems ok, and does contain
> nss-softokn.i686.    

Agreed. The origin is FC13 GA having contained nss-soft*i686 packages and FC13 containing other i686 packages depending on nss-soft*i686. I.e. users have installations which have these packages installed and now are facing yum problems originating from broken dependencies being caused by *.x86_64 packages having been upgraded and the i686 packages not having been upgraded.
Comment 10 Panu Matilainen 2010-05-31 01:50:47 EDT
*** Bug 597316 has been marked as a duplicate of this bug. ***
Comment 11 Pierre Blavy 2010-05-31 08:55:31 EDT
F13 x86 and i686 version number do not match, I was unable to install wine : 

#yum install wine
...
Erreur du contrôle de transaction :
  package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed
Comment 12 Elio Maldonado Batiz 2010-06-01 12:05:37 EDT
This seems to be a problem only on F-13. On my F-12 x86_64-based system where I have the latest versions of nss and nss-softokn and I installed the mingw32 group without problems. I also tested another x86_64 F-12 system where I installed mingw32 first and then updated nss and nss-softokn and it worked
Comment 13 Elio Maldonado Batiz 2010-06-01 14:32:40 EDT
Repo queries from my F-12 system
repoquery --repoid=updates --whatprovides nss-softokn
nss-softokn-0:3.12.4-19.fc12.i686
nss-softokn-0:3.12.4-19.fc12.x86_64

Repo queries from my F-13 system
[root@fedora13 emaldona]# repoquery --repoid=updates --whatprovides nss-softokn
nss-softokn-0:3.12.4-19.fc13.x86_64
nss-softokn-0:3.12.4-19.fc13.x86_64

When I visually inspect the repository, the F13/86_64 directory I see that
nss-softoken-3.12.4.19,fc13.i686.8.rpm is missing. It's there file for
F-12/x86_64. 

Some things weren't obvious to me while reading the above comments and I had to
check myself. Apologies if most of you knew this already.
Comment 14 Bill Nottingham 2010-06-02 14:09:34 EDT
*** Bug 597924 has been marked as a duplicate of this bug. ***
Comment 15 Bill Nottingham 2010-06-02 14:09:39 EDT
*** Bug 598843 has been marked as a duplicate of this bug. ***
Comment 16 Bill Nottingham 2010-06-02 14:19:25 EDT
There are two 'simple' fixes for this that don't involve hotfixing the push infrastructure:

1) For all nss/nspr packages that don't have .so symlinks in their devel packages, add %{?_isa} to the requires in the devel packages.

See https://fedoraproject.org/wiki/PackagingDrafts/ArchSpecificRequires for
a packaging draft for this.

For example, that would change, in nss-softokn-freebl-devel:

Requires:         nss-softokn-freebl = %{version}-%{release}
to:
Requires:         nss-softokn-freebl%{?_isa} = %{version}-%{release}

in nss-softokn-freebl-devel,

Requires:         nss-softokn = %{version}-%{release}
to
Requires:         nss-softokn%{?_isa} = %{version}-%{release}

in nss-softokn-devel, and so on.

The reason this is needed is that for most -devel pacakges, there is automatic dependencies added on the proper library package due to following the '.so' devel symlink to the main library. This doesn't work for nss/nspr, as the -devel packages don't have these symlinks.

2) Wait for either of https://admin.fedoraproject.org/updates/glibc-2.12-2 or https://admin.fedoraproject.org/updates/pidgin-2.7.1-2.fc13 to be pushed to stable, as those will pull in the i686 nss-softokn-freebl through library dependencies.
Comment 17 Stu Tomlinson 2010-06-02 16:20:02 EDT
(In reply to comment #16)
> 2) Wait for either of https://admin.fedoraproject.org/updates/glibc-2.12-2 or
> https://admin.fedoraproject.org/updates/pidgin-2.7.1-2.fc13 to be pushed to
> stable, as those will pull in the i686 nss-softokn-freebl through library
> dependencies.

Why isn't the existing Pidgin update that's already pushed to stable sufficient? https://admin.fedoraproject.org/updates/pidgin-2.7.0-2.fc13
Comment 18 Bill Nottingham 2010-06-02 18:51:24 EDT
I just checked... the libpurple update won't help, because libpurple-2.7.x has dropped its dependency on nss-softokn-freebl. Sorry I misspoke (the F13 GA version *does* depend on it.)
Comment 19 Elio Maldonado Batiz 2010-06-02 19:59:33 EDT
Created attachment 419215 [details]
Add %{?_isa} to requires in the devel packages

Bill's recommended fix: Add %{?_isa} to requires in the -devel packages.
Also fix typo in package description and update the nspr version to 4.8.4.
Comment 20 Ralf Corsepius 2010-06-03 03:23:01 EDT
(In reply to comment #16)
> There are two 'simple' fixes for this that don't involve hotfixing the push
> infrastructure:
> 
> 1) For all nss/nspr packages that don't have .so symlinks in their devel
> packages, add %{?_isa} to the requires in the devel packages.
I disagree on this proposal. It's an ugly hack polluting the package and means playing with symptoms.

The real fix to this issue is fixing the push infrastructure. It is based on assumptions which do not apply in reality.
Comment 21 Bill Nottingham 2010-06-03 11:54:30 EDT
The infrastructure works on -devel packages having dependencies on the shared libraries they implement the API for. In nearly all cases, this is handled automatically by RPM. However, since the packaging of nss/nspr does not allow for this, there needs to be hacks added.

Ralf, if you've got patches to help automatically handle that, we're perfectly willing to look at them. If you're not willing to help, only to complain, then you really shouldn't be expect to be taken that seriously.
Comment 22 Ralf Corsepius 2010-06-03 23:54:45 EDT
(In reply to comment #21)

> Ralf, if you've got patches to help automatically handle that, we're perfectly
> willing to look at them.
Where are your sources? URL?

> If you're not willing to help, only to complain, then
> you really shouldn't be expect to be taken that seriously.    
Bill, I am complaining, because I feel rel-eng is vastly underestimating the impact of this bug (you have effectively broken multilibs on i386 and turned multilibs on x86_64 unusable) and rel-eng not to have reacted in appropriate ways to it.

Also, I feel asking people to add %{_isa} to their rpm.specs to be a severe mistake, because I consider %{_isa} to be a broken and flawed design.
Comment 23 Bill Nottingham 2010-06-04 11:07:20 EDT
http://git.fedorahosted.org/git/?p=mash

specifically, mash/multilib.py is what selects packages for multilib. The caveats is that this has to operate on pretty much only information in the RPM header/metadata (provides, requires, file lists, etc.) - examining the files in the RPM itself would be way to time consuming.

To be clear; the recommendation of %{_isa} is specific for this case due to how nss et. al. are packaged.
Comment 24 Brad S 2010-06-06 17:07:49 EDT
Hi, this is a showstopper on my system.  I need the 32-bit glibc on my 64-bit install to run several applications.  Is there a decent workaround?

yum install glibc.i686 of course leads to the following error:

================================================================================
 Package                  Arch       Version                 Repository    Size
================================================================================
Installing:
 glibc                    i686       2.12-1                  fedora       4.3 M
Installing for dependencies:
 nss-softokn-freebl       i686       3.12.4-17.fc13          fedora       111 k

Transaction Summary
================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total size: 4.4 M
Installed size: 13 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed
Comment 25 Oded Arbel 2010-06-06 17:15:48 EDT
I downloaded the required RPM files from the i686 update site and installed them manually.
Comment 26 Fedora Update System 2010-06-06 19:50:05 EDT
nss-softokn-3.12.4-23.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/nss-softokn-3.12.4-23.fc13
Comment 27 Erik Wasser 2010-06-07 04:47:37 EDT
Thanks "Fedora Update System",

I've updated via 

% yum localinstall \
   --nogpgcheck \
   nss-softokn-3.12.4-23.fc13.i686.rpm \
   nss-softokn-freebl-3.12.4-23.fc13.i686.rpm

The following update went smooth. Thx.
Comment 28 Fedora Update System 2010-06-07 18:09:34 EDT
nss-softokn-3.12.4-23.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update nss-softokn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/nss-softokn-3.12.4-23.fc13
Comment 29 Oded Arbel 2010-06-08 03:01:32 EDT
Currently when I try to install glibc.i686 on Fedora x86_64 (which was my original problem), using update-testing, it does not require nss-softokn.i686 and it does not actually require anything from update-testing.

When I try to install nss-softokn.i686 specifically, it does use update-testing, but it does not require nss-softokn-freebl like it did before.

So for me, I'm happy that nss-softokn.i686 is available in the x86_64 repos, but it doesn't look like its a requirement for glibc.i686 any more (at least in revision 2.12-2 of it) and so the above fix does not manifest as any improvement on my systems.
Comment 30 Alex Lancaster 2010-06-11 13:15:19 EDT
Is bug #601804 a dupe of this one?
Comment 31 Alex Lancaster 2010-06-11 13:21:16 EDT
*** Bug 601804 has been marked as a duplicate of this bug. ***
Comment 32 Corey Ashford 2010-06-11 13:24:39 EDT
*** Bug 597583 has been marked as a duplicate of this bug. ***
Comment 33 Phillip Lynn 2010-06-13 11:13:37 EDT
When I attempt to complete a yum update I get the following:
package nss-softokn-3.12.4-19.fc13.x86_64 (which is newer than
nss-softokn-3.12.4-17.fc13.i686) is already installed

Something is not correct in nss-softokn update process.  I am using linux 64
bit but the system is attempting to update my system with a 32 bit file
Comment 34 Alex Lancaster 2010-06-13 12:02:30 EDT
(In reply to comment #33)
> When I attempt to complete a yum update I get the following:
> package nss-softokn-3.12.4-19.fc13.x86_64 (which is newer than
> nss-softokn-3.12.4-17.fc13.i686) is already installed
> 
> Something is not correct in nss-softokn update process.  I am using linux 64
> bit but the system is attempting to update my system with a 32 bit file    

The nss-softokn update hasn't yet been pushed to stable.  You have to enable the updates-testing repo temporarily as noted in comment #28 above, run:

su -c 'yum --enablerepo=updates-testing update nss-softokn'

Did you try this yet?   If it works for you should provide feedback on the update page:

https://admin.fedoraproject.org/updates/nss-softokn-3.12.4-23.fc13

The more positive karma points, the quicker the update will be pushed to stable for everybody else to enjoy.
Comment 35 Phillip Lynn 2010-06-13 15:42:51 EDT
After trying : su -c 'yum --enablerepo=updates-testing update nss-softokn'
the system updated nns-softokn.  Still can not use "sudo yum update" getting the following error now.


Transaction Check Error:
  package nss-3.12.6-7.fc13.x86_64 (which is newer than nss-3.12.6-4.fc13.i686) is already installed
  package nss-softokn-3.12.6-3.fc13.x86_64 (which is newer than nss-softokn-3.12.4-17.fc13.i686) is already installed
Comment 36 Corey Ashford 2010-06-13 16:11:59 EDT
(In reply to comment #35)
> After trying : su -c 'yum --enablerepo=updates-testing update nss-softokn'
> the system updated nns-softokn.  Still can not use "sudo yum update" getting
> the following error now.
> 
> 
> Transaction Check Error:
>   package nss-3.12.6-7.fc13.x86_64 (which is newer than nss-3.12.6-4.fc13.i686)
> is already installed
>   package nss-softokn-3.12.6-3.fc13.x86_64 (which is newer than
> nss-softokn-3.12.4-17.fc13.i686) is already installed    

You could try sudo yum --enablerepo=updates-testing update

or go into the updates-testing repo file (/etc/yum.repos.d/fedora-updates-testing.repo) change all of the enable=0 lines to enable=1 and then run
 sudo yum update
Comment 37 Alex Lancaster 2010-06-13 22:56:59 EDT
I agree with comment #36, but you could pare down the number of updates by trying:

sudo yum --enablerepo=updates-testing update <list of packages you are trying to update> 

that way you shouldn't end up updating everything in updates-testing, some of which you might not want.

(As a side note to the packager: nss-softokn doesn't "Require: nss = %{version}", that seems bad.)
Comment 38 Elio Maldonado Batiz 2010-06-14 09:47:28 EDT
(In reply to comment #37)
> (As a side note to the packager: nss-softokn doesn't "Require: nss =
> %{version}", that seems bad.)    

It does seems to be bad on first sight but it is purposely done that way. nss-softpkn was split off as a stand-alone package to able to release nss and nss-softokn independently of each other. In RHEL there is the need to keep softokn frozen at the last version that received FIPS 140 validation while continuing to upgrade the rest of nss with bug fixes.

As an aside: This time we updated softoken to 3.12.6 because of some N-V-R issues while updating from F-11 (pre-split) to F-12 (post-split) as explained in Bug 601407.
Comment 39 seth vidal 2010-06-16 14:52:30 EDT
*** Bug 604778 has been marked as a duplicate of this bug. ***
Comment 40 Elio Maldonado Batiz 2010-06-17 10:44:27 EDT
*** Bug 604934 has been marked as a duplicate of this bug. ***
Comment 41 Paul Lambert 2010-06-17 14:58:28 EDT
Attempting the updates from the testing repo as stated in comment #34 has made matters even worse.  Still getting transactions errors but many instead of one.  This is a major bug that was reported as early as 5/27 and there is still not a fix.  There is a lot of "guessing" going on as to what the problem is but no answer that totally resolves this upgrade.  In meantime, I am 62 upgrades behind and have no USB or sound for my VMs.  The priority for this bug needs to be escalated.

Test Transaction Errors:   package nss-softokn-freebl-3.12.6-3.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-19.fc13.i686) is already installed
  package nss-3.12.6-7.fc13.x86_64 (which is newer than nss-3.12.6-4.fc13.i686) is already installed
  package nss-softokn-3.12.6-3.fc13.x86_64 (which is newer than nss-softokn-3.12.4-17.fc13.i686) is already installed
Comment 42 Alex Lancaster 2010-06-17 15:33:16 EDT
Apparently this update has been superceded by:

https://admin.fedoraproject.org/updates/nss-3.12.6-7.fc13,nss-softokn-3.12.6-3.fc13?_csrf_token=33dc0f1fe64e7559f6434672e40dd18280920ae1

but the maintainer didn't transfer the bug numbers to this new update, so this bug won't be closed.  Please remember to do this for future updates.
Comment 43 Alex Lancaster 2010-06-17 15:36:48 EDT
(In reply to comment #41)
> Attempting the updates from the testing repo as stated in comment #34 has made
> matters even worse.  Still getting transactions errors but many instead of one.
>  This is a major bug that was reported as early as 5/27 and there is still not
> a fix.  There is a lot of "guessing" going on as to what the problem is but no
> answer that totally resolves this upgrade.  In meantime, I am 62 upgrades
> behind and have no USB or sound for my VMs.  The priority for this bug needs to
> be escalated.
> 
> Test Transaction Errors:   package nss-softokn-freebl-3.12.6-3.fc13.x86_64
> (which is newer than nss-softokn-freebl-3.12.4-19.fc13.i686) is already
> installed
>   package nss-3.12.6-7.fc13.x86_64 (which is newer than nss-3.12.6-4.fc13.i686)
> is already installed
>   package nss-softokn-3.12.6-3.fc13.x86_64 (which is newer than
> nss-softokn-3.12.4-17.fc13.i686) is already installed    

I think you might want:

su -c 'yum --enablerepo=updates-testing update nss nss-softokn'

For some reason it won't necessarily pull in the corresponding nss update to match the nss-softokn build, this is what I was pointing out in comment #37.
Comment 44 Paul Lambert 2010-06-18 10:43:40 EDT
Performed a complete rebuild of FE-13 from DVD image and then updated from repo testing-updates.  I did not encounter any transactions errors.

This is the versions currently installed.  The i686 version is suspicious.
nss-softokn.i686                           3.12.4-17.fc13               fedora  
nss-softokn-devel.i686                     3.12.4-19.fc13               updates 
nss-softokn-devel.x86_64                   3.12.4-19.fc13               updates 
nss-softokn-freebl.i686                    3.12.4-19.fc13               updates 
nss-softokn-freebl-devel.i686              3.12.4-19.fc13               updates 
nss-softokn-freebl-devel.x86_64            3.12.4-19.fc13               updates
Comment 45 Michael Cronenworth 2010-06-18 11:00:08 EDT
(In reply to comment #44)
> then updated from repo testing-updates.

You did not.

$ repoquery --enablerepo=updates-testing nss-softokn*
nss-softokn-0:3.12.6-3.fc13.i686
nss-softokn-0:3.12.6-3.fc13.x86_64
nss-softokn-devel-0:3.12.6-3.fc13.i686
nss-softokn-devel-0:3.12.6-3.fc13.x86_64
nss-softokn-freebl-0:3.12.6-3.fc13.i686
nss-softokn-freebl-0:3.12.6-3.fc13.x86_64
nss-softokn-freebl-devel-0:3.12.6-3.fc13.i686
nss-softokn-freebl-devel-0:3.12.6-3.fc13.x86_64

As root, perform the following:
# yum --enablerepo=updates-testing update nss nss-softokn
Comment 46 Paul Lambert 2010-06-18 12:13:44 EDT
I used Yum to update the entire system of which nss was updated to the latest versions.  Here is the result of running Yum again just for NSS.

[root@BRSINC-01 EB30750]# yum --enablerepo=updates-testing update nss nss-softokn
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
No Packages marked for Update
Comment 47 Elio Maldonado Batiz 2010-06-18 13:48:54 EDT
This updates have caused undue burden, my apologies. 

I'm wondering if I should make a new update with the following two changes:

1. Make sure to transfer the bug numbers to this new update, so this
bug gets tracked and closed. per Comment 44

2. Add requires on nss to nss-spec but slightly diferent than the proposed in Comment 37 because of what I stated on Comment 38. It would be
'Require: nss >= %{version}'

Would that help or is it too late?
Comment 48 Alex Lancaster 2010-06-18 15:08:55 EDT
(In reply to comment #46)
> I used Yum to update the entire system of which nss was updated to the latest
> versions.  Here is the result of running Yum again just for NSS.
> 
> [root@BRSINC-01 EB30750]# yum --enablerepo=updates-testing update nss
> nss-softokn
> Loaded plugins: presto, refresh-packagekit
> Setting up Update Process
> No Packages marked for Update    

You probably have a stale metadata cache.  Try cleaning it first to refresh:

yum clean metadata

then try the update with nss nss-softokn.  The latest in updates-testing should be nss-softokn-0:3.12.6-3.fc13
Comment 49 Sukru TIKVES 2010-06-21 04:12:14 EDT
Finally a workaround for me.

su -c 'yum --enablerepo=updates-testing update nss-softokn'

did not work, however

su -c 'yum --enablerepo=updates-testing install nss-softokn.i686'

did.

Apparently I did not have the i686 versions neither this package nor glibc installed. 

Now I can finally upgrade my system - except for nss, which is broken atm.
Comment 50 Michael Cronenworth 2011-05-13 15:30:51 EDT
(In reply to comment #42)
> Apparently this update has been superceded by:
> 
> https://admin.fedoraproject.org/updates/nss-3.12.6-7.fc13,nss-softokn-3.12.6-3.fc13?_csrf_token=33dc0f1fe64e7559f6434672e40dd18280920ae1
> 
> but the maintainer didn't transfer the bug numbers to this new update, so this
> bug won't be closed.  Please remember to do this for future updates.

Closing bug per update released... 1 year ago.

Note You need to log in before you can comment on or make changes to this bug.