Bug 597320 - no iPhone/iPod access due to incorrect usbmux user name
Summary: no iPhone/iPod access due to incorrect usbmux user name
Status: CLOSED DUPLICATE of bug 593494
Alias: None
Product: Fedora
Classification: Fedora
Component: usbmuxd (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-28 16:08 UTC by Ben Liblit
Modified: 2010-05-28 16:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 16:12:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Liblit 2010-05-28 16:08:27 UTC
Description of problem:

When I plug in my iPhone (via a USB cable), nothing seems to happen on the desktop.  No icon appears, no dialog boxes offer to launch gPhoto and Rhythmbox, etc.

Looking more closely, it seems that udev *does* detect the iPhone.  It runs the rules in "/lib/udev/rules.d/85-usbmuxd.rules", specifically by running the "/usr/sbin/usbmuxd -u -U usbmux" command.  However, this usbmuxd process exits immediately instead of staying around to manage communication with the iPhone.

If I run "/usr/sbin/usbmuxd -u -U usbmux" manually, as root, it also exits immediately and suggests looking in the system log.  In "/var/log/messages" I see "usbmuxd[...]: [0] Dropping privileges failed, check if user 'usbmux' exists!"

Checking "/etc/passwd" shows that user "usbmux" does not exist.  There is, however, a user "usbmuxd", created by the preinstall scriptlet for the usbmuxd rpm.  So it seems that the wrong user name is being used.  Either the usbmuxd daemon should be trying to drop privileges down to user "usbmuxd" instead of "usbmux", or the usbmuxd rpm preinstall scriptlet should be creating a user named "usbmux" instead of "usbmuxd".

Indeed, if I manually rename user "usbmuxd" to "usbmux", then everything else works fine: plugging in an iPhone yields a desktop icon, helpful dialog boxes, etc.  So it's pretty clear that the core of the problem is a simple mismatch between the user names being created and used.  Should be an easy fix!

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Peter Robinson 2010-05-28 16:12:12 UTC

*** This bug has been marked as a duplicate of bug 593494 ***


Note You need to log in before you can comment on or make changes to this bug.