Bug 593494 - rpm creates user/group 'usbmuxd', but it seems to want user/group 'usbmux'
Summary: rpm creates user/group 'usbmuxd', but it seems to want user/group 'usbmux'
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: usbmuxd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 596972 597320 597748 597824 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-18 22:53 UTC by Tom London
Modified: 2010-05-31 09:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-28 10:49:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tom London 2010-05-18 22:53:59 UTC
Description of problem:
I'm noticing this message in /var/log/messages each time I plug in my iPhone:

<<<<SNIP>>>>
May 18 14:42:00 tlondon kernel: usb 1-5.3: Product: iPhone
May 18 14:42:00 tlondon kernel: usb 1-5.3: Manufacturer: Apple Inc.
May 18 14:42:00 tlondon kernel: usb 1-5.3: SerialNumber: 27e03640511c0fcc68f17db232af8c1cd104ac18
May 18 14:42:00 tlondon usbmuxd[16907]: [0] Dropping privileges failed, check if user 'usbmux' exists!
May 18 14:42:01 tlondon kernel: ipheth 1-5.3:4.2: Apple iPhone USB Ethernet device attached
<<<<SNIP>>>>

Checking the rpm, appears that user/group 'usbmuxd' is created:

[root@tlondon ~]# rpm -q --scripts usbmuxd
preinstall scriptlet (using /bin/sh):
getent group usbmuxd >/dev/null || groupadd -r usbmuxd -g 113
getent passwd usbmuxd >/dev/null || \
useradd -r -g usbmuxd -d / -s /sbin/nologin \
	-c "usbmuxd user" -u 113 usbmuxd
exit 0
postinstall program: /sbin/ldconfig
postuninstall program: /sbin/ldconfig
[root@tlondon ~]# 

If I manually create user/group 'usbmux' per the above commands (changing the gid/uid to 114), this messages "goes away":

May 18 15:44:10 tlondon kernel: usb 1-5.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 18 15:44:10 tlondon kernel: usb 1-5.3: Product: iPhone
May 18 15:44:10 tlondon kernel: usb 1-5.3: Manufacturer: Apple Inc.
May 18 15:44:10 tlondon kernel: usb 1-5.3: SerialNumber: 27e03640511c0fcc68f17db232af8c1cd104ac18
May 18 15:44:11 tlondon kernel: ipheth 1-5.3:4.2: Apple iPhone USB Ethernet device attached
May 18 15:44:11 tlondon usbmuxd[19194]: [2] Could not open device 1-12: -3

I still don't get 'automounting' or 'connection to rhythmbox'......


Version-Release number of selected component (if applicable):
usbmuxd-1.0.4-2.fc14.x86_64

How reproducible:
Every time I plug in my iPhone

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Tom London 2010-05-18 23:02:43 UTC
Deleting the newly created user/group 'usbmux', and then renaming 'usbmuxd' -> 'usbmux' seems to "make this all work again"....

Comment 2 Rene Ploetz 2010-05-26 16:59:50 UTC
Wouldn't it be much more easier to add the user usbmuxd and change the udev-rules in /lib/udev/rules.d/85-usbmuxd.rules?

The current problem (it least in F13 as of now) is that we try to run usbmuxd as user "usbmux", which can be corrected easily:
[snip]... RUN+="/usr/sbin/usbmuxd -u -U usbmuxd" ...[/snip]

This would not lead to renaming the user to "usbmux" when the package itself is called "usbmuxd".

Note that we currently state in the release notes that we support iPod/iPhone in F13 out of the box, but this bug prevents the average user to be able use it, so we may want to get this fixed as fast as possible.

Comment 3 Peter Robinson 2010-05-26 19:51:51 UTC
I have been applying a patch to the udev rules for the user. The reason for the usbmuxd user is that its the same as the packge and daemon. I have it on my list to investigate further but I've had other release issues taking up my time.

Comment 4 Bastien Nocera 2010-05-28 10:49:51 UTC
Fixed in usbmuxd 1.0.4-3

I replaced the patch with some sed lines, so this is unlikely to happen in the future :)

Updates are trickling in for F-11, F-12 and F-13 as well.

Comment 5 Tom London 2010-05-28 13:43:31 UTC
Probably OK, but on my system where I had deleted the usbmuxd user/group, and added a usbmux user/group, the package update "failed":

  Updating       : usbmuxd-1.0.4-3.fc14.x86_64                            25/64 
useradd: group 'usbmuxd' does not exist
  Updating       : 1:openoffice.org-math-3.2.1-19.2.fc14.x86_64           26/64

and subsequent "plugging in" of an iPhone got confused:

May 28 06:35:02 tlondon kernel: usb 2-2: Product: iPhone
May 28 06:35:02 tlondon kernel: usb 2-2: Manufacturer: Apple Inc.
May 28 06:35:02 tlondon kernel: usb 2-2: SerialNumber: 27e03640511c0fcc68f17db232af8c1cd104ac18
May 28 06:35:02 tlondon usbmuxd[3724]: [2] Could not open device 2-3: -3
May 28 06:35:02 tlondon kernel: ipheth 2-2:4.2: Apple iPhone USB Ethernet device attached
May 28 06:35:02 tlondon kernel: usbcore: registered new interface driver ipheth

Renaming my usbmux user/group to usbmuxd and then reinstalling worked just fine.

Is this just an aberrant case?

Comment 6 Bastien Nocera 2010-05-28 14:08:40 UTC
Well, if you fiddle with it like that, it breaks. You're not really supposed to rename the usbmuxd user, especially not without changing is gid/uid.

Comment 7 Peter Robinson 2010-05-28 16:12:06 UTC
*** Bug 596972 has been marked as a duplicate of this bug. ***

Comment 8 Peter Robinson 2010-05-28 16:12:12 UTC
*** Bug 597320 has been marked as a duplicate of this bug. ***

Comment 9 Peter Robinson 2010-05-30 11:10:25 UTC
*** Bug 597748 has been marked as a duplicate of this bug. ***

Comment 10 Peter Robinson 2010-05-31 09:03:30 UTC
*** Bug 597824 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.