Bug 59734 - Literal ^L (not CTRL-L) appearing in rpm config.h
Summary: Literal ^L (not CTRL-L) appearing in rpm config.h
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: autoconf   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-02-12 14:04 UTC by Jeff Johnson
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-14 04:35:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Johnson 2002-02-12 14:04:04 UTC
While upgrading rpm to the latest autofoo tools, I noticed
a literal '^L' rather than CTRL-L appearing in config.h.

Poke me if you need more details.

Comment 1 Jens Petersen 2002-02-13 00:45:09 UTC
Looked at rpm-4.0.4-7x.2 and configured with autoconf-2.52-7.
Could see any ^L's (literal or not) in config.h, popt/config.h or
beecrypt/config.h.  So yes, could you give me some details, please. ;-)


Comment 2 Jens Petersen 2002-02-13 00:46:32 UTC
oops, I meant "Couldn't see any ^L's..." above.

Comment 3 Jeff Johnson 2002-02-13 00:54:22 UTC
rpm-4.1, not rpm-4.0.4, from CVS checkout.

    cvs -d :pserver:anonymous@cvs.rpm.org:/cvs/devel login
    (no password, just carriage return)
    cvs -d :pserver:anonymous@cvs.rpm.org:/cvs/devel get rpm
    cd rpm
     ./autogen.sh
and examine config.h. That alone is may not be enough to reproduce,
the ^L's were seen while upgrading to new autotool chain, occurred
after diddling and remerging retrofitted acconfig.h.

Gimme a couple of days to get over the pain of upgrading to
autotools, and I'll try to figger precisely what happened.

A grep for '^L' through autoconf scripts and m4 templates might
popy out the culprit too.

Comment 4 Jens Petersen 2002-02-13 03:10:42 UTC
Ok, I see them in the generated file config.h.in (and hence config.h) too.

But how do these "^L"s hurt you?  Aren't they just page-breaks for Emacs and
friends?

Comment 5 Jeff Johnson 2002-02-13 13:42:11 UTC
A CTRL-L doesn't hurt a bit, but the literal "^L" -- that's caret L --
ain't exactly C, nor is it whitespace.

Comment 6 Jens Petersen 2002-02-14 01:24:55 UTC
Which version of autoconf?  I not seeing any carets with autoconf-2.52-7.

Comment 7 Jens Petersen 2002-02-14 01:34:54 UTC
Don't see them with autoconf-2.52f (autoconf-2.52-5) either.

Comment 8 Jeff Johnson 2002-02-14 03:14:47 UTC
I reproduced this several times today. Hmmm -- checking --
autoconf-2.52-7 was the culprit.

After running autogen.sh as above, try "make", fails in popt
with a compile problem. Both config.h and config.h.in have
the literal "^L", ditto for the main config.h in rpm-4.1.

Comment 9 Jens Petersen 2002-02-14 04:35:30 UTC
I really can't reproduce it on my beta1-ish devel machine here:

% rpm -q autoconf
autoconf-2.52-7
% cvs -d :pserver:anonymous@cvs.rpm.org:/cvs/devel get rpm
:
% cd rpm
% ./autogen.sh
% find . -type d \( -name SCCS -o -name RCS \) -prune -o -type f  -print0 |
xargs -0 -e grep -n  -e \\\^L
Binary file ./bzip2/sample2.bz2 matches
./db/perl/DB_File/Makefile.PL:139:
@(grep "^LIB.*/usr/local/BerkeleyDB" config.in && 	\
./db/test/scr003/chk.define:34:
-e '/^LIST/d' \
./db/test/scr003/chk.define:35:
-e '/^LOG_OP/d' \
% make
:
:
make[1]: Leaving directory `/home/petersen/work/autoconf/59734/rpm'
% rpm -q automake libtool
automake-1.5-8
libtool-1.4.2-5


Something must be different on our machines, but I can't think what.  Is it
possible you could try on a beta1 install?

Btw better to use autoreconf instead of autogen.sh, that is the Right Way these
days.


Note You need to log in before you can comment on or make changes to this bug.