Bug 597583 - Cannot install glibc.i686 on x86_64 Fedora 13 due to dependency problems
Summary: Cannot install glibc.i686 on x86_64 Fedora 13 due to dependency problems
Status: CLOSED DUPLICATE of bug 596840
Alias: None
Product: Fedora
Classification: Fedora
Component: radiusclient-ng   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-29 17:30 UTC by Corey Ashford
Modified: 2010-06-13 15:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 17:24:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Ashford 2010-05-29 17:30:24 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora 13 for x86_64 from Live CD
2. Get all available updates
3. yum install glibc.i686
  
Actual results:

Transaction Check Error:
   package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed.


Expected results:

I would expect this package to install successfully.

Additional info:

Comment 1 Corey Ashford 2010-05-29 17:32:18 UTC
Looks like I left a couple of fields blank.

The description would be the same as the summary.

It reproduces 100% of the time.

Comment 2 Andre Robatino 2010-05-29 21:43:59 UTC
See bug #596840.  It looks like although nss-softokn was updated yesterday - see

http://lists.fedoraproject.org/pipermail/package-announce/2010-May/042083.html

the 32-bit version isn't available yet.  You can download it and install manually from

http://download.fedora.redhat.com/pub/fedora/linux/updates/13/i386/

if you want, or just wait for it to be straightened out.

Comment 3 wdsnyc 2010-06-03 00:53:02 UTC
Isn't this an issue with either the dependency or the transaction check for glib.i686? It appears that glibc.i686 depends on nss-softokn-freebl-3.12.4-17.fc13.i686 yet nss-softokn-freebl-3.12.4-19.fc13.x86_64 installed as a dependency for glibc.x86_64:

yum install glibc.i686
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package glibc.i686 0:2.12-1 set to be updated
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.i686
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.i686
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.12.4-17.fc13 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===========================================================================================================================
 Package                             Arch                  Version                           Repository               Size
===========================================================================================================================
Installing:
 glibc                               i686                  2.12-1                            fedora                  4.3 M
Installing for dependencies:
 nss-softokn-freebl                  i686                  3.12.4-17.fc13                    fedora                  111 k

Transaction Summary
===========================================================================================================================
Install       2 Package(s)
Upgrade       0 Package(s)

Total size: 4.4 M
Installed size: 13 M
Downloading Packages:
Running rpm_check_debug
Running Transaction Test


Transaction Check Error:
  package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed

Error Summary
-------------

Comment 5 Darryl L. Pierce 2010-06-06 13:01:53 UTC
This issue isn't solely an i386 issue. I'm hitting the same issue on an x86_64 desktop trying to install KDE onto an existing system.

Comment 6 Darryl L. Pierce 2010-06-06 13:08:02 UTC
Sorry, should have provided more details.

I have nss-softokn{-freebl} 3.12.4-19 installed on my system:

(mcpierce@mcpierce-work:~)$ rpm -qa nss-softokn*
nss-softokn-freebl-3.12.4-19.fc13.x86_64
nss-softokn-3.12.4-19.fc13.x86_64

and am hitting dependency problems trying to install KDE onto an existing system.

Comment 7 wdsnyc 2010-06-06 23:27:53 UTC
Thanks fabrixx. Running localinstall against the fedora 13 mirrors will allow one to install the 3.12.4-19.fc13.i686 version of nss-softokn-freebl which will allow glibc.i686 to be installed.

But I believe a problem still exists in the yum dependency for glibc.i686. It should be upgraded to nss-softokn-freebl-3.12.4-19.fc13.i686 which corresponds to the x86_64 versions.

Comment 8 Corey Ashford 2010-06-11 17:24:39 UTC

*** This bug has been marked as a duplicate of bug 596840 ***

Comment 9 Phillip Lynn 2010-06-13 15:12:43 UTC
When I attempt to complete a yum update I get the following:
package nss-softokn-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-3.12.4-17.fc13.i686) is already installed

Something is not correct in nss-softokn update process.  I am using linux 64 bit but the system is attempting to update my system with a 32 bit file.


Note You need to log in before you can comment on or make changes to this bug.