Bug 597925 - backtrace when a volumegroup starts with freespace
Summary: backtrace when a volumegroup starts with freespace
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 6.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Hans de Goede
QA Contact: Martin Banas
URL:
Whiteboard: anaconda_trace_hash:ed39ed2eaa515363c...
Keywords:
: 610510 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 02:36 UTC by Zhang Kexin
Modified: 2010-11-10 19:46 UTC (History)
3 users (show)

Fixed In Version: anaconda-13.21.51-1
Doc Type: Bug Fix
Doc Text:
The installer will backtrace (crash) when it encounters a physical volume which contains freespace (space not used by a logical volume) at the beginning of the physicial volume. To work around this create a logical volume using this space before starting the installation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 19:46:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (176.13 KB, text/plain)
2010-05-31 02:36 UTC, Zhang Kexin
no flags Details

Description Zhang Kexin 2010-05-31 02:36:09 UTC
The following was filed automatically by anaconda:
anaconda 13.21.48 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicelibs/lvm.py", line 406, in lvactivate
    raise LVMError("lvactivate failed for %s: %s" % (lv_name, msg))
  File "/usr/lib/anaconda/storage/devices.py", line 2332, in setup
    lvm.lvactivate(self.vg.name, self._name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1529, in handleVgLvs
    lv_device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1964, in _setupLvs
    if self.handleVgLvs(device):
  File "/usr/lib/anaconda/storage/devicetree.py", line 2045, in populate
    if self._setupLvs():
  File "/usr/lib/anaconda/storage/__init__.py", line 379, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 208, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1423, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1336, in nextClicked
    self.setScreen ()
LVMError: lvactivate failed for LVM2_LV_NAME=x64_fc: 11:43:35,618 ERROR   :   One or more specified logical volume(s) not found.

Comment 1 Zhang Kexin 2010-05-31 02:36:14 UTC
Created attachment 418140 [details]
Attached traceback automatically from anaconda.

Comment 3 Chris Lumens 2010-06-01 14:13:45 UTC
We probably shouldn't be including "LVM2_LV_NAME=" in the name of the logical volume we're trying to activate.

Comment 7 Hans de Goede 2010-06-02 15:55:24 UTC
We've a patch fixing this granting devel ack. We should really fix this for 6.0, this will happen whenever there is a pre-existing VG which has some freespace at the beginning of one of its pvs.

Comment 8 Hans de Goede 2010-06-07 12:27:02 UTC
Technical note added. If any revisions are required, please edit the "Technical Notes" field
accordingly. All revisions will be proofread by the Engineering Content Services team.

New Contents:
The installer will backtrace (crash) when it encounters a physical volume which contains freespace (space not used by a logical volume) at the beginning of the physicial volume. To work around this create a logical volume using this space before starting the installation.

Comment 9 Hans de Goede 2010-06-12 13:02:20 UTC
This is fixed in anaconda-13.21.51-1, moving to modified.

Comment 11 Martin Banas 2010-07-02 08:13:21 UTC
Verified on build RHEL6.0-20100701.0 with anaconda-13.21.56-1.el6. Closing the bug.

Comment 12 Chris Lumens 2010-07-07 18:26:46 UTC
*** Bug 610510 has been marked as a duplicate of this bug. ***

Comment 14 releng-rhel@redhat.com 2010-11-10 19:46:24 UTC
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.