Bug 598079 - [abrt] calibre-0.6.55-1.fc14: output.py:380:workaround_ade_quirks:AttributeError: 'CSSRuleList' object has no attribute 'rulesOfType'
[abrt] calibre-0.6.55-1.fc14: output.py:380:workaround_ade_quirks:AttributeEr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
abrt_hash:12088fff
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 07:43 EDT by Stephen
Modified: 2010-10-05 09:24 EDT (History)
13 users (show)

See Also:
Fixed In Version: calibre-0.7.20-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-05 09:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (2.04 KB, text/plain)
2010-05-31 07:43 EDT, Stephen
no flags Details

  None (edit)
Description Stephen 2010-05-31 07:43:01 EDT
abrt version: 1.1.4
architecture: x86_64
Attached file: backtrace
cmdline: python /usr/bin/calibre-parallel
component: calibre
executable: /usr/bin/calibre-parallel
kernel: 2.6.34-11.fc14.x86_64
package: calibre-0.6.55-1.fc14
reason: output.py:380:workaround_ade_quirks:AttributeError: 'CSSRuleList' object has no attribute 'rulesOfType'
release: Fedora release 14 (Rawhide)

How to reproduce
-----
1. Running a scheduled news download from the independent
2.
3.
Comment 1 Stephen 2010-05-31 07:43:04 EDT
Created attachment 418272 [details]
File: backtrace
Comment 2 Kevin Fenzi 2010-06-02 13:20:34 EDT
Stephen: This looks like http://bugs.calibre-ebook.com/ticket/5422 upstream. 
It's only fixed in an even NEWER python-cssutils. ;( 

Which we can't ship yet since it's alpha. ;( 
Sorry about this. I could make you a scratch build of it perhaps... or we can
hope they push out the final soon.
Comment 3 Stephen 2010-06-05 07:41:13 EDT
Package: calibre-0.6.55-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Attempted to download scheduled News from Independent.co.uk
2. At 47% done crash occurred
3.
Comment 4 Frank Murphy 2010-06-06 06:01:19 EDT
Package: calibre-0.7.0-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Convert pdf book to epub
2. 
3.
Comment 5 Frank Murphy 2010-06-06 06:07:17 EDT
(In reply to comment #2)
> Stephen: This looks like http://bugs.calibre-ebook.com/ticket/5422 upstream. 
> It's only fixed in an even NEWER python-cssutils. ;( 
> 
> Which we can't ship yet since it's alpha. ;( 
> Sorry about this. I could make you a scratch build of it perhaps... or we can
> hope they push out the final soon.    

I'd appreciate a scratch Kevin, if anything just to test.
testing against: calibre-0.7.0-1.fc14
Comment 6 Kevin Fenzi 2010-06-06 21:29:18 EDT
F-13 scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2234425
rawhide scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2234427

Please do let me know if it fixes this issue (as the upstream bug indicates).
Comment 7 Frank Murphy 2010-06-07 05:18:21 EDT
(In reply to comment #6)
> F-13 scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2234425
> rawhide scratch build:
> http://koji.fedoraproject.org/koji/taskinfo?taskID=2234427
> 
> Please do let me know if it fixes this issue (as the upstream bug indicates).    


This appears to have fixed this bug for me on  calibre-0.7.0-1.fc14 

It still crashed out with another bug abrt added me to a cc of:
https://bugzilla.redhat.com/show_bug.cgi?id=559484
Comment 8 Kevin Fenzi 2010-06-07 18:12:50 EDT
I'll leave this open until 0.9.7 cssutils comes out then. 
Thanks.
Comment 9 Frank Murphy 2010-06-22 03:59:27 EDT
Package: calibre-0.7.4-1.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Rawhide)


How to reproduce
-----
1. Convert PDF book to epub
Comment 10 Kyryl Bilokurov 2010-06-23 16:54:17 EDT
Package: calibre-0.6.55-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. attempted to convert pdf to epub with kindle profile on
2.
3.
Comment 11 Patrick C. F. Ernzer 2010-07-15 05:48:35 EDT
the scratch build 2234425 has expired on koji. Can you please trigger another build?
Comment 12 Kevin Fenzi 2010-07-15 21:40:45 EDT
Absolutely: http://koji.fedoraproject.org/koji/taskinfo?taskID=2323226 is a new caliber build, and http:  http://koji.fedoraproject.org/koji/taskinfo?taskID=2323239 is a new python-cssutils 0.9.7b3 build. 

Please do test.
Comment 13 Patrick C. F. Ernzer 2010-07-17 07:18:51 EDT
The combination
 calibre-0.7.8-1.fc13.x86_64
 python-cssutils-0.9.7-0.b3.fc13.noarch
works for PDF handling. Sending all my PDF to the PRS-505 and converting 3 PDF to EPUB worked fine.

But, I have experienced a new failure with those versions, it's entered as Bug 615602.
Comment 14 Kyryl Bilokurov 2010-07-17 19:07:15 EDT
I can also confirm that conversion of PDF to MOBI and EPUB works OK with the new build.

Regards,
Kyryl
Comment 15 Bug Zapper 2010-07-30 07:46:05 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Johnny 2010-08-06 06:30:43 EDT
Package: calibre-0.6.55-1.fc13
Architecture: x86_64
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. I was just trying to fetch the news AKA Linux Magazine
2.
3.


Comment
-----
Maybe Fedora 13 is not ready for general everyday use.
Comment 17 Frank Murphy 2010-08-06 07:23:48 EDT
(In reply to comment #16)
> Package: calibre-0.6.55-1.fc13
> Architecture: x86_64
> OS Release: Fedora release 13 (Goddard)
> 
> 
> How to reproduce
> -----
> 1. I was just trying to fetch the news AKA Linux Magazine
> 2.
> 3.
> 
> 
> Comment
> -----
> Maybe Fedora 13 is not ready for general everyday use.    

Can you upgrade to latest from:
https://bugzilla.redhat.com/show_bug.cgi?id=620966#c2

and re-test.
If any errors can you attach to bug.
Comment 18 Alina Silvestrovici Paun 2010-08-31 13:54:28 EDT
Package: calibre-0.6.55-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
1. I was trying to download news. I selected the newsources and chose download now. 
2. While the source was downloading, calibre crashed. 
3.
Comment 19 Fedora Update System 2010-09-15 16:13:37 EDT
calibre-0.7.18-3.fc14,python-cssutils-0.9.7-0.0.b3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/calibre-0.7.18-3.fc14,python-cssutils-0.9.7-0.0.b3.fc14
Comment 20 Fedora Update System 2010-09-15 23:28:06 EDT
calibre-0.7.18-3.fc14, python-cssutils-0.9.7-0.0.b3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update calibre python-cssutils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/calibre-0.7.18-3.fc14,python-cssutils-0.9.7-0.0.b3.fc14
Comment 21 Fedora Update System 2010-10-05 09:23:59 EDT
calibre-0.7.20-1.fc14, python-cssutils-0.9.7-0.0.b3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.