Bug 615602 - xkcd recipe non-functional in 0.7.8-1
xkcd recipe non-functional in 0.7.8-1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: calibre (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-17 07:16 EDT by Patrick C. F. Ernzer
Modified: 2011-01-22 15:32 EST (History)
6 users (show)

See Also:
Fixed In Version: calibre-0.7.38-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-22 15:28:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full error output from calibre (45.25 KB, text/plain)
2010-07-17 07:17 EDT, Patrick C. F. Ernzer
no flags Details

  None (edit)
Description Patrick C. F. Ernzer 2010-07-17 07:16:14 EDT
Description of problem:
xkcd recipe fails with
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 22: ordinal not in range(128)

Version-Release number of selected component (if applicable):
 calibre-0.7.8-1.fc13.x86_64
 python-cssutils-0.9.7-0.b3.fc13.noarch
because of Bug 598079 I have these two scratch builds installed.

How reproducible:
always

Steps to Reproduce:
1. update to the scratch builds from https://bugzilla.redhat.com/show_bug.cgi?id=598079#c12
2. attempt to use the built-in xkcd recipe
  
Actual results:
ERROR: Conversion Error

Expected results:
xkcd EPUB created

Additional info:
Comment 1 Patrick C. F. Ernzer 2010-07-17 07:17:25 EDT
Created attachment 432574 [details]
full error output from calibre
Comment 2 Frank Murphy 2010-07-17 07:38:11 EDT
Looking at this, it may be there is nothing to convert?
Is there any other feed you can test?
Comment 3 Patrick C. F. Ernzer 2010-07-17 12:09:25 EDT
"Skipping article Blogging (Mon, 17 May, 2010 00:00) from feed xkcd as it is too old." seems to be the newest skipped article.

http://xkcd.com/archive/ has 26 newer ones at this moment.
Comment 4 Frank Murphy 2010-07-17 12:41:52 EDT
Hi Patrick,

Can't seem to reproduce this on F12, or 13 at the moment.
What I have done is gone into:
Fetch News  > Schedule News > English (added all non user\pw\ ones) to schedule)
Then clicked "download now"
downloaded ok
And all opened when highlighted, view clicked.

Can you guide me through the steps you took?
Comment 5 Patrick C. F. Ernzer 2010-07-17 14:25:39 EDT
In response to Comment #4

I do this;
Fetch News  > Schedule News > search 'xkcd'
when search completed, trigger download.

Your steps should have given you xkcd too as it is under English.

Can you verify you did grab xkcd and can you verify that your target format was epub (I suspect the latter might make a difference)
Comment 6 Frank Murphy 2010-07-17 14:40:34 EDT
Doing it as #5 did get the same crash.
Comment 7 Frank Murphy 2010-07-17 14:52:18 EDT
If you need xkcd at the moment try adding:
http://xkcd.com/archive/

as a custom news service.
Just tested and it didn't crash,
will check upstream for similar.

Thank for the help Patrick.
Comment 8 Frank Murphy 2010-07-18 07:34:54 EDT
This is purely a Fedora Bug, upstream install does *not* have this bug
(Tested on F13)
Similar upstream bugs were previously closed "worksforme"

Bug also exists on F12.

Rawhide version of this bug:
https://bugzilla.redhat.com/show_bug.cgi?id=615738

xkcd feed is ok in itself, 
tested in Liferea.



Kevin?
Comment 9 Kevin Fenzi 2010-07-18 13:58:09 EDT
Right. The problem here is that one of the xkcd titles is UTF8, and the debug output where it says it's not taking something because it's so old can't understand the UTF8 title and blows up. 

I don't know why yet the upstream version doesn't show this. It could be a customization they have in their local cssutils. I can look at reporting it upstream or trying to make a patch.
Comment 10 Gwyn Ciesla 2010-07-27 11:35:42 EDT
I see this too.  My feeds for Open Left, LWN, and The Nation fail as well, with similar looking errors.
Comment 11 Gwyn Ciesla 2010-07-27 11:37:17 EDT
http://xkcd.com/archive/ fails also.
Comment 12 Kevin Fenzi 2010-07-27 12:27:55 EDT
My local repo at http://www.scrye.com/~kevin/fedora/calibre/ has 0.7.10 if you want to try that and confirm that it's still not working there?
Comment 13 Gwyn Ciesla 2010-07-28 09:20:58 EDT
Confirmed, still not working.
Comment 14 Patrick C. F. Ernzer 2010-07-29 03:38:56 EDT
Can confirm as well that
 calibre-0.7.10-1.fc13.x86_64
 python-cssutils-0.9.7-0.b3.fc13.noarch
does not fix the problem
Comment 15 Gwyn Ciesla 2010-11-22 11:14:23 EST
As of F-14, this works.
Comment 16 Kevin Fenzi 2010-11-22 11:33:18 EST
Excellent. That means the one in my repos fixes it for f13 as well hopefully. 

Can anyone confirm?

http://repos.fedoraproject.org/kevin/calibre/
Comment 17 Frank Murphy 2010-11-22 12:24:57 EST
(In reply to comment #16)
> Excellent. That means the one in my repos fixes it for f13 as well hopefully. 
> 
> Can anyone confirm?
> 
> http://repos.fedoraproject.org/kevin/calibre/


Confirmed with 7.29 on F13 guest
Comment 18 Patrick C. F. Ernzer 2010-11-23 09:41:19 EST
I can also confirm that on F14 with
 calibre-0.7.23-1.fc14.x86_64
 python-cssutils-0.9.7-0.0.b3.fc14.noarch
the bug is fixed.
Thanks
Comment 19 Kevin Fenzi 2010-11-23 16:20:26 EST
ok. Now to see if I can get a f13/f14 update out. Thanks for the testing.
Comment 20 Fedora Update System 2011-01-12 19:07:34 EST
calibre-0.7.38-3.fc14,python-cssutils-0.9.7-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/calibre-0.7.38-3.fc14,python-cssutils-0.9.7-1.fc14
Comment 21 Fedora Update System 2011-01-12 19:19:18 EST
calibre-0.7.38-3.fc13,python-cssutils-0.9.7-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/calibre-0.7.38-3.fc13,python-cssutils-0.9.7-1.fc13
Comment 22 Fedora Update System 2011-01-13 18:25:32 EST
calibre-0.7.38-3.fc13, python-cssutils-0.9.7-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update calibre python-cssutils'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/calibre-0.7.38-3.fc13,python-cssutils-0.9.7-1.fc13
Comment 23 Fedora Update System 2011-01-22 15:27:11 EST
calibre-0.7.38-3.fc13, python-cssutils-0.9.7-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2011-01-22 15:31:11 EST
calibre-0.7.38-3.fc14, python-cssutils-0.9.7-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.