Bug 598095 - AS4 plugin detects 2nd pair of TC connectors when IP address changes
Summary: AS4 plugin detects 2nd pair of TC connectors when IP address changes
Status: CLOSED WONTFIX
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins   
(Show other bugs)
Version: 3.0.0
Hardware: All
OS: All
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
: 606641 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-05-31 12:30 UTC by Heiko W. Rupp
Modified: 2014-05-29 18:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 18:15:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Heiko W. Rupp 2010-05-31 12:30:08 UTC
Start an AS 4 with binding to 1 address on an interface, take it into inventory.
Later when everything is green, shut down the AS, bind it to a different IP (with -b) and start it again.
See that it stays red and no new AS is discovered. Then go to its connection properties on the inventory tab and change its IP to the new one.
The server should green again. Now check for downed resources and find its connectors (8080 / 8009) being down and two new connectors for the same ports but different IP showing up.

The connectors should detect the IP change by looking at the grand parent (=AS) port and change the accrodingly, and not create new resources.

Comment 1 Heiko W. Rupp 2010-05-31 12:43:09 UTC
Same applies to the AS5 plugin

Comment 2 Corey Welton 2010-09-24 12:45:16 UTC
ips, how would you go about fixing this?

Comment 3 Corey Welton 2010-09-24 13:17:04 UTC
*** Bug 606641 has been marked as a duplicate of this bug. ***

Comment 4 Ian Springer 2010-09-24 23:08:13 UTC
The default JBossWeb server.xml file contains the following:

<Connector protocol="HTTP/1.1" port="${jboss.web.http.port}" address="${jboss.bind.address}" 
               connectionTimeout="20000" redirectPort="${jboss.web.https.port}" 
/>

so by default the connector address is the same as the app server's bind address, but this is not necessarily always the case. 

The connector's address is part of the connector Resource's Resource key, and even once we've added support for Resource key upgrades, I don't think we should change this.

If users want to avoid such issues, they could probably bind the app server to a hostname, rather than an IP address.


Note You need to log in before you can comment on or make changes to this bug.