Bug 606641 - multiple connectors get created when time is changed on the rhq server
Summary: multiple connectors get created when time is changed on the rhq server
Status: CLOSED DUPLICATE of bug 598095
Alias: None
Product: RHQ Project
Classification: Other
Component: Communications Subsystem   
(Show other bugs)
Version: 3.0.0
Hardware: All Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-22 06:38 UTC by Sudhir D
Modified: 2010-09-24 13:17 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-24 13:17:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Multiple connectors post system time change. (182.23 KB, image/png)
2010-06-22 06:38 UTC, Sudhir D
no flags Details

Description Sudhir D 2010-06-22 06:38:35 UTC
Created attachment 425835 [details]
Multiple connectors post system time change.

Description of problem:
The rhq server system time was out of sync and when I synced to ntp and restarted rhq, created another set of connectors and the old ones now show down and report under "Has Alerts or Currently Unavailable" in Dashboard

Version-Release number of selected component (if applicable):
jon-server-2.4.0.GA_QA 

How reproducible:
Always

Steps to Reproduce:
1. Install and configure rhq server on a non synced ntp server.
2. Sync the server, which is running rhq, to ntp and restart rhq.
3. Check the dashboard under "Has Alerts or Currently Unavailable"
  
Actual results:
The connectors show down for 7080 and 7443. However, when we check under Resources->Connector, we can see that there is a new set of connector that is created and the old ones show as down.

Expected results:
The old one should be removed, if the new connectors are automatically created. If not the old ones should be re-used instead of creating new.

Additional info:

Comment 1 Corey Welton 2010-09-24 13:17:04 UTC

*** This bug has been marked as a duplicate of bug 598095 ***


Note You need to log in before you can comment on or make changes to this bug.