This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 598145 - CPU usage of gdm-user-switch (100% CPU for N minutes)
CPU usage of gdm-user-switch (100% CPU for N minutes)
Status: CLOSED DUPLICATE of bug 598483
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-applets (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ray Strode [halfline]
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 10:53 EDT by Matthias Schroder
Modified: 2010-06-22 14:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-22 14:12:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthias Schroder 2010-05-31 10:53:09 EDT
Description of problem: gdm-user-switch needs too much CPU


Version-Release number of selected component (if applicable): 2.28.2-5.el6.x86_64


How reproducible: 100%


Steps to Reproduce:
1. create password file with many entries
2. login
3. run top or ps
  
Actual results: gdm-user-switch takes almost 100% CPU time for quite a long time.


Expected results: less greedy gdm-user-switch


Additional info: I made tests with various sized /etc/passwd files:

# entries   CPU minutes
2000        ~1
4000        ~4:37
8000        ~20:46
Comment 2 RHEL Product and Program Management 2010-06-07 12:01:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 jmccann 2010-06-22 14:12:51 EDT

*** This bug has been marked as a duplicate of bug 598483 ***

Note You need to log in before you can comment on or make changes to this bug.