Bug 598210 - [abrt] crash in ristretto-0.0.22-3.fc13: IA__g_object_unref: Process /usr/bin/ristretto was killed by signal 11 (SIGSEGV)
[abrt] crash in ristretto-0.0.22-3.fc13: IA__g_object_unref: Process /usr/bin...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: ristretto (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:4d81f6c89cdc8bf3f9ea137e4fd...
:
: 603511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 14:46 EDT by Rasmus Dall
Modified: 2010-07-16 10:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-16 10:26:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.03 KB, text/plain)
2010-05-31 14:46 EDT, Rasmus Dall
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 6493 None None None Never

  None (edit)
Description Rasmus Dall 2010-05-31 14:46:29 EDT
abrt 1.1.0 detected a crash.

architecture: i686
Attached file: backtrace
cmdline: ristretto '/home/Rasmus/Pictures/Highlands 09 Paaske/Isle of Skye_064.JPG'
comment: I was browsing pictures and wanted to close ristretto, had just pressed page down to see the next picture but closed ristretto before it loaded.
component: ristretto
crash_function: IA__g_object_unref
executable: /usr/bin/ristretto
global_uuid: 4d81f6c89cdc8bf3f9ea137e4fde6ceb71933cfb
kernel: 2.6.33.4-95.fc13.i686
package: ristretto-0.0.22-3.fc13
rating: 4
reason: Process /usr/bin/ristretto was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Open Ristretto
2. Browse pictures
3. Cloe Ristretto while it is loading a picture
Comment 1 Rasmus Dall 2010-05-31 14:46:32 EDT
Created attachment 418371 [details]
File: backtrace
Comment 2 Christoph Wickert 2010-06-07 11:37:09 EDT
Thanks for your report. I have forwarded it upstream as
http://bugzilla.xfce.org/show_bug.cgi?id=6493

You will be notified once the bug is resolved in Fedora. Feel free to also subscribe to the upstream bug report.
Comment 3 Christoph Wickert 2010-07-04 18:19:11 EDT
*** Bug 603511 has been marked as a duplicate of this bug. ***
Comment 4 Christoph Wickert 2010-07-16 10:26:21 EDT
According to upstream there is not much he can do to fix this without a major
rewrite of ristretto. The rewrite is in progress and ristretto 0.1.0 will be
included in Fedora 14.

I'm now closing the bug UPSTREAM because this is where further investigation should take place. Thanks for reporting this bug.

Note You need to log in before you can comment on or make changes to this bug.