Bug 598358 - Unable to login to KDE with SWcursor enabled in X.org
Unable to login to KDE with SWcursor enabled in X.org
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
6.3
All Linux
low Severity high
: rc
: ---
Assigned To: Jérôme Glisse
Desktop QE
: Triaged
Depends On:
Blocks: 842499
  Show dependency treegraph
 
Reported: 2010-06-01 03:54 EDT by Miroslav Suchý
Modified: 2012-10-22 10:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 10:45:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (2.33 KB, text/plain)
2010-06-02 04:56 EDT, Miroslav Suchý
no flags Details
comment #8 xorg.log, syslog, kdm.log (52.06 KB, text/plain)
2010-07-26 19:39 EDT, Zenon Panoussis
no flags Details
comment #8 abrt dumps (605.46 KB, application/x-bzip2)
2010-07-26 19:40 EDT, Zenon Panoussis
no flags Details
comment #8 xorg.conf (1.42 KB, text/plain)
2010-07-26 19:42 EDT, Zenon Panoussis
no flags Details

  None (edit)
Description Miroslav Suchý 2010-06-01 03:54:56 EDT
Description of problem:
I yesterday upgraded and I'm now unable to log in to KDE using KDM. I can however log into Gnome of Failsafe mode.

Version-Release number of selected component (if applicable):
# rpm -qa |grep kdm
kde-settings-kdm-4.3.1-1.el6.noarch
kdm-4.3.4-17.el6.x86_64
# rpm -qa |grep kde
kdepimlibs-4.3.4-4.el6.x86_64
kdegraphics-4.3.4-6.el6.x86_64
kdebase-workspace-wallpapers-4.3.4-17.el6.noarch
kde-settings-pulseaudio-4.3.1-1.el6.noarch
kdepim-4.3.4-5.el6.x86_64
kdeplasma-addons-4.3.4-4.el6.x86_64
kdeutils-libs-4.3.4-5.el6.x86_64
kdeartwork-screensavers-4.3.4-4.el6.x86_64
kdelibs-4.3.4-7.el6.x86_64
constantine-backgrounds-kde-12.1.0-1.fc12.noarch
kdenetwork-libs-4.3.4-8.el6.x86_64
kdenetwork-4.3.4-8.el6.x86_64
kde-filesystem-4-30.1.el6.noarch
constantine-kde-theme-12.1.0-1.fc12.noarch
kde-plasma-ihatethecashew-0.3-3.fc12.x86_64
kde-settings-kdm-4.3.1-1.el6.noarch
kdegraphics-libs-4.3.4-6.el6.x86_64
kdelibs-experimental-4.3.4-3.el6.x86_64
kdebase-runtime-libs-4.3.4-7.el6.x86_64
kdepimlibs-akonadi-4.3.4-4.el6.x86_64
kdemultimedia-libs-4.3.4-3.el6.x86_64
kdemultimedia-4.3.4-3.el6.x86_64
kdeadmin-4.3.4-4.el6.x86_64
kdelibs-common-4.3.4-7.el6.x86_64
kdelibs-devel-4.3.4-7.el6.x86_64
kdebase-runtime-4.3.4-7.el6.x86_64
kdebase-libs-4.3.4-4.el6.x86_64
kdeplasma-addons-libs-4.3.4-4.el6.x86_64
kde-plasma-translatoid-1.0-1.fc12.x86_64
kdeutils-4.3.4-5.el6.x86_64
kdebase-4.3.4-4.el6.x86_64
kdebase-workspace-4.3.4-17.el6.x86_64
kdepim-libs-4.3.4-5.el6.x86_64
kdebase-workspace-libs-4.3.4-17.el6.x86_64
kdelibs3-3.5.10-21.el6.x86_64
lockdev-1.0.1-18.el6.x86_64
kde-settings-4.3.1-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. upgrade to nighlty 
2. reboot
3. in kdm choose KDE as your environment
  
Actual results:
screen blink and take me back to KDM

Expected results:
log in to KDE

Additional info:
#tail /var/log/messages
Jun  1 09:14:50 dri kdm_greet[1812]: Cannot load /usr/share/kde4/apps/kdm/faces/.default.face: No such file or directory
Jun  1 09:15:09 dri kdm[1415]: X server for display :0 terminated unexpectedly
Jun  1 09:15:10 dri kdm_greet[1980]: Cannot load /usr/share/kde4/apps/kdm/faces/.default.face: No such file or directory

#ls /usr/share/kde4/apps/kdm/
patterns  pics  programs  themes

# yum whatprovides /usr/share/kde4/apps/kdm/faces
Loaded plugins: multithread, refresh-packagekit, rhsmplugin
brew/filelists_db                                                                     | 3.3 kB     00:00
rhel6/filelists_db                                                                    | 3.8 MB     00:00
rhel6-ap/filelists_db                                                                 | 3.8 MB     00:00
rhts/filelists                                                                        |  78 kB     00:00
No Matches found


#tail /var/log/kdm.log
X.Org X Server 1.7.7
Release Date: 2010-05-04
X Protocol Version 11, Revision 0
Build Operating System: x86-004 2.6.18-194.3.1.el5
Current Operating System: Linux dri.englab.brq.redhat.com 2.6.32-31.el6.x86_64 #1 SMP Thu May 27 18:26:27 EDT 2010 x86_64
Kernel command line: ro root=/dev/mapper/VolGroup00-rhel6  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us quiet rhgb
Build Date: 30 May 2010  08:21:00PM
Build ID: xorg-x11-server 1.7.7-3.el6
Current version of pixman: 0.16.6
        Before reporting problems, check https://www.redhat.com/apps/support/
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue Jun  1 09:14:48 2010
(==) Using config file: "/etc/X11/xorg.conf"
(II) [KMS] Kernel modesetting enabled.
(II) [KMS] Kernel modesetting enabled.
(EE) RADEON(1):  reusing fd for second head
SELinux: Disabled on system, not enabling in X server

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x4696f8]
1: /usr/bin/X (0x400000+0x65819) [0x465819]
2: /lib64/libpthread.so.0 (0x7f6f749d8000+0xf440) [0x7f6f749e7440]
3: /usr/bin/X (xf86_reload_cursors+0x56) [0x51cd66]
4: /usr/lib64/xorg/modules/drivers/radeon_drv.so (0x7f6f712cc000+0xda872) [0x7f6f713a6872]
5: /usr/bin/X (xf86CrtcSetModeTransform+0x14c) [0x48374c]
6: /usr/bin/X (0x400000+0x11b088) [0x51b088]
7: /usr/bin/X (RRCrtcSet+0x99) [0x4a83e9]
8: /usr/bin/X (ProcRRSetScreenConfig+0x508) [0x559118]
9: /usr/bin/X (0x400000+0xa6499) [0x4a6499]
10: /usr/bin/X (0x400000+0x35efc) [0x435efc]
11: /usr/bin/X (0x400000+0x21ffa) [0x421ffa]
12: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7f6f73629c5d]
13: /usr/bin/X (0x400000+0x21bb9) [0x421bb9]
Segmentation fault at address 0x4

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting


Please consult the Red Hat support
         at https://www.redhat.com/apps/support/
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.



In /var/log/Xorg.0.log is the same backtrace. No usefull EE or WW message.
Comment 1 RHEL Product and Program Management 2010-06-01 03:55:44 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Miroslav Suchý 2010-06-01 07:06:37 EDT
After more investigation I find this is not problem in kdm. Even if I start X manualy and run startkde it will throw this traceback and Xwindow segfault.

When I commented in xorg.conf line:
 Option "SWcursor" "true"
I was able to login and this traceback do not appear again.

Rasigning to xorg-x11-drv-ati
Comment 3 Miroslav Suchý 2010-06-02 04:56:33 EDT
Created attachment 418962 [details]
xorg.conf
Comment 6 Jérôme Glisse 2010-06-14 10:42:41 EDT
Can't reproduce it, please attach full Xorg log, also what is your GPU.
Comment 7 RHEL Product and Program Management 2010-07-15 10:46:20 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 8 Zenon Panoussis 2010-07-26 19:38:20 EDT
I'm having the same problem: can't log in to KDE, exactly the same symptoms as noteded in the first two lines of the bug description. 

The solution of comment #2 didn't work for me; setting SWcursor to true or false makes no difference. 

Attaching: Xorg.log, syslog, kdm.log and abrt logs and dumps, including core.
Comment 9 Zenon Panoussis 2010-07-26 19:39:45 EDT
Created attachment 434563 [details]
comment #8 xorg.log, syslog, kdm.log
Comment 10 Zenon Panoussis 2010-07-26 19:40:49 EDT
Created attachment 434564 [details]
comment #8 abrt dumps
Comment 11 Zenon Panoussis 2010-07-26 19:42:13 EDT
Created attachment 434565 [details]
comment #8 xorg.conf
Comment 12 Jérôme Glisse 2010-07-27 09:21:39 EDT
Zenon you are facing a different issue, it seems that your having an issue with synaptics, please open a new bug against synaptic
Comment 13 Zenon Panoussis 2010-07-27 10:44:57 EDT
(In reply to comment #12)

> Zenon you are facing a different issue, it seems that your having an issue with
> synaptics, please open a new bug against synaptic    

It's not  synaptics, but indeed it's not xorg-x11-drv-ati either. Moved to https://bugzilla.redhat.com/show_bug.cgi?id=618690 .
Comment 15 Miroslav Suchý 2011-01-12 03:31:05 EST
In meanwhile I upgraded to Fedora14. Therefore I'm unable to reproduce it on my machine.
Comment 23 Jérôme Glisse 2011-10-24 17:15:28 EDT
Moving to 6.3
Comment 26 RHEL Product and Program Management 2012-07-10 02:00:35 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 27 RHEL Product and Program Management 2012-07-10 22:05:41 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 31 Miroslav Suchý 2012-09-12 18:05:10 EDT
Yes. Dual screen. HW was ATI card, which I gave to tpelka.
Comment 32 Tomas Pelka 2012-09-13 03:03:07 EDT
(In reply to comment #31)
> Yes. Dual screen. HW was ATI card, which I gave to tpelka.

I can confirm I got the graphics.
Comment 33 Jérôme Glisse 2012-09-13 13:44:47 EDT
Which ati ? :)
Comment 34 Tomas Pelka 2012-09-14 04:13:32 EDT
(In reply to comment #33)
> Which ati ? :)

Radeon X500 [RV380] PCIe.
Comment 35 Jérôme Glisse 2012-10-04 14:27:46 EDT
Still can't reproduce is there a special kde configuration ? Like one screen rotated ?
Comment 36 Jérôme Glisse 2012-10-11 16:42:47 EDT
Can you try if you still can trigger it with 6.4 nightly ?
Comment 37 Miroslav Suchý 2012-10-12 06:32:04 EDT
I do not use RHEL6 on my workstation anymore. So I could not test it, sorry.
Comment 40 Jérôme Glisse 2012-10-15 10:30:02 EDT
Tomas if you could test with 6.4 it would be nice.
Comment 42 Tomas Pelka 2012-10-21 14:52:27 EDT
(In reply to comment #40)
> Tomas if you could test with 6.4 it would be nice.

Jerome, sorry for my late response. I wasn't able to reproduce either.

I would be fine with close too.
Comment 43 Denise Dumas 2012-10-22 10:45:50 EDT
Since this is not reproducing, I am closing it worksforme. If this problem reappears, please reopen this bz with detailed information on how it occurred. Thanks.

Note You need to log in before you can comment on or make changes to this bug.