Bug 598423 - Add Asturian to list of languages when using system-config-language
Summary: Add Asturian to list of languages when using system-config-language
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-language
Version: 13
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Naveen Kumar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-01 11:46 UTC by ivarela
Modified: 2010-07-29 05:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-07-29 05:48:46 UTC


Attachments (Terms of Use)
picture showing the correct place for "Asturian" language in the list (89.46 KB, image/png)
2010-06-01 11:46 UTC, ivarela
no flags Details
Patch for this bug. (3.73 KB, patch)
2010-06-18 06:31 UTC, Naveen Kumar
no flags Details | Diff

Description ivarela 2010-06-01 11:46:35 UTC
Created attachment 418598 [details]
picture showing the correct place for "Asturian" language in the list

Description of problem:
Can't select "Asturian" language in the list when using "system-config-language"

Version-Release number of selected component (if applicable):
Fedora 13

How reproducible:


Steps to Reproduce:
1.Open terminal
2.type: system-config-language
3.
  
Actual results:
"Asturian (Spain)" language, doesn't appear in the list

Expected results:
"Asturian" Iso code "ast", must be appears between "Assamese (India)" and "Basque (Spain)" languages

Additional info:

Comment 1 Pravin Satpute 2010-06-02 03:19:29 UTC
ivarela thanks for reporting bug, will do this
locale code for Asturian (Spain) is ast_ES, need to update locale-list file for this locale

Comment 2 ivarela 2010-06-02 06:45:32 UTC
Hi Pravin.

Of course, you know which code is better. But I think that "ast" is the correct code, because "Asturian" is only spoken in Spain (then it's no neccessary specify the _ES ). As you can see, Debian, Ubuntu, Fedora, Gnome, Mozilla, KDE uses only "ast". IMHO using the same code avoids problems with other platforms

I provide you some links to make it you easy  ;)
Regards.

[DEBIAN] http://www.debian.org/international/l10n/po/ast

[GNOME] http://l10n.gnome.org/teams/ast

[KDE] http://l10n.kde.org/team-infos.php?teamcode=ast

[FEDORA] http://fedoraproject.org/ast/

[UBUNTU] https://translations.launchpad.net/ubuntu/lucid/+lang/ast

[MOZILLA] http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.2-l10n/

Ethnologue code iso: http://www.ethnologue.com/show_language.asp?code=ast

Comment 3 ivarela 2010-06-02 07:06:10 UTC
Hi again..

When I said "avoids problems with other platforms", I mean that (for example) this list of languages is the same that MeeGo uses. (Meego and Moblin uses code "ast" too)

..but I'm not a developer. I'm sure you will do the best ;)

Regards
Iñigo Varela.

Comment 4 ivarela 2010-06-02 11:45:30 UTC
Oooops!! I think that I've misunderstood things, and you are right. 

Typing in a terminal (ubuntu) "locale -a" the result is:

ast_ES.utf8
ca_AD.utf8
ca_ES.utf8
es_AR.utf8
es_BO.utf8
es_CL.utf8
es_CO.utf8
es_ES.utf8
...
...

so, I supposse that iso code and locale code are different things :S
Sorry. ;)

Comment 5 Pravin Satpute 2010-06-03 03:50:50 UTC
(In reply to comment #4)

> so, I supposse that iso code and locale code are different things :S
> Sorry. ;)    

yes exactly,
no problem this happens

Comment 6 Naveen Kumar 2010-06-15 13:27:20 UTC
File a bug/request for package "comps" to add support for Asturian Language, because even if I add it (Asturian) to the present list s-c-l would not do anything useful for this language as there would not be any yum auto "language support" download. I will anyway add it with next build within this week, but in order to do anything useful it must get it added to comps first.

Comment 7 ivarela 2010-06-15 14:27:30 UTC
Thank you.

I've requested it in: https://bugzilla.redhat.com/show_bug.cgi?id=604161


(I hope do it well... :S)

Comment 8 Naveen Kumar 2010-06-18 06:31:26 UTC
Created attachment 425016 [details]
Patch for this bug.

 Must be applied in order specified in specfile for fc-13 build

Comment 9 Fedora Update System 2010-06-18 06:43:02 UTC
system-config-language-1.3.4-3.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-language-1.3.4-3.fc13

Comment 10 Fedora Update System 2010-06-21 12:54:19 UTC
system-config-language-1.3.4-3.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update system-config-language'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/system-config-language-1.3.4-3.fc13

Comment 11 Fedora Update System 2010-07-09 10:32:24 UTC
system-config-language-1.3.4-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/system-config-language-1.3.4-5.fc13


Note You need to log in before you can comment on or make changes to this bug.