Bug 604161 - add support for Asturian Language
Summary: add support for Asturian Language
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: comps
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-06-15 14:25 UTC by ivarela
Modified: 2014-03-17 03:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-17 16:47:18 UTC


Attachments (Terms of Use)

Description ivarela 2010-06-15 14:25:21 UTC
Description of problem:
Requesting add support for Asturian Language

See bug: https://bugzilla.redhat.com/show_bug.cgi?id=598423

as Naveen Kumar asked. (in comment #6)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Bill Nottingham 2010-06-15 19:30:53 UTC
Do you have a patch? What sort of language-specific packages exist for Asturian?

Comment 2 ivarela 2010-06-15 21:11:05 UTC
Hi Bill....
..ooops... I'm not sure, but maybe this can help?
http://www.openoffice.org/nonav/issues/showattachment.cgi/63239/ast_ES.xml 

(from http://www.openoffice.org/issues/show_bug.cgi?id=97602 )

If not, I'm sure that our language-specific package it's very, very similar to Galician, (they are very close languages) so if you (please) can provide me an example, I think that I can see it and change it properly.

Comment 3 Naveen Kumar 2010-06-16 08:57:16 UTC
(In reply to comment #2)
> Hi Bill....
> ..ooops... I'm not sure, but maybe this can help?
> http://www.openoffice.org/nonav/issues/showattachment.cgi/63239/ast_ES.xml 
> 
> (from http://www.openoffice.org/issues/show_bug.cgi?id=97602 )
> 
> If not, I'm sure that our language-specific package it's very, very similar to
> Galician, (they are very close languages) so if you (please) can provide me an
> example, I think that I can see it and change it properly.    

Here is an example from file comps-f13.xml.in comps pkg:

--------------------------------------------------------
...........
  <group>
    <id>hindi-support</id>
    <_name>Hindi Support</_name>
    <_description/>
    <default>false</default>
    <uservisible>true</uservisible>
    <langonly>hi</langonly>
    <packagelist>
      <packagereq type="mandatory">lohit-devanagari-fonts</packagereq>
      <packagereq type="mandatory">m17n-contrib-hindi</packagereq>
      <packagereq type="mandatory">m17n-db-hindi</packagereq>
      <packagereq type="conditional" requires="aspell">aspell-hi</packagereq>
      <packagereq type="conditional" requires="eclipse-platform">eclipse-nls-hi</packagereq>
      <packagereq type="conditional" requires="gcompris">gcompris-sound-hi</packagereq>
      <packagereq type="conditional" requires="hunspell">hunspell-hi</packagereq>
      <packagereq type="conditional" requires="hyphen">hyphen-hi</packagereq>
      <packagereq type="conditional" requires="xorg-x11-server-Xorg">ibus-m17n</packagereq>
      <packagereq type="conditional" requires="kdelibs3">kde-i18n-Hindi</packagereq>
      <packagereq type="conditional" requires="kdelibs">kde-l10n-Hindi</packagereq>
      <packagereq type="conditional" requires="moodle">moodle-hi</packagereq>
      <packagereq type="conditional" requires="openoffice.org-core">openoffice.org-langpack-hi_IN</packagereq>
      <packagereq type="default">iok</packagereq>
      <packagereq type="default">samyak-devanagari-fonts</packagereq>
      <packagereq type="default">sarai-fonts</packagereq>
    </packagelist>
  </group>
  <group>
    <id>hungarian-support</id>
    <_name>Hungarian Support</_name>
    <_description/>
    <default>false</default>
    <uservisible>true</uservisible>
    <langonly>hu</langonly>
    <packagelist>
      <packagereq type="conditional" requires="autocorr-en">autocorr-hu</packagereq>
      <packagereq type="conditional" requires="eclipse-platform">eclipse-nls-hu</packagereq>
      <packagereq type="conditional" requires="gcompris">gcompris-sound-hu</packagereq>
      <packagereq type="conditional" requires="hunspell">hunspell-hu</packagereq>
      <packagereq type="conditional" requires="hyphen">hyphen-hu</packagereq>
      <packagereq type="conditional" requires="kdelibs3">kde-i18n-Hungarian</packagereq>
      <packagereq type="conditional" requires="kdelibs">kde-l10n-Hungarian</packagereq>
      <packagereq type="conditional" requires="koffice-core">koffice-langpack-hu</packagereq>
      <packagereq type="conditional" requires="moodle">moodle-hu</packagereq>
      <packagereq type="conditional" requires="openoffice.org-core">openoffice.org-langpack-hu_HU</packagereq>
      <packagereq type="optional">fonts-ISO8859-2</packagereq>
      <packagereq type="optional">fonts-ISO8859-2-100dpi</packagereq>
      <packagereq type="optional">fonts-ISO8859-2-75dpi</packagereq>
    </packagelist>
  </group>
...........
--------------------------------------------------------

I hope this would be helpful.

Comment 4 ivarela 2010-06-16 22:00:53 UTC
Hi! Then it's easy....  only add this to comps-f13.xml.in comps pkg:

-----------------------

  <group>
    <id>asturian-support</id>
    <_name>Asturian Support</_name>
    <_description/>
    <default>false</default>
    <uservisible>true</uservisible>
    <langonly>ast</langonly>
    <packagelist>
      <packagereq type="conditional" requires="aspell">aspell-ast</packagereq>
      <packagereq type="conditional" requires="hunspell">hunspell-ast</packagereq>
      <packagereq type="conditional" requires="kdelibs">kde-l10n-Asturian</packagereq>
      <packagereq type="conditional" requires="koffice-core">koffice-langpack-ast</packagereq>
      <packagereq type="conditional" requires="moodle">moodle-ast</packagereq>
      <packagereq type="conditional" requires="openoffice.org-core">openoffice.org-langpack-ast_ES</packagereq>
    </packagelist>
  </group>

----------------------------

And that's all. Thanks Naveen, for your help. ;)

P.D. I've seen that other languages uses:

<packagereq type="conditional"
requires="kdelibs3">kde-i18n-LANGUAGE</packagereq>  

(i.e. spanish, japanese, italian, french, danish... etc). Asturian language has translated kdelibs4 (not kdelibs3):
http://l10n.kde.org/stats/gui/trunk-kde4/essential/

Should I include this?: 
<packagereq type="conditional"
requires="kdelibs3">kde-i18n-Asturian</packagereq>

...i don't know if it's correct. If yes, can you do it for me? Thanks

Comment 5 Bill Nottingham 2010-06-17 16:47:18 UTC
Added as http://git.fedorahosted.org/git/?p=comps.git;a=commitdiff;h=9354e7279427991d04801e23db0f6458f66fe503.

This is smaller than what you posted, simply because the other packages you referenced don't exist, as far as I can tell.


Note You need to log in before you can comment on or make changes to this bug.