Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598460 - [PATCH] rb-site crashes when finishing
[PATCH] rb-site crashes when finishing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ReviewBoard (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
: Reopened
: 616578 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 08:43 EDT by Lubomir Rintel
Modified: 2010-09-04 00:54 EDT (History)
4 users (show)

See Also:
Fixed In Version: ReviewBoard-1.0.9-6.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-04 00:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed fix (3.44 KB, text/plain)
2010-06-01 08:43 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2010-06-01 08:43:01 EDT
Created attachment 418623 [details]
Proposed fix

Description of problem:

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 770, in next_page
    func()
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 944, in call_func
    func()
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 313, in sync_database
    self.run_manage_command("syncdb", ["--noinput"])
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 352, in run_manage_command
    execute_manager(reviewboard.settings, [__file__, cmd] + params)
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 438, in execute_manager
    utility.execute()
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 379, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/lib/python2.6/site-packages/django/core/management/base.py", line 191, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/lib/python2.6/site-packages/django/core/management/base.py", line 218, in execute
    output = self.handle(*args, **options)
  File "/usr/lib/python2.6/site-packages/django/core/management/base.py", line 347, in handle
    return self.handle_noargs(**options)
  File "/usr/lib/python2.6/site-packages/django/core/management/commands/syncdb.py", line 103, in handle_noargs
    emit_post_sync_signal(created_models, verbosity, interactive, db)
  File "/usr/lib/python2.6/site-packages/django/core/management/sql.py", line 185, in emit_post_sync_signal
    interactive=interactive, db=db)
  File "/usr/lib/python2.6/site-packages/django/dispatch/dispatcher.py", line 162, in send
    response = receiver(signal=self, sender=sender, **named)
  File "/usr/lib/python2.6/site-packages/reviewboard/admin/management/sites.py", line 21, in init_siteconfig
    create_default_site(app, created_models, verbosity)
TypeError: create_default_site() takes exactly 4 arguments (3 given)


Version-Release number of selected component (if applicable):

ReviewBoard-1.0.5.1-2.fc13.noarch

Additional info:

Proposed patch attached.
Comment 1 Stephen Gallagher 2010-06-01 14:12:24 EDT
This is a bug due to an incompatibility with Django 1.2. I am going to be updating ReviewBoard in Fedora 13 to 1.0.8 shortly, which includes this fix.
Comment 2 Fedora Update System 2010-06-28 09:14:52 EDT
ReviewBoard-1.0.8-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ReviewBoard-1.0.8-5.fc13
Comment 3 Stephen Gallagher 2010-07-20 16:34:38 EDT
*** Bug 616578 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2010-08-13 17:14:36 EDT
ReviewBoard-1.0.8-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Leif Gruenwoldt 2010-08-13 17:48:40 EDT
How did this get pushed to stable? rb-site requires a version of python-djblets that's not in F13 stable?

$ sudo rb-site install /var/www/reviews
Traceback (most recent call last):
  File "/usr/bin/rb-site", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2675, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 552, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: Djblets>=0.6.0
Comment 6 Stephen Gallagher 2010-08-16 07:07:02 EDT
Argh, so it turns out that ReviewBoard 1.0.8 has a requirement on DJblets 0.6.0 or higher, but this wasn't listed in the release notes.

Things worked fine in my testing because I happened to have DJblets 0.6.3 installed on my machine for testing ReviewBoard 1.5.0.

On the other hand, this was in updates-testing for two and a half months without any negative karma.

Anyway, I'm reopening this. I'm building ReviewBoard 1.0.9 and DJblets 0.6.3 for Fedora 13 now, and I'll make sure that they share a single update request so they'll be pushed together.
Comment 7 Fedora Update System 2010-08-16 07:09:57 EDT
ReviewBoard-1.0.9-6.fc13,python-djblets-0.6.3-5.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ReviewBoard-1.0.9-6.fc13,python-djblets-0.6.3-5.fc13
Comment 8 Fedora Update System 2010-09-04 00:54:09 EDT
ReviewBoard-1.0.9-6.fc13, python-djblets-0.6.3-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.