Bug 616578 - rb-site install fails to complete
rb-site install fails to complete
Status: CLOSED DUPLICATE of bug 598460
Product: Fedora
Classification: Fedora
Component: ReviewBoard (Show other bugs)
13
All Linux
low Severity high
: ---
: ---
Assigned To: Stephen Gallagher
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-20 16:17 EDT by Leif Gruenwoldt
Modified: 2010-07-20 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-20 16:34:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leif Gruenwoldt 2010-07-20 16:17:06 EDT
Description of problem:

ReviewBoard fails to complete site config install.

Version-Release number of selected component (if applicable):

ReviewBoard-1.0.5.1-2.fc13.noarch

How reproducible:

Always.

Steps to Reproduce:
1. sudo rb-site install /var/www/reviews
2. Walk through gui installer clicking next a lot
3. I chose a MySQL, Apache, and Memcached
  
Actual results:

Creating table django_evolution
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 770, in next_page
    func()
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 944, in call_func
    func()
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 313, in sync_database
    self.run_manage_command("syncdb", ["--noinput"])
  File "/usr/lib/python2.6/site-packages/reviewboard/cmdline/rbsite.py", line 352, in run_manage_command
    execute_manager(reviewboard.settings, [__file__, cmd] + params)
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 438, in execute_manager
    utility.execute()
  File "/usr/lib/python2.6/site-packages/django/core/management/__init__.py", line 379, in execute
    self.fetch_command(subcommand).run_from_argv(self.argv)
  File "/usr/lib/python2.6/site-packages/django/core/management/base.py", line 191, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/lib/python2.6/site-packages/django/core/management/base.py", line 218, in execute
    output = self.handle(*args, **options)
  File "/usr/lib/python2.6/site-packages/django/core/management/base.py", line 347, in handle
    return self.handle_noargs(**options)
  File "/usr/lib/python2.6/site-packages/django/core/management/commands/syncdb.py", line 103, in handle_noargs
    emit_post_sync_signal(created_models, verbosity, interactive, db)
  File "/usr/lib/python2.6/site-packages/django/core/management/sql.py", line 185, in emit_post_sync_signal
    interactive=interactive, db=db)
  File "/usr/lib/python2.6/site-packages/django/dispatch/dispatcher.py", line 162, in send
    response = receiver(signal=self, sender=sender, **named)
  File "/usr/lib/python2.6/site-packages/reviewboard/admin/management/sites.py", line 21, in init_siteconfig
    create_default_site(app, created_models, verbosity)
TypeError: create_default_site() takes exactly 4 arguments (3 given)


Expected results:

rb-site install to finish cleanly.

Additional info:

Recommended action is to upgrade to ReviewBoard 1.0.9

http://groups.google.com/group/reviewboard/browse_thread/thread/5fdfa28b64f92bc2/1f0cb810cfcd834e?tvc=2#1f0cb810cfcd834e
Comment 1 Stephen Gallagher 2010-07-20 16:34:38 EDT

*** This bug has been marked as a duplicate of bug 598460 ***

Note You need to log in before you can comment on or make changes to this bug.