Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598540 - Gnome power manager suspends system when notebook in docking station is closed.
Gnome power manager suspends system when notebook in docking station is closed.
Status: CLOSED DUPLICATE of bug 546497
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 11:25 EDT by Andreas Thienemann
Modified: 2010-07-12 15:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 15:12:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2010-06-01 11:25:12 EDT
Description of problem:
A Dell Latitude E4200 notebook is docked in a Dell docking station with two TFTs connected via DVI.

Monitors are configured to show a desktop spanning both TFTs and to disable the notebook monitor.

When the notebook is now closed, the screen is faded out and the notebook suspends.
The suspend action can be changed in gnome-power-manager to "Blank Screen" but the machine is still unusable as the screen are blanked.
I distinctly remember a selection called "Do Nothing" being available in prior versions. Unfortunately this option does not exist any longer making that a infeasible workaround.

Version-Release number of selected component (if applicable):
gnome-power-manager-2.30.1-1.fc13.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Dock the notebook.
2. Configure external screens, disable internal screen.
3. Close the lid.
  
Actual results:
System suspends/blanks screen

Expected results:
System still running with screens still visible
Comment 1 Pasi Karkkainen 2010-07-12 08:15:56 EDT
There's a similar bugzilla entry here:
https://bugzilla.redhat.com/show_bug.cgi?id=546497

And yes, this should be fixed.

The simplest fix would be to have "Do nothing" option for the "When laptop lid is closed" parameter in gnome-power-manager.
Comment 2 Pasi Karkkainen 2010-07-12 08:17:33 EDT
I think this is the "main" bugzilla entry about this issue:
https://bugzilla.redhat.com/show_bug.cgi?id=530211
Comment 3 Andreas Thienemann 2010-07-12 08:27:57 EDT
"Do Nothing" is something I'd consider a workaround. Not necessarily a fix...
Comment 4 Pasi Karkkainen 2010-07-12 08:31:03 EDT
Yeah.. I guess workaround is better term for it. But it would be good enough for me :) (until better solution is developed).
Comment 5 jmccann 2010-07-12 15:12:25 EDT

*** This bug has been marked as a duplicate of bug 546497 ***

Note You need to log in before you can comment on or make changes to this bug.