Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 598664 - SELinux is preventing /usr/bin/kdm "write" access on .dmrc.
SELinux is preventing /usr/bin/kdm "write" access on .dmrc.
Status: CLOSED DUPLICATE of bug 583340
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:a0ad2e179bd...
:
: 598665 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-01 15:56 EDT by Elad Mizrahi
Modified: 2014-09-01 07:32 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-29 14:01:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elad Mizrahi 2010-06-01 15:56:12 EDT
Summary:

SELinux is preventing /usr/bin/kdm "write" access on .dmrc.

Detailed Description:

[SELinux is in permissive mode. This access was not denied.]

SELinux denied access requested by kdm. It is not expected that this access is
required by kdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                .dmrc [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.4.3-1.fc13.1
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-21.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.4-95.fc13.i686 #1 SMP Thu
                              May 13 05:55:24 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Mon 31 May 2010 11:01:43 PM IDT
Last Seen                     Mon 31 May 2010 11:01:43 PM IDT
Local ID                      b19a26d7-1a3e-4e89-9ae7-d4643bf9c875
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1275336103.372:33258): avc:  denied  { write } for  pid=28127 comm="kdm" name=".dmrc" dev=dm-0 ino=7910 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1275336103.372:33258): arch=40000003 syscall=5 success=yes exit=3 a0=8066133 a1=8a41 a2=180 a3=8066133 items=0 ppid=28101 pid=28127 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=798 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,kdm,xdm_t,admin_home_t,file,write
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t admin_home_t:file write;
Comment 1 Daniel Walsh 2010-06-01 16:46:22 EDT
Are you attempting to login as root from X?
Comment 2 Daniel Walsh 2010-06-01 16:46:43 EDT
*** Bug 598665 has been marked as a duplicate of this bug. ***
Comment 3 Carl G. 2010-06-29 14:01:08 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

*** This bug has been marked as a duplicate of bug 583340 ***

Note You need to log in before you can comment on or make changes to this bug.