Bug 598690 - [LTC 6.0]: Update SBLIM data gatherer to 2.2.1
[LTC 6.0]: Update SBLIM data gatherer to 2.2.1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sblim-gather (Show other bugs)
6.0
All All
low Severity medium
: rc
: 6.0
Assigned To: Vitezslav Crhonek
Yulia Kopkova
: OtherQA, Rebase
: 463329 (view as bug list)
Depends On:
Blocks: 356741
  Show dependency treegraph
 
Reported: 2010-06-01 16:41 EDT by IBM Bug Proxy
Modified: 2010-11-15 09:47 EST (History)
8 users (show)

See Also:
Fixed In Version: sblim-gather-2.2.1-1.el6
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-15 09:47:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 64366 None None None Never

  None (edit)
Description IBM Bug Proxy 2010-06-01 16:41:18 EDT
1. Feature Overview:
Feature Id: [64366]
a. Name of Feature: [LTC 6.0 FEAT]: Update SBLIM data gatherer to 2.2.1
b. Feature Description
Update the version of sblim-gather, including sblim-gather-develop, sblim-gather-provider and
sblim-gather-test, to version 2.2.1.

2. Feature Details:
Sponsor: LTC System Mgmt
Architectures:
  x86x86_64zSeries - 64 native

Arch Specificity: purely common code
Affects Kernel Modules: No
Delivery Mechanism: Direct from Community
Category: system management
Request Type: Package - Version Update
d. Upstream Acceptance: Accepted
Sponsor Priority P2
f. Severity: normal
IBM Confidential: No
Code Contribution: IBM code
g. Component Version Target:
---

3. Business Case
IBM Director will be converging on the SBLIM Data Gatherer to provide the base DMTF Metrics Profile
complaint runtime metric gathering instrumentation. We have been using it for some time for Director
Xen, zVM is planning on using for Director 6.1, and when we properly converge on some common VSM
metrics post-6.1 having some cross-platform infrastructure established and available will be even
more important. Utilized and required currently by VMControl, zGryphon, and Phoenix.

4. Primary contact at Red Hat:
John Jarvis, jjarvis@redhat.com

5. Primary contacts at Partner:
Project Management Contact:
Michael W. Wortman, wortman@us.ibm.com

Technical contact(s):
TYREL N. DATWYLER, tyreld@us.ibm.com
Comment 2 RHEL Product and Program Management 2010-06-02 08:49:52 EDT
This feature request did not get resolved in time for Feature Freeze
for the current Red Hat Enterprise Linux release and has now been
denied. You may re-open your request by requesting your support
representative to propose it for the next release.
Comment 4 RHEL Product and Program Management 2010-06-02 10:45:32 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 5 John Jarvis 2010-06-02 12:19:17 EDT
IBM is signed up to test and provide feedback.
Comment 7 John Jarvis 2010-06-28 12:55:46 EDT
This request is approved and planned for snapshot 7.
Comment 9 IBM Bug Proxy 2010-07-26 10:11:06 EDT
------- Comment From tyreld@us.ibm.com 2010-07-26 10:04 EDT-------
The cim providers are missing from the sblim-gather package in snapshot7. In previous releases the gatherer daemons have been packaged in sblim-gather and the CIM instrumentation in sblim-gather-provider. I didn't see the later package in my testing. Is the provider rpm going to be included, or was it overlooked in this snapshot?
Comment 10 IBM Bug Proxy 2010-07-27 17:51:09 EDT
------- Comment From tyreld@us.ibm.com 2010-07-27 17:49 EDT-------
(In reply to comment #9)
> The cim providers are missing from the sblim-gather package in snapshot7. In
> previous releases the gatherer daemons have been packaged in sblim-gather and
> the CIM instrumentation in sblim-gather-provider. I didn't see the later
> package in my testing. Is the provider rpm going to be included, or was it
> overlooked in this snapshot?

It occurred to me to check the optional packages for sblim-gather-provider, and sure enough there it was. The provider package is required to retrieve metrics from the gatherer daemons via CIM, and it would make sense that it is placed with the rest of the SBLIM providers (sblim-cmpi-base, etc.). Can it be made part of the Server packages?
Comment 11 Bill Nottingham 2010-07-28 15:21:50 EDT
Changed in comps.
Comment 12 IBM Bug Proxy 2010-08-10 20:01:10 EDT
------- Comment From tyreld@us.ibm.com 2010-08-10 19:57 EDT-------
After reviewing snap9 the only issue I see is that the 32/31 bit sblim-gather-provider rpm package is missing on 64bit platforms.

x86_64 present but no i686

ppc64 present but no ppc

s390x present but no s390
Comment 16 Alexander Todorov 2010-08-25 09:42:06 EDT
*** Bug 463329 has been marked as a duplicate of this bug. ***
Comment 18 releng-rhel@redhat.com 2010-11-15 09:47:16 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.