Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 598727 - [Intel 6.0 Bug] Could not create a new guest or open an old guest image on RHEL6.0, it always reports errors
[Intel 6.0 Bug] Could not create a new guest or open an old guest image on RH...
Status: CLOSED DUPLICATE of bug 593909
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.0
All Linux
low Severity high
: rc
: 6.0
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks: 562808 576638
  Show dependency treegraph
 
Reported: 2010-06-01 18:31 EDT by sibai.li
Modified: 2010-06-09 15:33 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-09 15:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sibai.li 2010-06-01 18:31:01 EDT
Description of problem:
Could not create a new guest or open an old guest image on RHEL6.0, it always reports errors

Version-Release number of selected component (if applicable):
Redhat kernel: 2.6.32-28.el6.x86_64


How reproducible:
(1)Run VMM to create a new guest image, follow the steps to create a new image.
(2) it reports that Uninstall to complete install: 'internal error Process exited while reading console log output:char device redirected to /dev/pts/3//qemu:could not open disk image /var/lib/kvm-vm1-1.img: invalid argument.

(3)Check /var/lib/ the image is already created.


Additional info:
Log file
login as: root
root@10.23.22.61's password:
[root@localhost ~]# cd /var/log
[root@localhost log]# ls
anaconda.log          cluster     maillog           secure
anaconda.program.log  ConsoleKit  mcelog            spooler
anaconda.storage.log  cron        messages          sssd
anaconda.syslog       dmesg       ntpstats          tallylog
anaconda.xlog         dmesg.old   piranha           wpa_supplicant.log
anaconda.yum.log      gdm         pm-powersave.log  wtmp
audit                 httpd       ppp               Xorg.0.log
boot.log              lastlog     prelink           Xorg.0.log.old
brcm-iscsi.log        libvirt     sa                Xorg.9.log
btmp                  luci        samba             yum.log
[root@localhost log]# tail messages
Jun  1 10:26:45 localhost libvirtd: 10:26:45.066: error : storageVolumeLookupByName:1157 : Storage volume not found: no storage vol with matching name 'vm1.img'
Jun  1 10:26:45 localhost libvirtd: 10:26:45.129: error : storageVolumeLookupByPath:1242 : invalid storage volume pointer in no storage vol with matching path
Jun  1 10:26:45 localhost kernel: device vnet0 entered promiscuous mode
Jun  1 10:26:45 localhost kernel: virbr0: topology change detected, propagating
Jun  1 10:26:45 localhost kernel: virbr0: port 1(vnet0) entering forwarding state
Jun  1 10:26:45 localhost NetworkManager[2090]: <warn> /sys/devices/virtual/net/vnet0: couldn't determine device driver; ignoring...
Jun  1 10:26:45 localhost kernel: virbr0: port 1(vnet0) entering disabled state
Jun  1 10:26:45 localhost kernel: device vnet0 left promiscuous mode
Jun  1 10:26:45 localhost kernel: virbr0: port 1(vnet0) entering disabled state
Jun  1 10:26:45 localhost libvirtd: 10:26:45.687: error : qemudReadLogOutput:2251 : internal error Process exited while reading console log output: char device redirected to /dev/pts/3#012qemu: could not open disk image /var/lib/libvirt/images/vm1.img: Invalid argument#012
[root@localhost log]#
[root@localhost log]# ll /var/lib/libvirt/images/
total 8388612
-rw-------. 1 root root 8589934592 Jun  1 10:26 vm1.img
[root@localhost log]#
Comment 2 RHEL Product and Program Management 2010-06-02 14:25:52 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Cole Robinson 2010-06-09 15:33:16 EDT
I believe this is fixed in qemu-kvm-0.12.1.2-2.56.el6

*** This bug has been marked as a duplicate of bug 593909 ***

Note You need to log in before you can comment on or make changes to this bug.