Bug 598843 - Can't install glibc.i686 on Fedora 13 x86_64 due to failed dependencies
Can't install glibc.i686 on Fedora 13 x86_64 due to failed dependencies
Status: CLOSED DUPLICATE of bug 596840
Product: Fedora
Classification: Fedora
Component: nss-softokn (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-02 03:22 EDT by Oded Arbel
Modified: 2010-06-02 14:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-02 14:09:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oded Arbel 2010-06-02 03:22:57 EDT
Description of problem:
When I try to install glibc.i686 on an x86_64 Fedora 13 installation (because I want to run some 32bit precompiled binaries), I get dependency failure from yum

Version-Release number of selected component (if applicable):
3.12.4-17

How reproducible:
Always

Steps to Reproduce:
1. Open a console as root
2. make sure the "fedora-updates" repository is enabled
3. execute: yum install glibc.i686
  
Actual results:
Yum adds a dependency on nss-softokn-freebl.i686 0:3.12.4-17.fc13, then reports:
Transaction Check Error:
  package nss-softokn-freebl-3.12.4-19.fc13.x86_64 (which is newer than nss-softokn-freebl-3.12.4-17.fc13.i686) is already installed

Expected results:
glibc.i686 should be installed

Additional info:
It seems that the problem is in the updates repository, which has a newer version of the nss-softokn and nss-softokn-freebl packages (3.12.4-19) but only for the x86_64 binaries. When I try to install glibc.i686 it needs to install these packages' i686 builds, which exist in the primary Fedora 13 repo but not in the updates. 

Yum then adds insult to injury by preventing the installation of a different package architecture because a different architecture is more up to date.
Comment 1 Bill Nottingham 2010-06-02 14:09:39 EDT

*** This bug has been marked as a duplicate of bug 596840 ***

Note You need to log in before you can comment on or make changes to this bug.