Bug 599038 - confirmation message does not always render after disassociating a content source from a repository
confirmation message does not always render after disassociating a content so...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Content (Show other bugs)
3.0.0
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: rhq_auto_blocker
  Show dependency treegraph
 
Reported: 2010-06-02 11:02 EDT by John Sefler
Modified: 2014-05-29 14:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-29 14:15:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
page rendered with expected confirmation message after disassociating content source from repository (111.79 KB, image/png)
2010-06-02 11:04 EDT, John Sefler
no flags Details
page rendered withOUT expected confirmation message after disassociating content source from repository (110.39 KB, image/png)
2010-06-02 11:05 EDT, John Sefler
no flags Details

  None (edit)
Description John Sefler 2010-06-02 11:02:55 EDT
Description of problem:
After clicking DISASSOCIATE SELECTED when in the process of disassociating a content source from a repository, a confirmation message block is usually rendered. The message states "Disassociated [1] content sources from repository".  The problem is that this message does not always render.  Occasionally no confirmation message is rendered.

We have an automated test that looks for this message after disassociating a content source from a repository.  This test is failing when the message is not rendered.

Attached are screenshots with (expected behavior) and without (unexpected behavior) the confirmation block

Version-Release number of selected component (if applicable):
 RHQ
version: 3.0.0-SNAPSHOT
build number: 0661cb1 

How reproducible:
OCCASIONAL


Steps to Reproduce:
1. create any content source
2. create a repository
3. open the repository and associate the content source created earlier
4. click Administration > Content > Repositories > the repository created in 2
5. check the box next to the content source created in 1 and click DISASSOCIATE SELECTED
  
Actual results:
 sometimes this message does not appear
  "Disassociated [1] content sources from repository"

Expected results:
 this message should always appear
  "Disassociated [1] content sources from repository"

Additional info:
For what its worth, the only information that gets logged to rhq-server-log4j.log at the time of disassociation is the following.  However, this same WARN gets logged when the confirmation message is rendered successfully too.

2010-06-02 09:58:00,942 WARN  [org.jboss.seam.ui.renderkit.DefaultActionRendererBase] Must set an id for the default action source


AUTOMATED TEST REFERENCE:
Failed Tests
com.redhat.qe.rhq30.tests.ContentTests
disassociateChannelFromContentSource_Test 	10.241s 	
Starting Test: disassociateChannelFromContentSource_Test
Hover over link: top level menu 'Administration'. (//div[.='Administration'])
Hover over link: menu item 'Content'. (//span[.='Content'])
Click on link: menu item 'Repositories'. (//span[.='Repositories'])
Click on link: 'Channel for ContentTests (1275444895541)'. (link=Channel for ContentTests (1275444895541))
Click on checkbox: next to text 'ContentSource for ContentTests (1275444895540)'. (//*[(self::td or contains(@class,'dr-table-cell') or contains(@class,'rich-table-cell')) and normalize-space(.)='ContentSource for ContentTests (1275444895540)']/..//*[@type='checkbox'])
Click on submit button: //input[@value='DISASSOCIATE SELECTED' or @value='DISASSOCIATESELECTED']
Asserted: Error block is not present.
Test Failed: disassociateChannelFromContentSource_Test
screenshot URL= http://auto-rhq01.usersys.redhat.com:7080/rhq/content/repo.xhtml?mode=view&id=10011&conversationId=676
Captured screenshot to file:/home/hudson/localslave1/workspace/overnight-test-all-groups-rhq/automatjon/jon/test-output/screenshots/20100601-230428579-com.redhat.qe.rhq30.tests.ContentTests.disassociateChannelFromContentSource_Test.png
Screenshot
com.redhat.qe.jon20.conditions.MissingMessageException: Confirmation block is missing. [Location in JBoss ON: Unknown]
Comment 1 John Sefler 2010-06-02 11:04:44 EDT
Created attachment 419062 [details]
page rendered with expected confirmation message after disassociating content source from repository
Comment 2 John Sefler 2010-06-02 11:05:34 EDT
Created attachment 419063 [details]
page rendered withOUT expected confirmation message after disassociating content source from repository
Comment 3 John Sefler 2010-06-02 11:08:41 EDT
The only way I know how to reproduce the missing confirmation message is to repeatedly try to ASSOCIATE content source to repository and then DISASSOCIATE it. Occasionally the confirmation message will not appear.
Comment 4 John Sefler 2010-06-28 11:11:34 EDT
The confirmation message has also failed to appear when selecting multiple repositories and clicking the "SYNC SELECTED" button.
Comment 5 Corey Welton 2010-09-24 08:50:55 EDT
Joseph - initial thought was to close due to gwt effort.  However, wondering if this is a candidate for any maintenance releases?  It (on occasion) breaks and will continue to break tests in automation, as long as we are maintaining the non-gwt product.

Note You need to log in before you can comment on or make changes to this bug.