Bug 59918 - /sbin/setsysfont ignores SYSFONTACM
/sbin/setsysfont ignores SYSFONTACM
Status: CLOSED DUPLICATE of bug 76472
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-02-14 15:35 EST by Leonid Kanter
Modified: 2014-03-16 22:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2002-02-14 15:35:42 EST
Description of Problem:

/sbin/setsysfont ignores SYSFONTACM

Version-Release number of selected component (if applicable):

initscripts-6.51-1


How Reproducible:

always

Steps to Reproduce:

sh -x /sbin/setsysfont

Actual Results:

[root@leon /]# sh -x /sbin/setsysfont.orig
+ PATH=/bin:/usr/bin
+ '[' -f /etc/sysconfig/i18n ']'
+ . /etc/sysconfig/i18n
++ LANG=ru_RU.koi8r
++ SUPPORTED=ru_RU.koi8r:ru_RU:ru:uk_UA:uk
++ SYSFONT=cyr-sun16
++ SYSFONTACM=koi8-u
+ '[' -x /bin/consolechars -o -x /usr/bin/consolechars ']'
+ '[' -x /bin/setfont ']'
+ '[' -n cyr-sun16 -a -n '' ']'
+ '[' -n cyr-sun16 ']'
+ /bin/setfont cyr-sun16
+ exit 0

Expected Results:

[root@leon /]# sh -x /sbin/setsysfont
+ PATH=/bin:/usr/bin
+ '[' -f /etc/sysconfig/i18n ']'
+ . /etc/sysconfig/i18n
++ LANG=ru_RU.koi8r
++ SUPPORTED=ru_RU.koi8r:ru_RU:ru:uk_UA:uk
++ SYSFONT=cyr-sun16
++ SYSFONTACM=koi8-u
+ '[' -x /bin/consolechars -o -x /usr/bin/consolechars ']'
+ '[' -x /bin/setfont ']'
+ '[' -n cyr-sun16 -a -n '' ']'
+ '[' -n koi8-u ']'
+ /bin/setfont -m koi8-u
+ exit 0


Additional Information:
	
[root@leon /]# diff /sbin/setsysfont.orig /sbin/setsysfont -u
--- /sbin/setsysfont.orig       Mon Feb 11 19:15:41 2002
+++ /sbin/setsysfont    Mon Feb 11 19:19:43 2002
@@ -20,10 +20,10 @@
 elif [ -x /bin/setfont ]; then
   if [ -n "$SYSFONT" -a -n "$UNIMAP" ]; then
     /bin/setfont $SYSFONT -u $UNIMAP
+  elif [ -n "$SYSFONTACM" ]; then
+    /bin/setfont -m $SYSFONTACM
   elif [ -n "$SYSFONT" ]; then
     /bin/setfont $SYSFONT
-#  else
-#    /bin/setfont
   fi
 else
   echo $"can't set font"
Comment 1 Bill Nottingham 2003-09-29 17:20:56 EDT

*** This bug has been marked as a duplicate of 76472 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:48:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.