Bug 76472 - setsysfont script provides no capability to set up ACM when using kbd
setsysfont script provides no capability to set up ACM when using kbd
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 59918 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-22 02:32 EDT by Sinitsyn Valentine
Modified: 2014-03-16 22:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-22 02:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Proposed patch for 'setsysfont' script (1.07 KB, patch)
2002-10-22 02:33 EDT, Sinitsyn Valentine
no flags Details | Diff

  None (edit)
Description Sinitsyn Valentine 2002-10-22 02:32:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Description of problem:
setsysfont script is unable to use SYSFONTACM variable when using setfont (kbd's
tools), which substitutes consoletools in RH Linux 8.0

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Set SYSFONTACM="smth" in /etc/sysconfig/i18n
	

Actual Results:  Symbols are output to the console without regarding the
specified translation table

Expected Results:  Symbols are output to the console regarding the specified
translation table

Additional info:

setsysfont script seems to be designed for using with 'consoletools' package
(6.2<=RH Linux<=8.0) and not kbd (RH Linux 8.0). I've simply dubbed the code for
consolechars (from the top of the script) for setfont. This solves the problem
(patch attached). Then I've put 'echo -ne "\033(K" > /dev/console' commmand
after calling setfont in order to make startup messages to print correctly (see
bug #76470).
Comment 1 Sinitsyn Valentine 2002-10-22 02:33:59 EDT
Created attachment 81504 [details]
Proposed patch for 'setsysfont' script
Comment 2 Bill Nottingham 2002-11-12 00:41:18 EST
Fixed in CVS, will be in 6.96-1 or later.
Comment 3 Bill Nottingham 2003-09-29 17:20:59 EDT
*** Bug 59918 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.