Bug 599237 - Show or hide particular custom fields values based on multiple values of another field
Show or hide particular custom fields values based on multiple values of anot...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: Max Kanat-Alexander
Kevin Baker
contractor
:
: 588602 (view as bug list)
Depends On: 588602
Blocks: JIRABZ 584956
  Show dependency treegraph
 
Reported: 2010-06-02 17:58 EDT by David Lawrence
Modified: 2014-12-01 18:09 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 588602
Environment:
Last Closed: 2011-05-30 02:40:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Lawrence 2010-06-02 17:58:31 EDT
Description of problem:
As part of the JIRA migration several new custom fields will need to be created that are going to be visible only for certain products. Several of the products will need to have a different list of values visible based on the product in the select field. We need to have support in Bugzilla to allow turning on or off certain values for a given custom field so we do not need to create multiple custom fields in order to have different lists.

Assigning to contractor as part of his work estimate.
Comment 1 Max Kanat-Alexander 2010-07-15 18:07:03 EDT
  You know, actually, it might be possible to just have the extension adjust the list of legal values before parsing the template, in which case we wouldn't need to do this. In fact, I think it would be simpler to just have the extension hack it.
Comment 2 David Lawrence 2010-07-24 17:06:15 EDT
*** Bug 588602 has been marked as a duplicate of this bug. ***
Comment 3 Mike Harvey 2010-10-11 15:00:58 EDT
Assigned to Dave Lawrence to verify/QA.  https://bz-web2-test.devel.redhat.com/

Changes are in place now to support this although it requires going in and actually cleaning up the fields that are already there to so that they only show up for products they are required for. I will need to talk to the different partner/program managers to start performing this clean up. So for now all custom
fields are still enabled for all bugs. So please don't think the show_bug.cgi page will have all of the fields displayed permanently.
Comment 6 Simon Green 2011-02-23 09:40:46 EST
Can this bug be closed?

The target release changes are tracked with bug 587798.

I am not aware of any other fields that need to be specifically product based. Please let me know if this is not the case.

  -- simon
Comment 7 Len DiMaggio 2011-03-09 13:12:28 EST
Clean-up task from the March 9 2011 Bugzilla / BRMS Pilot Meeting

This bugzilla has been marked as verified - we need to verify that the changes made to https://bz-web2-test.devel.redhat.com/ are acceptable and that this bugzilla can be closed. Please verify the change and close (or re-open) this bugzilla by March 15 2011. Thx!
Comment 8 Simon Green 2011-04-06 09:05:13 EDT
As per meeting discussion, this requires someone to test it before going to VERIFIED
Comment 9 Mike Harvey 2011-04-06 09:24:17 EDT
per our call today, the only customer filed to be verified is target release changes and is tracked with bug 587798.  Once 587798 is verified/closed, we can also close this bz 599237.
Comment 10 Simon Green 2011-05-30 02:40:14 EDT
As per comment #9, this bug is now CLOSED :)

Note You need to log in before you can comment on or make changes to this bug.