Bug 599305 - php-pecl-memcache extension broken due to a "protocol error"
php-pecl-memcache extension broken due to a "protocol error"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-pecl-memcache (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 00:40 EDT by Solomon Peachy
Modified: 2010-10-28 02:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: php-pecl-memcache-3.0.5-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 638887 (view as bug list)
Environment:
Last Closed: 2010-10-14 02:31:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Solomon Peachy 2010-06-03 00:40:58 EDT
Description of problem:

There's some sort of protocol error in what php-pecl-memcache is handing to the memcached daemon.

Version-Release number of selected component (if applicable):

php-5.3.2-2.fc12.x86_64
memcached-1.4.5-1.fc12.x86_64
php-pecl-memcache-3.0.4-3.fc12.x86_64

How reproducible:

Always!

Steps to Reproduce:
1. Get a memcache instance in a php script:

    $memcache = new Memcache;
    $memcache->connect("tcp://localhost:11211/");

2. call the $memcache->delete() function:
    $memcache->delete("path_folder.1.$folder_id"):
  
Actual results:

[Thu Jun 03 00:28:30 2010] [error] [client 192.168.1.22] PHP Notice:  MemcachePool::delete(): Server tcp://localhost:11211/ (tcp 11211, udp 0) failed with: CLIENT_ERROR bad command line format.  Usage: delete <key> [noreply]\r\n (0) in /home/pizza/public_html_pp/po-devel/src/folder.edit.2.php on line 59, referer: http://www.peachyphotos.com/po/folder.edit.php?folder=1016

Expected results:

The call should JustWork.

Additional info:

This worked on Fedora 11, which had an older memcached (1.2.8) and the same version of php-pecl-memcache (3.0.4).  This may be an upstream bug.
Comment 1 Solomon Peachy 2010-06-03 01:11:53 EDT
Upstream bug ticket:  http://pecl.php.net/bugs/bug.php?id=16927

They claim it's a WONTFIX bug.. but I don't see how this can be anything but a regression?  PHP code that used to work fine no longer does!
Comment 2 Remi Collet 2010-06-03 01:44:45 EDT
Don't know if we could this if upstream don't want...

Same code using memcached instead of memcache works without error (so it's really a client issue)
Comment 3 Solomon Peachy 2010-06-03 08:10:49 EDT
exactly; it's definitely a bug/regression in php-pecl-memcache.  If I have to I'll file another upstream bug ticket, but my comment on the existing one should suffice for now.

Unfortunately php-pecl-memcached isn't a drop-in replacement, due to some API differences..
Comment 4 Robert Vogelgesang 2010-09-30 05:22:05 EDT
During the last week or so I hit this very same bug in a system running the latest RHEL-6 Beta (update 2.1).

The upstream bug ticket mentioned in comment #1 now references ticket #17566 that has a fix for this issue.  The SVN log entry of this fix is available at: http://svn.php.net/viewvc?view=revision&revision=300434

I used this patch (downloaded from SVN) to build a new RPM for RHEL-6 Beta, which fixes this bug, indeed.
Comment 5 Fedora Update System 2010-09-30 15:02:19 EDT
php-pecl-memcache-3.0.4-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/php-pecl-memcache-3.0.4-4.fc14
Comment 6 Fedora Update System 2010-09-30 15:02:56 EDT
php-pecl-memcache-3.0.4-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/php-pecl-memcache-3.0.4-4.fc13
Comment 7 Fedora Update System 2010-09-30 15:03:45 EDT
php-pecl-memcache-3.0.4-4.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/php-pecl-memcache-3.0.4-4.fc12
Comment 8 Fedora Update System 2010-09-30 17:18:45 EDT
php-pecl-memcache-3.0.4-4.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update php-pecl-memcache'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/php-pecl-memcache-3.0.4-4.fc14
Comment 9 Fedora Update System 2010-10-05 13:47:31 EDT
php-pecl-memcache-3.0.5-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/php-pecl-memcache-3.0.5-1.fc14
Comment 10 Fedora Update System 2010-10-05 13:48:36 EDT
php-pecl-memcache-3.0.5-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/php-pecl-memcache-3.0.5-1.fc13
Comment 11 Fedora Update System 2010-10-14 02:30:56 EDT
php-pecl-memcache-3.0.4-4.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2010-10-21 01:58:02 EDT
php-pecl-memcache-3.0.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-10-28 02:12:15 EDT
php-pecl-memcache-3.0.5-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.