Bug 638887 - php-pecl-memcache extension broken due to a "protocol error"
php-pecl-memcache extension broken due to a "protocol error"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: php-pecl-memcache (Show other bugs)
6.0
All Linux
low Severity high
: rc
: ---
Assigned To: Joe Orton
qe-baseos-daemons
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-30 05:33 EDT by Robert Vogelgesang
Modified: 2011-05-19 10:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
The php-pecl-memcache package has been rebased to version 3.0.5 which fixes multiple bugs and adds one enchancement: the MemcachePool class now supports the "findServer" method.
Story Points: ---
Clone Of: 599305
Environment:
Last Closed: 2011-05-19 10:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Vogelgesang 2010-09-30 05:33:30 EDT
+++ This bug was initially created as a clone of Bug #599305 +++

Description of problem:

There's some sort of protocol error in what php-pecl-memcache is handing to the memcached daemon.

Version-Release number of selected component (if applicable):
php-5.3.2-4.el6.x86_64
php-pecl-memcache-3.0.4-3.2.el6.2.x86_64
memcached-1.4.4-3.el6.x86_64

For futher information, and a link to a patch that fixes this issue, please see the original Bug #599305 for Fedora.

Please update the php-pecl-memcache RPM for the final RHEL 6 release.
Comment 2 Robert Vogelgesang 2010-10-06 07:40:55 EDT
Upstream has released version 3.0.5 which contains the fix mentioned in Bugzilla #599305, so please upgrade to the latest release.
Comment 3 Joe Orton 2010-11-13 16:07:58 EST
Thanks for reporting this!  I'd propose to fix this by updating to 3.0.5.
Comment 4 RHEL Product and Program Management 2011-01-07 10:52:25 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 8 Joe Orton 2011-04-07 10:40:22 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The php-pecl-memcache package has been rebased to version 3.0.5 which fixes multiple bugs and adds one enchancement: the MemcachePool class now supports the "findServer" method.
Comment 10 errata-xmlrpc 2011-05-19 10:29:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0794.html

Note You need to log in before you can comment on or make changes to this bug.