Bug 599639 - udev rules broken for rawhide
udev rules broken for rawhide
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 642435
  Show dependency treegraph
 
Reported: 2010-06-03 12:47 EDT by Bastien Nocera
Modified: 2010-12-04 07:47 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 642435 (view as bug list)
Environment:
Last Closed: 2010-12-04 07:47:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2010-06-03 12:47:07 EDT
In the latest spec file:

# Remove permissions from udev rules, but register for ACL management
examples/hotplug -a"SYMLINK+=\"libmtp-%k\", ENV{ACL_MANAGE}=\"1\"" > libmtp.rules

Apparently ACL_MANAGE shouldn't be used in udev rules anymore, and broke gnome-bluetooth (see bug 588660 and the links near the end).
Comment 1 Linus Walleij 2010-06-05 05:36:29 EDT
OK edited the Fedora extenstion to remove this, built to
RawHide, is it working out?
Comment 2 Kevin Kofler 2010-06-08 19:00:43 EDT
Are you sure that just removing the ACL_MANAGE is sufficient? I think you'll have to set the TAG+="udev-acl" instead, as e.g. http://svn.debian.org/wsvn/pkg-gnome/desktop/unstable/gnome-bluetooth/debian/61-gnome-bluetooth-rfkill.rules or http://cvs.fedoraproject.org/viewvc/rpms/gnome-bluetooth/devel/61-gnome-bluetooth-rfkill.rules?revision=1.2&view=markup does.
Comment 3 Bastien Nocera 2010-06-08 20:47:22 EDT
Just removing ACL_MANAGE isn't enough, and apparently adding udev-acl is frowned upon. You'll need to ask Harald or upstream udev what to do in this case.
Comment 4 Linus Walleij 2010-06-09 19:30:44 EDT
OK now it says ENV{ACL_MANAGE}="0" TAG+="udev-acl"
But if adding udev-acl is frowned upon, then it's not good for
RFKill either I guess?

This is more than a bit idiomatic, is there some post I can
read up on the general idea of these strings and how it's
supposed to work these days...
Comment 5 Kevin Kofler 2010-06-09 19:34:48 EDT
ENV{ACL_MANAGE}="0" is incorrect. ENV{ACL_MANAGE}!="0" as an added condition would make sense.
Comment 6 Kevin Kofler 2010-06-09 19:36:13 EDT
(ENV{ACL_MANAGE}="0" is an assignment, not a condition, ENV{ACL_MANAGE}=="0" would be a condition, but the wrong one: if you check the gnome-bluetooth rules carefully, it SKIPS the block if ENV{ACL_MANAGE}=="0".)
Comment 7 Bug Zapper 2010-07-30 07:48:23 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 14 development cycle.
Changing version to '14'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Linus Walleij 2010-10-19 16:57:43 EDT
Well I don't know how to proceed with this because I just
don't know what to do. I obviously know too little about
udev to make use of the advice given here, please help.
A patch is very good help, for example...
Comment 9 Kevin Kofler 2010-10-31 18:38:39 EDT
With the current udev in F14, ACL_MANAGE is not used anymore at all, so just TAG+="udev-acl" is likely to work.

But as far as I understand, a proper long-term solution would be for the udev authors to add some ENV{ID_*} variable for each library which needs one so that libraries don't have to set that udev-acl tag themselves.
Comment 10 Linus Walleij 2010-12-04 07:47:55 EST
This is fixed in rawhide now, closing.

Note You need to log in before you can comment on or make changes to this bug.