This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 599712 - Net install doesn't recognize Broadcom 57780 (Dell OptiPlex 380)
Net install doesn't recognize Broadcom 57780 (Dell OptiPlex 380)
Status: CLOSED DUPLICATE of bug 602155
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-03 15:27 EDT by Larry Gilbert
Modified: 2010-06-11 13:15 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-11 13:15:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Larry Gilbert 2010-06-03 15:27:17 EDT
Description of problem:

The Dell OptiPlex 380 uses an integrated NIC based on the Broadcom 57780, normally handled by Linux's tg3 kernel module.  When using the netinstall CD-ROM for Fedora 13, the installation fails with an error saying that "no netork [sic] devices were found on your system."

Version-Release number of selected component (if applicable):

2.6.33.3-85.fc13.x86_64 (Thu May 6 18:09:49 UTC 2010)

How reproducible:

CD-R burned with Fedora-13-x86_64-netinst.iso (dated 2010-05-13); PC with Intel Core 2 Duo and Broadcom 57780 integrated NIC (such as Dell OptiPlex 380)

Steps to Reproduce:
1. Boot CD and follow through the graphical installation process.
  
Actual results:

Error window "Network Install Required" containing this text: "Your installation source is set to a network location, but no netork [sic] devices were found on your system. To avoid a network installation, boot with the full DVD, full CD set, or do not pass a repo= parameter that specifies a network source."

Expected results:

Detection of NIC and normal Fedora installation.

Additional info:

Recently when I installed Fedora 13 Beta on one of these machines with a full DVD, I had to tweak modprobe to load the broadcom kernel module before tg3 to allow the NIC to function.  It seems that the tg3 module depends on the broadcom module.  It is possible to load tg3 without broadcom, but then it does not function.

I have noticed that tg3.ko exists in the (release) netinstall image, but broadcom.ko does not.  I believe this is why the NIC detection is broken here.
Comment 1 Chris Lumens 2010-06-08 15:11:15 EDT
> I have noticed that tg3.ko exists in the (release) netinstall image, but
> broadcom.ko does not.  I believe this is why the NIC detection is broken here.    

The list of modules to include in the installation image is largely constructed from the modules.networking file.  If the broadcom.ko module is not being included, it's likely because it's not listed in modules.networking.
Comment 2 Larry Gilbert 2010-06-11 13:15:11 EDT
This is covered by a more recent ticket with more comments, bug 602155.

*** This bug has been marked as a duplicate of bug 602155 ***

Note You need to log in before you can comment on or make changes to this bug.