Bug 602155 - broadcom.ko module missing from F-13 installer
broadcom.ko module missing from F-13 installer
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
: 599712 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-06-09 05:34 EDT by Adam Huffman
Modified: 2010-07-23 07:14 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-23 07:14:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2010-06-09 05:34:08 EDT
Description of problem:

I have been trying to install F13 on a Dell T1500 workstation.  The NIC, a Broadcom BCM57780, is not initialised and so networking is not available during installation.

Here is the relevant dmesg output:

17:40:22,419 INFO kernel:tg3.c:v3.106 (January 12, 2010)
17:40:22,419 INFO kernel:tg3 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
17:40:22,419 DEBUG kernel:tg3 0000:02:00.0: setting latency timer to 64
17:40:22,423 INFO kernel:tg3 mdio bus: probed
17:40:22,423 WARN kernel:eth%d: No PHY devices
17:40:22,423 ERR kernel:tg3: Problem fetching invariants of chip, aborting.
17:40:22,423 INFO kernel:tg3 0000:02:00.0: PCI INT A disabled

and the lspci output:

02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
	Subsystem: Dell Device 0427
	Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Interrupt: pin A routed to IRQ 16
	Region 0: Memory at fbff0000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [48] Power Management version 3
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
		Status: D0 NoSoftRst+ PME-Enable- DSel=0 DScale=1 PME-
	Capabilities: [60] Vendor Specific Information: Len=6c <?>
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
		Address: 00000000feeff00c  Data: 49b0
	Capabilities: [cc] Express (v2) Endpoint, MSI 00
		DevCap:	MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
			ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
		DevCtl:	Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
			RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-
			MaxPayload 128 bytes, MaxReadReq 4096 bytes
		DevSta:	CorrErr+ UncorrErr- FatalErr- UnsuppReq+ AuxPwr+ TransPend-
		LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <1us, L1 <32us
			ClockPM+ Surprise- LLActRep- BwNot-
		LnkCtl:	ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
			ExtSynch- ClockPM+ AutWidDis- BWInt- AutBWInt-
		LnkSta:	Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
		DevCap2: Completion Timeout: Range ABCD, TimeoutDis+
		DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-
		LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-, Selectable De-emphasis: -6dB
			 Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
			 Compliance De-emphasis: -6dB
		LnkSta2: Current De-emphasis Level: -6dB
	Capabilities: [100 v1] Advanced Error Reporting
		UESta:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UEMsk:	DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
		UESvrt:	DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
		CESta:	RxErr- BadTLP- BadDLLP- Rollover- Timeout+ NonFatalErr+
		CEMsk:	RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
		AERCap:	First Error Pointer: 00, GenCap+ CGenEn- ChkCap+ ChkEn-
Capabilities: [13c v1] Virtual Channel
		Caps:	LPEVC=0 RefClk=100ns PATEntrySize=0
		Arb:	Fixed- WRR32- WRR64- WRR128- 100ns- - - onfig- TableOffset=0
		Ctrl:	ArbSelect=Fixed
		Status:	InProgress-
		VC0:	Caps:	PATOffset=00 MaxTimeSlots=1 RejSnoopTrans-
			Arb:	Fixed- WRR32- WRR64- WRR128- TWRR128- WRR256- Fixed- RR32-
			Ctrl:	Enable+ ID=0 ArbSelect=Fixed TC/VC=ff
			Status:	NegoPending- InProgress-
	Capabilities: [160 v1] Device Serial Number a4-ba-db-ff-fe-fa-dc-44
	Capabilities: [16c v1] Power Budgeting <?>

This seems like a reincarnation of https://bugzilla.redhat.com/show_bug.cgi?id=525966

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 David Woodhouse 2010-06-09 06:58:52 EDT
Does it work after installation? Are the required modules just missing from the install media?
Comment 2 Adam Huffman 2010-06-09 07:17:44 EDT
I haven't installed yet as there's a separate bug with partitioning (https://bugzilla.redhat.com/show_bug.cgi?id=601791) and I wanted to wait a couple of days to see if that could be fixed before wiping the disk.

The tg3 module is definitely present, it just doesn't work with that particular NIC, though I haven't tried removing and reloading it yet.
Comment 3 David Woodhouse 2010-06-09 08:09:18 EDT
The broadcom.ko module is missing from the install image.

Reassigning to anaconda.
Comment 4 Chris Lumens 2010-06-09 08:40:02 EDT
We add modules to the install image based on the modules being listed in the modules.networking file.  If the broadcom.ko module is not being included, that's likely why.
Comment 5 David Woodhouse 2010-06-09 10:54:46 EDT
Doh, sorry -- I used to know how this worked... and I rejoiced when it was shifted to the kernel; I should have remembered.

kernel-2.6.33.5-122.fc13 is building with this fixed. Not that it necessarily helps those with existing install images.
Comment 6 Andy Gospodarek 2010-06-09 14:31:18 EDT
It sounds like maybe broadcom.ko module (and possibly other phy modules) need to be added to the list of modules included in the installer initrd.  I think that is correct.

Switching component to anaconda.
Comment 7 Andy Gospodarek 2010-06-09 14:32:23 EDT
Sorry, I should read all the comments first. :-/
Comment 8 Larry Gilbert 2010-06-11 13:15:11 EDT
*** Bug 599712 has been marked as a duplicate of this bug. ***
Comment 9 Chuck Ebbert 2010-06-14 14:13:47 EDT
Fixed in 2.6.33.5-122.fc13 and 2.6.34-30.fc14
Comment 10 Adam Huffman 2010-06-14 18:23:13 EDT
I installed 2.6.33.5-124.fc13 on this box.  However, it still loaded the tg3 module for this NIC, not the broadcom one.  When I removed and then re-loaded tg3, the NIC was detected.
Comment 11 David Woodhouse 2010-06-14 19:28:29 EDT
Adam, tg3 is the correct NIC driver. broadcom.ko is the driver for the PHY. The tg3 driver requires the broadcom driver and should automatically load it.

Did you _need_ to remove and re-load tg3 before the NIC was detected and working properly? If so, please show your boot messages from _before_ you did so.
Comment 12 Adam Huffman 2010-06-15 06:05:47 EDT
Ah - thanks for the explanation.  Wondered why I hadn't heard of it before...

As I recall, yes I did need to remove and re-load it, though I won't have physical access to the machine until tomorrow.  I'll try and check this for you then.
Comment 13 Adam Huffman 2010-06-16 09:39:51 EDT
Having just tried, I can report that with the -124 kernel, the NIC was detected properly and working at boot.  There was no need to remove and re-load the module.
Comment 14 Nora 2010-06-21 13:26:24 EDT
I'm thinking of purchasing a Vostro 430 for CentOS 5.  But sounds like this defect is in both Fedora and RedHat, so I expect it will also be in CentOS 5.  Will the fix be in the RedHat libraries sometime soon ? TIA

Note You need to log in before you can comment on or make changes to this bug.